LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 05-28-2005, 09:48 PM   #1
dping
Member
 
Registered: Dec 2004
Location: Oregon, USA
Distribution: Kubuntu 9.04
Posts: 181

Rep: Reputation: 30
Mepis and US Robotics modem


I have an old computer with a "US Robotics 56k voice INT" internal ISA modem. When I boot Mepis dmesg tells me the modem is recognized, but I am having problems setting it up in kppp.

Running under the 2.6* kernel, when I run a "modem query" the resulting popup shows all the ATI fields empty (no communication) each time for every single ttyS device.

Running under the 2.4* kernel, the modem query popup tells me that the modem is not responding and times out.

I have tried changing the baud rates, unchecking the "lock file" option, and of course have tried all of the ttyS's.

How does one tell whether Mepis is assigning the modem to a ttyS device? (I am guessing it is not)
Could the problem be because the modem is an ISA unit?
Basically I'm not sure where to start debugging this.

The modem works fine under SUSE 9.1, so I don't think it is a winmodem.

Help??
 
Old 05-29-2005, 02:10 PM   #2
osvaldomarques
Member
 
Registered: Jul 2004
Location: Rio de Janeiro - Brazil
Distribution: Conectiva 10 - Conectiva 8 - Slackware 9 - starting with LFS
Posts: 519

Rep: Reputation: 34
Hi dping,

As your modem is an ISA, it's probably a hard modem. You need to discover where is it installed. You need to use "/bin/setserial" to find it, as root:
Code:
/bin/setserial -bg /dev/ttyS[0-9]*
This command will look for all /dev/ttyS* declared, showing the ones active. Keep in mind that its address can conflict with the on board serial devices.
Remember of this relation:
Code:
dos     Linux   I/O addr IRQ
---- ---------- -------- ---
com1 /dev/ttyS0    0x3f8  4
com2 /dev/ttyS1    0x2f8  3
com3 /dev/ttyS2    0x3e8  4
com4 /dev/ttyS3    0x2e8  3
If your modem has jumpers to program IRQ and your modem is found as /dev/ttyS2 or /dev/ttyS3 it's convenient to change its irq for, say, 5, which would be used by the second parallel port to prevent IRQ conflicts as this ports use the same irq from the first and second serial devices. Otherwise, you could disable one of the on board serial devices on the bios setup and use its address to access the modem.

This setserial command also serves to set the kernel to use it as another tty, using another IRQ. Remember that this command does not program the serial device; it just informs the kernel what address and irq must be used to access it. In this case you could put the command on /etc/rc.d/rc.local to setup your serial automaticaly on boot.

After identifying it, you should link it to "/dev/modem" and use it on kppp as kppp has not a good way to choose any serial line; the list it shows is a table compiled into the program.

Good luck!

Osvaldo.
 
Old 05-29-2005, 11:18 PM   #3
dping
Member
 
Registered: Dec 2004
Location: Oregon, USA
Distribution: Kubuntu 9.04
Posts: 181

Original Poster
Rep: Reputation: 30
Thanks.

I had run accross the setserial command in some searches, but didn't bother man'ing it and didn't guess how useful it was. That should get me going good.
 
Old 06-02-2005, 11:47 PM   #4
dping
Member
 
Registered: Dec 2004
Location: Oregon, USA
Distribution: Kubuntu 9.04
Posts: 181

Original Poster
Rep: Reputation: 30
Okay, here's some more. I had fun playing around with setserial and other commands I happened upon, but the mepis kernel is not detecting/setting-up the modem properly, so setserial is not much use.

Here is some dmesg output for more information. From both SUSE (which works) and Mepis (which doesn't).

both SUSE and Mepis:
Quote:
isapnp: Scanning for PnP cards...
isapnp: Card 'U.S. Robotics 56K Voice INT'
isapnp: 1 Plug & Play card detected total
SUSE:
Quote:
Serial: 8250/16550 driver $Revision: 1.90 $ 48 ports, IRQ sharing enabled
ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
pnp: Device 00:01.00 activated.
ttyS2 at I/O 0x3e8 (irq = 5) is a 16550A
Mepis:
Quote:
Serial: 8250/16550 driver $Revision: 1.90 $ 8 ports, IRQ sharing disabled
ttyS0 at I/O 0x3f8 (irq = 4) is a 16550A
ttyS1 at I/O 0x2f8 (irq = 3) is a 16550A
It looks like both distros recognize the device fine, but perhaps Mepis is not activating it?
Could this problem be related to ACPI? ACPI irq routing??
 
Old 06-03-2005, 10:05 AM   #5
dping
Member
 
Registered: Dec 2004
Location: Oregon, USA
Distribution: Kubuntu 9.04
Posts: 181

Original Poster
Rep: Reputation: 30
One more thing.

Under mepis, during the boot process isapnp says that it is setting up the modem at address 0x2f8 with irq 3 (ie: setting it up as ttyS1); however, ttyS1 does not work.

Last edited by dping; 06-03-2005 at 10:07 AM.
 
Old 06-03-2005, 12:58 PM   #6
osvaldomarques
Member
 
Registered: Jul 2004
Location: Rio de Janeiro - Brazil
Distribution: Conectiva 10 - Conectiva 8 - Slackware 9 - starting with LFS
Posts: 519

Rep: Reputation: 34
Hi Dping,

Good research! You have two alternatives. Go to the bios setup and disable onboard second serial port or, better, take a look in the differences between isapnp configuration on both systems. I believe there is a isapnp.conf in the "/etc/" directory.

Osvaldo.
 
Old 06-03-2005, 07:17 PM   #7
dping
Member
 
Registered: Dec 2004
Location: Oregon, USA
Distribution: Kubuntu 9.04
Posts: 181

Original Poster
Rep: Reputation: 30
There's the rub.

I'm guessing that suse is using isapnp, however, there is no isapnp.conf file in /etc/. When I run pnpdump it shows me what I believe is the effective isapnp.conf file, but strangely, only the lines that appear to identify the modem are uncommented, all of the lines that would define the irq, base address, etcetera remain commented out.

I tried changing the mepis isapnp.conf file to mirror the settings that suse is effectively using ( ttyS2, irq 5 ), but then after rerunning isapnp and using setserial to tell the kernel what I did there still isn't any reply from the modem when kppp queries it.

I will keep messing with things. I don't really want to change bios settings since the modem works under suse as is, but I may try it to see what happens. I will experiment more with isapnp.conf in mepis.

Thanks for the help!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
US Robotics modem ? MaaSTaaR Linux - Hardware 3 10-31-2005 04:35 AM
US Robotics modem Canadica Linux - Hardware 5 11-11-2004 04:18 PM
Is This US Robotics Modem a Good Modem to Buy? Trip in VA Linux - Hardware 2 11-03-2004 10:09 AM
us robotics modem and hsp modem on one system eagle0669 Linux - General 4 08-11-2004 03:03 PM
US Robotics Modem mfaisalkh Solaris / OpenSolaris 1 07-03-2004 07:52 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 01:44 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration