LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 04-28-2004, 08:23 PM   #1
TheRealDeal
Member
 
Registered: Jun 2003
Location: Central Coast, NSW, Australia
Distribution: Gentoo
Posts: 438

Rep: Reputation: 30
Measuring NIC input/output speed.


Hi all.

I've got a strange problem. I have a server with dual Broadcom (BCM5703) NIC's. I am getting a slow network performance from the server. With both the standard RH9 tg3 driver, and also when I install broadcom's RH9 drivers from the broadcom site.

We also use mrtg to monitor the input output of our linux servers. This particular server is saying that the NIC's inside are 10Mbps. Instead of 1000 like the others say.

Is there anything I can run locally on the server to see what actual speeds I am getting through my NIC's?

Thanks alot.

Regards,
Craig
 
Old 04-28-2004, 09:11 PM   #2
AutOPSY
Member
 
Registered: Mar 2004
Location: US
Distribution: Redhat 9 - Linux 2.6.3
Posts: 836

Rep: Reputation: 31
They are probably using auto negotiation.

What are the NIC's conneted to?
They can only auto negotiate speed dependent on their counterpart.
 
Old 04-28-2004, 10:03 PM   #3
TheRealDeal
Member
 
Registered: Jun 2003
Location: Central Coast, NSW, Australia
Distribution: Gentoo
Posts: 438

Original Poster
Rep: Reputation: 30
Thanks for the reply AutOPSY.

They are connected to a Gig Switch. The same ones that our other Gig servers are connected to and working fine.

Is there anyway I can turn off the auto negotiate? Or to try and force it to Gig?


Here is the output for ethtool on either network card. I can't notice anything wrong except for the "Speed" entry.

Settings for eth0:
Supported ports: [ TP ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Advertised auto-negotiation: Yes
Speed: 100Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: g
Wake-on: d
Link detected: yes


Settings for eth1:
Supported ports: [ TP ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Advertised auto-negotiation: Yes
Speed: 1000Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: g
Wake-on: d
Link detected: yes



Thanks alot again for you reply.

>Craig

Last edited by TheRealDeal; 04-28-2004 at 10:21 PM.
 
Old 05-08-2004, 04:55 PM   #4
krails
LQ Newbie
 
Registered: May 2004
Posts: 1

Rep: Reputation: 0
ethtool -h:
ethtool -s DEVNAME \
[ speed 10|100|1000 ] \
[ duplex half|full ] \
[ port tp|aui|bnc|mii|fibre ] \
[ autoneg on|off ] \
[ phyad %d ] \
[ xcvr internal|external ] \
[ wol p|u|m|b|a|g|s|d... ] \
[ sopass %x:%x:%x:%x:%x:%x ] \
[ msglvl %d ]

Do: ethtool -s eth0 autoneg off
and: ethtool -s eth1 autoneg off

Then do: ethtool -s eth0 speed 1000

Kevin
 
Old 05-09-2004, 05:30 PM   #5
TheRealDeal
Member
 
Registered: Jun 2003
Location: Central Coast, NSW, Australia
Distribution: Gentoo
Posts: 438

Original Poster
Rep: Reputation: 30
Hi Kevin,

Thanks alot for your reply. ethtool -s eth0 autoneg off worked fine. However, this is what I got when I tried the rest.

[root@Images root]# ethtool -s eth1 autoneg off
Cannot set new settings: Invalid argument
not setting autoneg
[root@Images root]# ethtool -s eth0 speed 1000
Cannot set new settings: Invalid argument
not setting speed


Would you know what would be wrong here?

Thanks alot again.

Regards,
Craig
 
Old 06-09-2004, 02:13 PM   #6
faither137
LQ Newbie
 
Registered: Jul 2003
Posts: 1

Rep: Reputation: 0
I experience the same problem on eth1. Does anyone know how to fix it?

RHEL ES 2.4.21-9.0.1.EL
Broadcom Gigabit Ethernet Driver bcm5700 with Broadcom NIC Extension (NICE) ver. 7.1.9c (01/23/04)

Much appreciated.
 
Old 06-18-2004, 01:53 PM   #7
ne1scott
LQ Newbie
 
Registered: Jul 2003
Distribution: Red Hat
Posts: 11

Rep: Reputation: 0
I would try setting the options in the /etc/modules.conf file for the bcm5700 driver. Using "man bcm5700" should show you all of the available options but I think the line you would want would be "options bcm5700 auto_speed=0 line_speed=1000 full_duplex=1" or to set 2 nic cards you would use "options bcm5700 auto_speed=0,0 line_speed=1000,1000 full_duplex=1,1". This would force the nic to obey 1000Mbit Full Duplex with auto negotiation turned off. Ethtools works from the command line but I had problems getting the options to stick upon reboot...even with the ETHTOOLS_OPTS defined in the ifcfg-eth? files. Since the bcm5700 driver supports this, it makes it a smoother solution.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Input/output error rob19 Linux - Newbie 14 08-21-2012 09:35 PM
Input/Output error new@linux Linux - Newbie 1 01-21-2005 07:59 AM
connection speed measuring Ninth Bit Linux - Networking 2 08-23-2004 04:26 AM
input/output error c12ayon Linux - Newbie 2 12-27-2003 07:04 AM
Input/Output error arctuniol Linux - Software 2 10-06-2003 05:35 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 01:08 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration