LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Measuring NIC input/output speed. (https://www.linuxquestions.org/questions/linux-networking-3/measuring-nic-input-output-speed-175737/)

TheRealDeal 04-28-2004 08:23 PM

Measuring NIC input/output speed.
 
Hi all.

I've got a strange problem. I have a server with dual Broadcom (BCM5703) NIC's. I am getting a slow network performance from the server. With both the standard RH9 tg3 driver, and also when I install broadcom's RH9 drivers from the broadcom site.

We also use mrtg to monitor the input output of our linux servers. This particular server is saying that the NIC's inside are 10Mbps. Instead of 1000 like the others say.

Is there anything I can run locally on the server to see what actual speeds I am getting through my NIC's?

Thanks alot.

Regards,
Craig

AutOPSY 04-28-2004 09:11 PM

They are probably using auto negotiation.

What are the NIC's conneted to?
They can only auto negotiate speed dependent on their counterpart.

TheRealDeal 04-28-2004 10:03 PM

Thanks for the reply AutOPSY.

They are connected to a Gig Switch. The same ones that our other Gig servers are connected to and working fine.

Is there anyway I can turn off the auto negotiate? Or to try and force it to Gig?


Here is the output for ethtool on either network card. I can't notice anything wrong except for the "Speed" entry.

Settings for eth0:
Supported ports: [ TP ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Advertised auto-negotiation: Yes
Speed: 100Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: g
Wake-on: d
Link detected: yes


Settings for eth1:
Supported ports: [ TP ]
Supported link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Supports auto-negotiation: Yes
Advertised link modes: 10baseT/Half 10baseT/Full
100baseT/Half 100baseT/Full
1000baseT/Half 1000baseT/Full
Advertised auto-negotiation: Yes
Speed: 1000Mb/s
Duplex: Full
Port: Twisted Pair
PHYAD: 0
Transceiver: internal
Auto-negotiation: on
Supports Wake-on: g
Wake-on: d
Link detected: yes



Thanks alot again for you reply.

>Craig :)

krails 05-08-2004 04:55 PM

ethtool -h:
ethtool -s DEVNAME \
[ speed 10|100|1000 ] \
[ duplex half|full ] \
[ port tp|aui|bnc|mii|fibre ] \
[ autoneg on|off ] \
[ phyad %d ] \
[ xcvr internal|external ] \
[ wol p|u|m|b|a|g|s|d... ] \
[ sopass %x:%x:%x:%x:%x:%x ] \
[ msglvl %d ]

Do: ethtool -s eth0 autoneg off
and: ethtool -s eth1 autoneg off

Then do: ethtool -s eth0 speed 1000

Kevin

TheRealDeal 05-09-2004 05:30 PM

Hi Kevin,

Thanks alot for your reply. ethtool -s eth0 autoneg off worked fine. However, this is what I got when I tried the rest.

[root@Images root]# ethtool -s eth1 autoneg off
Cannot set new settings: Invalid argument
not setting autoneg
[root@Images root]# ethtool -s eth0 speed 1000
Cannot set new settings: Invalid argument
not setting speed


Would you know what would be wrong here?

Thanks alot again.

Regards,
Craig

faither137 06-09-2004 02:13 PM

I experience the same problem on eth1. Does anyone know how to fix it?

RHEL ES 2.4.21-9.0.1.EL
Broadcom Gigabit Ethernet Driver bcm5700 with Broadcom NIC Extension (NICE) ver. 7.1.9c (01/23/04)

Much appreciated.

ne1scott 06-18-2004 01:53 PM

I would try setting the options in the /etc/modules.conf file for the bcm5700 driver. Using "man bcm5700" should show you all of the available options but I think the line you would want would be "options bcm5700 auto_speed=0 line_speed=1000 full_duplex=1" or to set 2 nic cards you would use "options bcm5700 auto_speed=0,0 line_speed=1000,1000 full_duplex=1,1". This would force the nic to obey 1000Mbit Full Duplex with auto negotiation turned off. Ethtools works from the command line but I had problems getting the options to stick upon reboot...even with the ETHTOOLS_OPTS defined in the ifcfg-eth? files. Since the bcm5700 driver supports this, it makes it a smoother solution.


All times are GMT -5. The time now is 10:40 AM.