Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Networking
User Name
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.


  Search this Thread
Old 08-26-2004, 12:03 PM   #1
LQ Newbie
Registered: Aug 2004
Posts: 3

Rep: Reputation: 0
mapping a NT 2000 share to a linux box

Hi--to begin, thanks for your help. Also: I'm a newbie.

I have successfully mapped a NT 2000 share to /mnt/music.

As linux root, I am able to read and write to the folder on the 2000 box both from the mount point and from a network browse (i.e. smb://sharing@windows2000/) .

As a user, however, I only have read access. Attempts to change the file attributes or ownership (while as root) fail, the error message saying that the smb protocol doesn't support changing file attributes or that root has insufficient access rights. I don't think that's the problem though....I have a suspicion that my mount technique is somehow incorrect. The files permissions on the 2000 machine are set for full read/write, so the problem isn't there.

Here is my fstab entry:
//windows2000/music /home/cm/music smbfs username=sharing,password=default 0 0

Any ideas how I extend read/write permissions to the user level?
Thanks, I will respond quickly with any additional needed info.

I'm using SUSE 9.1 Personal.
Old 08-26-2004, 12:22 PM   #2
Registered: Jan 2004
Location: Duesseldorf /Germany
Distribution: Gentoo amd64 / Debian
Posts: 226

Rep: Reputation: 30
Your Fstab is allmost correct:
//windows2000/music /home/cm/music smbfs username=sharing,password=default 0 0

but it should read:

//windows2000/music /home/cm/music smbfs username=sharing,password=default,user 0 0

The user option shows mount that it is ok for a user to invoke mount on this mount point.

Then the user (you) should be the owner of the directory (mount point) _before_
you mount the share,
so as root you must issue a "chown cm /home/cm/music"
I know this is a little confusing, but smbmount (which is allso called if you issue a "mount -t smbfs")
expects this for security reasons.

Now if you mount the share as root, root will be the owner of the share,
if you mount with your own user account, it's yours.

AFAIK it is not possible to change the file attributes on the remote server over a samba share,
but I could be wrong about this.

Another option would be to fidle around with umask,fmask and dmask,
you have to rtfm mount for this.
Old 08-26-2004, 01:35 PM   #3
LQ Newbie
Registered: Aug 2004
Posts: 3

Original Poster
Rep: Reputation: 0
thanks for the reply.

i have now changed the permissions and ownership for the mountpoint to the 'user' level.

is there a way to mount the samba share from boot so that users can read and write?? (this is my real question, i suppose).

i've tried the tips on, but they don't seem to be helping.

thanks for the help thus far--it's definitely got me back on track
Old 08-26-2004, 01:44 PM   #4
LQ Newbie
Registered: Aug 2004
Posts: 3

Original Poster
Rep: Reputation: 0
ok. problem solved! i'm so pleased in my naive, non-total-computer-geek way!! this was one of the final things pissing me off. next project: getting the ipod running

for those who may also be struggling with similar issues, this is the fstab line that finally got it done:

//ntcomputername/music /mnt/music smbfs username=sharing,password=default,rw,uid=billy,gid=users 0 0




Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
xp-box to share internet connection with linux-box CrazyHorse Linux - Networking 7 09-28-2006 11:05 PM
Mapping Linux box to XP Fully dson78 Linux - Networking 2 08-29-2005 12:42 PM
Mapping Linux box to XP Fully dson78 Linux - Newbie 1 08-28-2005 06:49 PM
Mapping a windows drive to a Linux box tbthorpe Linux - Networking 6 02-21-2005 01:48 PM
Linux box not able to join win 2000 domain jomy Linux - Networking 0 12-13-2004 02:59 AM > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 08:27 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration