LinuxQuestions.org

LinuxQuestions.org (/questions/)
-   Linux - Networking (https://www.linuxquestions.org/questions/linux-networking-3/)
-   -   Mandrake 7.2 and PCTEL HSP56 modem (https://www.linuxquestions.org/questions/linux-networking-3/mandrake-7-2-and-pctel-hsp56-modem-1086/)

stray 02-28-2001 03:03 PM

I'm a bit of a newbie but i installed Mandrake 7.2, and it was working pretty well overall except when trying to use it with my PCTEL win/linmodem. Downloaded drivers from http://www.linmodems.org as well as variances from a few other spots to no avail.

I compiled the pctel.o driver just fine, insmod pctel.o, and i can see the modem, etc. open up a terminal and dial out, but if i try to open a ppp connection kppp dials and tells me pppd died unexpectedly, then hangs the modem. I'd been looking for an updated version of the driver but there doesn't seem to be one. Am I missing anything or is there some sort of patch/fix that wouldn't involve trying to recompile the kernel?

Thanks
Miguel

CragStar 03-01-2001 05:44 AM

You make me so happy! Not because you can't connect but because I have at last met somebody with the same problem! (sorry, had to get it off my chest). I have the exact same config (mandrake 7.2, HSP56), and I also get the pppd died thingy. The reason I believe, if you have set up everything correctly, is that kppp doesn't like symbolic links. I say this because when you query modem, you get no response in the 'at' boxes. But you do get a response when you do it manually. There is actually a reference in the kppp docu that it doesn't like symbolic links too much.

What can you do?

You will probably have to use a different program to dial out. You should have minicom installed, so you may want to try that to dial out. Are you a UK user? If so I may have some dial-up scripts you can try.

There is a driver which is suited for the 2.4 kernel, so you may want to try to recompile the kernel from kernel source and then use the 2.4 driver. But I think it is more of a problem for kppp. You do have a symbolic link? (ie from /dev/ttyS15 to /dev/modem).

stray 03-03-2001 01:11 AM

The modem was linked to /dev/modem from /dev/pctel... ttyS15 was taken... tried linking to /dev/ttyS1 as well as ttyS15 (no serial ports on my machine) with no luck either...

I'd kinda set Mandrake on the back burner for a bit but would minicom allow me to dial a connection for pppd? If so I might give it a shot... didn't see it as part of the install but it might be an rpm.

Good to know I'm not the only one having this problem and thanks for the advice.

Miguel

CragStar 03-06-2001 05:09 PM

minicom has an option to allow you to dial anumber regardless and then you could invoke your pppd script or a script. However, I haven't had a load of success with this either! I have also tried wvdial (another dial-up program), and that too seems to have problems. Perhaps you should try writing a script for it all?

Search for minicom at http://www.rpmfind.net for all you rpm needs.


All times are GMT -5. The time now is 05:08 PM.