LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 06-10-2004, 02:30 PM   #16
Pete M
Member
 
Registered: Aug 2003
Location: UK
Distribution: Redhat 9 FC 3 SUSE 9.2 SUSE 9.3 Gentoo 2005.0 Debian Sid
Posts: 657

Rep: Reputation: 32

gslater

Quote:
you only need one entry in /etc/mail/local-host-names
gavinslater.com
otherwise sendmail will only let you send mail using gslater@linuxpc.gavinslater.com
Pete
 
Old 06-10-2004, 03:03 PM   #17
shmude
Member
 
Registered: Aug 2003
Distribution: Fedora, DSL, LAS, Knoppix
Posts: 83

Rep: Reputation: 15
Well we know that the email's are hitting your server and it is your server that is rejecting them. Im not the sendmail wiz here but look for something that has to do with relaying, and turn it off, so you can relay messages through it (not the safest, but just to see if it works). Then try to send another email to yourself.
 
Old 06-10-2004, 04:35 PM   #18
gslater
LQ Newbie
 
Registered: Feb 2004
Location: London
Distribution: Ubuntu
Posts: 20

Original Poster
Rep: Reputation: 0
Have taken out the other entries in etc/local-host-names...still the same problem

When you say look for something that has to do with relaying I presume you mean in the sendmail config program?

Will investigate and report back
 
Old 06-10-2004, 05:41 PM   #19
shmude
Member
 
Registered: Aug 2003
Distribution: Fedora, DSL, LAS, Knoppix
Posts: 83

Rep: Reputation: 15
Yes, in the sendmail config there should be a setting that allows your server to relay messages.
 
Old 06-11-2004, 07:43 AM   #20
linuxxed
Member
 
Registered: Feb 2004
Posts: 273

Rep: Reputation: 30
Quote:
Originally posted by gslater
Have taken out the other entries in etc/local-host-names...still the same problem

When you say look for something that has to do with relaying I presume you mean in the sendmail config program?

Will investigate and report back
Right this thread has elongated.

Have checked your domain and records look fine.

You are getting relaying denied because sendmail by default is anti relay i.e A cannot use B's server to send a mail to C without proper permissions.

This is allowed in relay-domains file or access file or you can configure your mail server to authenticate. See sendmail documentation on relaying.
 
Old 06-11-2004, 08:49 AM   #21
gslater
LQ Newbie
 
Registered: Feb 2004
Location: London
Distribution: Ubuntu
Posts: 20

Original Poster
Rep: Reputation: 0
I have tried looking in the sendmail.mc file for where the relaying is being denied but alas I cant really establish what part is causing it.

The only thing I changed in the sendmail.mc fiule when I started was to comment out the line:

DAEMON_OPTIONS('port=smtp,Addr=127.0.0.1, Name=MTA')dnl

...since I belive this will allow me to receive incoming mail from the internet.

Other than that the file remains intact from the original RH installation.

From doing some googling I think one other part of the file may be relevant but I'm not sure...it is:

FEATURE(relay_based_on_MX). Setting this feature permits relaying for any domain that is directed to your host.

Will changing this feature help?
 
Old 06-11-2004, 01:37 PM   #22
gslater
LQ Newbie
 
Registered: Feb 2004
Location: London
Distribution: Ubuntu
Posts: 20

Original Poster
Rep: Reputation: 0
one other thing which may indicate the cause of the problem.....

when I send an email to myself at anotheer account it says it was received from gslater@linuxpc.gavinslater.com rather than gslater@gavinslater.com

I have checked in /etc/mail/local-host-names and it shows gavinslater.com

when I run the command hostname though it shows as linuxpc.gavinslater.com

Could this be the problem

I am getting myself completely confused with this whole hostname issue and which files should include the hostname versus those that should just show the domain name....aaaaarrrrrgggghhh

Please help me keep my sanity!
 
Old 06-11-2004, 03:24 PM   #23
Pete M
Member
 
Registered: Aug 2003
Location: UK
Distribution: Redhat 9 FC 3 SUSE 9.2 SUSE 9.3 Gentoo 2005.0 Debian Sid
Posts: 657

Rep: Reputation: 32
Hi gslater

How's the headache ?

Ok

My /etc/hosts looks like this
127.0.0.1 server.mydomain.net server localhost.localdomain localhost
Command 'hostname' returns server

Changed it to
127.0.0.1 localhost.localdomain localhost
192.168.0.3 server.mydomain.net server mail www

Which is the way you said yours looks
Command 'hostname' returns server

So as far as I can see /etc/hosts is not the problem

Here's a new one for you just to confuse you even more, take a look at /etc/sysconfig/network mine looks like this does yours ?

NETWORKING=yes
HOSTNAME=server

Worth a try

Pete
 
Old 06-11-2004, 03:53 PM   #24
gslater
LQ Newbie
 
Registered: Feb 2004
Location: London
Distribution: Ubuntu
Posts: 20

Original Poster
Rep: Reputation: 0
Pete,

A glass of red wine seems to be helping....here is what /etc/sysconfig/network says:

NETWORKING=yes
HOSTNAME=localhost.localdomain

Should I change it?
 
Old 06-11-2004, 04:07 PM   #25
Pete M
Member
 
Registered: Aug 2003
Location: UK
Distribution: Redhat 9 FC 3 SUSE 9.2 SUSE 9.3 Gentoo 2005.0 Debian Sid
Posts: 657

Rep: Reputation: 32
Gavin

Please change it then come back and tell that 'hostname' returns linuxpc

NETWORKING=yes
HOSTNAME=linuxpc

This may be one problem solved, you will have to reboot to make the change take effect

Pete
 
Old 06-11-2004, 05:00 PM   #26
gslater
LQ Newbie
 
Registered: Feb 2004
Location: London
Distribution: Ubuntu
Posts: 20

Original Poster
Rep: Reputation: 0
Well....who would have thought....11pm on a Friday night (sad I know).....a few glasses of wine under the belt....a few less hairs on the head and hey presto I'm getting emails at long last.

In the end it was a matter of principle....this thing was not going to get the better of me.

Thanks a million to:

Pete M....especially for the final hurdle
Shmude
Linuxxed
OceanSurf
 
Old 06-11-2004, 05:12 PM   #27
Pete M
Member
 
Registered: Aug 2003
Location: UK
Distribution: Redhat 9 FC 3 SUSE 9.2 SUSE 9.3 Gentoo 2005.0 Debian Sid
Posts: 657

Rep: Reputation: 32
At last

You have mail

Pete
 
Old 06-11-2004, 07:55 PM   #28
shmude
Member
 
Registered: Aug 2003
Distribution: Fedora, DSL, LAS, Knoppix
Posts: 83

Rep: Reputation: 15
Good job, way to stick with it!
 
Old 06-12-2004, 07:48 AM   #29
linuxxed
Member
 
Registered: Feb 2004
Posts: 273

Rep: Reputation: 30
There's nothing like the sweet smell of success esp on un*x!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
What do i need to set up a mail server tomed Linux - Networking 3 11-05-2004 11:06 AM
what do i need to do to set up mail server feetyouwell Linux - Software 6 02-16-2004 01:08 PM
How do I set up a Mail Server jamie_barrow Linux - Newbie 8 07-21-2003 11:56 AM
Set up Mail server kelper Linux - General 1 05-12-2003 12:17 AM
How do I set up a mail server? ChaosX2 Linux - Networking 10 05-30-2002 03:48 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 10:00 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration