LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 10-15-2004, 03:11 PM   #1
Ansible
LQ Newbie
 
Registered: Jul 2004
Posts: 7

Rep: Reputation: 0
Machine rebooting when eth0 drops.


Lately, my linux box back home has been randomly rebooting. I run apache, torrentflux, ftpd, and sshd on it mainly, and often I will use it to route newsgroup traffic over ssh so I can access usenet at college. The problem started about a week ago, and no changes were made to the system before that time. The reboots seem to happen at random times, and often when I'm not even logged into the system. /var/log/messages shows lines like this:

Code:
Oct 15 13:52:16 obelisk kernel: eth0: link down
Oct 15 13:53:56 obelisk syslogd 1.4.1: restart.
Oct 15 13:53:56 obelisk syslog: syslogd startup succeeded
every time it reboots, so I am almost sure it has something to do with my ethernet connection dropping, but why would that cause the machine to reboot? When I go home this weekend I was planning to try a new ethernet card, and hopefully the different card with different drivers will fix the problem, but I'd still like to learn for learning's sake what is causing this.
 
Old 10-15-2004, 04:27 PM   #2
mritch
Member
 
Registered: Nov 2003
Location: austria
Distribution: debian
Posts: 667

Rep: Reputation: 30
is a watchdog running? checking connectivity?

sl mritch.
 
Old 10-15-2004, 05:11 PM   #3
Ansible
LQ Newbie
 
Registered: Jul 2004
Posts: 7

Original Poster
Rep: Reputation: 0
I am not aware of any such program, and I haven't noticed any while perusing processes. How would I check?
 
Old 10-15-2004, 06:14 PM   #4
mritch
Member
 
Registered: Nov 2003
Location: austria
Distribution: debian
Posts: 667

Rep: Reputation: 30
start the box. sync your drives. plug out the ethernet. wait...

sl mritch.
 
Old 10-15-2004, 06:25 PM   #5
Ansible
LQ Newbie
 
Registered: Jul 2004
Posts: 7

Original Poster
Rep: Reputation: 0
I just got home and messed with the box; I can unplug the cable or reboot my router with no problems. Maybe the kernel is unloading the ethernet module and faulting or something similar? I don't know quite how to check something like that. I did use apt-get to upgrade to a newer kernel last night, and the problem didn't go away as I had hoped.
 
Old 10-15-2004, 06:40 PM   #6
mritch
Member
 
Registered: Nov 2003
Location: austria
Distribution: debian
Posts: 667

Rep: Reputation: 30
ok. problem likely somewhere else.

well lets go back a bit. when did it start?
what kernel are you running? is it handrolled?

do a "lspci -v" and post your network card and any other device on the same irq channel. have you usb plugged in / when it happen?

sl mritch.

Last edited by mritch; 10-15-2004 at 06:41 PM.
 
Old 10-15-2004, 06:55 PM   #7
Ansible
LQ Newbie
 
Registered: Jul 2004
Posts: 7

Original Poster
Rep: Reputation: 0
I am running the SMP version of the kernel "Linux 2.6.8-1.521" that was installed via apt-get. The problem began while I was still using the kernel I orignally installed with Fedora Core 2, and like I said, no changes were made before the problem began. The lspci command didn't work so I can't post that, but all I have in the PCI slots is my network card and vidcard. I use no USB devices whatsoever. An interesting development that just happened, I turned off syslog, and about 20 minutes later my network connection dropped (gaim disconnected), while I am 99% sure other computers on the network stayed up. The computer did not reboot. However, I assume since the reboots were from syslogd, the computer did not reboot since that wasn;'t running. So not I just need to figure out why the network is dropping, or why syslogd is rebooting when the network does drop.
 
Old 10-15-2004, 07:40 PM   #8
mritch
Member
 
Registered: Nov 2003
Location: austria
Distribution: debian
Posts: 667

Rep: Reputation: 30
syslogd won't cause a reboot. a problem with klogd ..could be, but *very* unlikely also.

cat /proc/interrupts for irq assignment.
& dmesg | grep ACPI
what about usb?

since the msg about eth0 is the last one in your syslog, and your comp wont boot in less then 1.~min i rather think it's a hardware/driver issue with your nic. what brand/model is it anyway?

sl mritch.
 
Old 10-15-2004, 08:18 PM   #9
Ansible
LQ Newbie
 
Registered: Jul 2004
Posts: 7

Original Poster
Rep: Reputation: 0
Some ethernet info :

Code:
eth0: RealTek RTL8139 at 0xac00, 00:90:47:03:ac:54, IRQ 10
eth0:  Identified 8139 chip type 'RTL-8100B/8139D'
divert: freeing divert_blk for eth0
8139too Fast Ethernet driver 0.9.27
PCI: Found IRQ 10 for device 0000:00:0b.0
PCI: Sharing IRQ 10 with 0000:00:07.2
PCI: Sharing IRQ 10 with 0000:00:07.3
divert: allocating divert_blk for eth0
eth0: RealTek RTL8139 at 0xac00, 00:90:47:03:ac:54, IRQ 10
eth0:  Identified 8139 chip type 'RTL-8100B/8139D'
eth0: link up, 100Mbps, full-duplex, lpa 0x45E1
[code]

Code:
[mmuskne@obelisk mmuskne]$ cat /proc/interrupts
           CPU0
  0:   17729994          XT-PIC  timer
  1:      10372          XT-PIC  i8042
  2:          0          XT-PIC  cascade
  8:          1          XT-PIC  rtc
 10:    5167468          XT-PIC  uhci_hcd, uhci_hcd, eth0
 11:     118277          XT-PIC  VIA686A
 12:     198510          XT-PIC  i8042
 14:     136841          XT-PIC  ide0
 15:     308550          XT-PIC  ide1
NMI:          0
ERR:          0
dmesg:
Code:
 BIOS-e820: 000000001fff0000 - 000000001fff3000 (ACPI NVS)
 BIOS-e820: 000000001fff3000 - 0000000020000000 (ACPI data)
ACPI disabled because your bios is from 2000 and too old
ACPI: Subsystem revision 20040326
ACPI: Interpreter disabled.

Last edited by Ansible; 10-15-2004 at 08:20 PM.
 
Old 10-16-2004, 04:35 AM   #10
mritch
Member
 
Registered: Nov 2003
Location: austria
Distribution: debian
Posts: 667

Rep: Reputation: 30
i have some rtl8193 nics and never had trouble with the driver.
as you see in your irq list, usb is using the same interrupt. mostly no problem, but i suggest moving them away (may be this can be changed in the bios or plug your nic in another pci slot [5,7,9]).

sl mritch.
 
Old 10-16-2004, 01:47 PM   #11
Ansible
LQ Newbie
 
Registered: Jul 2004
Posts: 7

Original Poster
Rep: Reputation: 0
Ran into a problem this morning. I swapped the NIC to a different slot to change the IRQ, and now the system still recognizes it, but eth0 refuses to come up. I tried a different NIC, different kernel, deleted and remade eth0, but it still does not come up. If I use dhcp it never finds an address, and if I use static IP, when I try to go to any site it doesn't get past DNS, even if I type in an IP (for my router) I get "connection refused". In /var/log/messages I am seeing tons of NETDEV WATCHDOG errors.

This may be related, around that time I also played with APCI=force since my BIOS was old enough that the kernel didn't automatically accept it. I ended up turning it back off, but it seemed the problem started after that first boot.

--edit

I moved the network card to the only slot I hadn't tried, still didn't work.. so I swapped the network cable to a different port on the rotuer and it's fine. That was crazy, I guess I blew out one of my network ports.

Last edited by Ansible; 10-16-2004 at 02:16 PM.
 
Old 10-16-2004, 03:39 PM   #12
mritch
Member
 
Registered: Nov 2003
Location: austria
Distribution: debian
Posts: 667

Rep: Reputation: 30
do you think it's your router?

if not:
doublecheck your setup. "netdev watchdog" (i was looking for something like this before. look at your lsmod output to see what you've loaded) and the problems you told me tells me that there might be something misconfigured.

acpi is critical here since it can overwrite bios pnp and takes care for proper irq routing/assignment. at my home pc it also refuses to work without the force setting but lucky as i'm, everything is fine (old, but intel (acpi is, de facto, a intel standard) :).
there are some acpi options that might be helpful* for you, but if you want let us start new here:

i'd suggest to get the kernelsource (i'd say the last 2.4 from your distribution), build a kernel for your needs and get the system running. i'll assist you if you're unfamiliar with.

*/usr/src/<kernel-version>/Documentation/kernel-parameters.txt


sl mritch.

here is one that might help:
use the acpi=ht option to disable everything not needed for hypertrading.

Last edited by mritch; 10-16-2004 at 03:42 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Mandrake 10 Official drops eth0 configuration cabinetcrafter Mandriva 10 10-11-2004 09:32 AM
Rebooting Locked up Linux Machine? matt80 Linux - General 6 05-19-2004 10:35 AM
eth0 drops connection intermittently JLDixon Linux - Networking 5 09-28-2003 05:27 PM
Network Drops Out on eth0 dkranendonk Linux - Networking 1 05-11-2002 01:24 AM
linux machine rebooting begeek Linux - General 0 04-24-2002 01:58 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 07:56 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration