-   Linux - Networking (
-   -   Machine gets IP from DHCP but can't see the world (

JoAnywhere 10-27-2003 01:59 PM

Machine gets IP from DHCP but can't see the world
Hi there all,
if you've been following my saga, you'll know I've been trying to get an ADMTEK8211 based card working under debian. Eventually I gave up in disgust as part of the driver is not open source, and it was causing version conflicts and breaking debian. The good news on THAT particular front is that they will be releasing the full driver to Open Source in the near future (next two-three weeks). I hope my bitching at them in some small part helped facilitate this :)

So, I blew my debian install away, and installed redhat 7.3. This installed just fine. Then I installed the drivers for the network card (they came with a nice precompiled rpm for redhat). This also worked pretty damned well!!!!

So, my wireless NIC now goes to my Access Point and gets an IP Address (so I know DHCP is working). The address seems sane (I only have 2 other machines on the network, and know the IP address of those are and, so when the linux machine came back with that seems pretty reasonable :) )

At this point, I thought I had it in the bag.. but NO!!!

I can't see the web, I can't ping or anything. I tryed to ping my router/WAP which I know is I got destination host unreachable. I tried pinging to another machine on the network ( and got the same error.

What on earth have I missed this time?


dlm4444 10-27-2003 02:03 PM

do an ifconfig

JoAnywhere 10-27-2003 02:06 PM


Originally posted by dlm4444
do an ifconfig
and then what?

I type

ifconfig eth0
and it gives me info on my card

all of which seems sane.

Now what?


kongfanzhao 10-28-2003 12:42 AM

sounds like an error of "media disconnected".
I assure you that if you type

#ifconfig eth0 down
#ifconfig eth1 up

you couldn't get an IP address from your DHCP Server.
if you do get an IP address from your DHCP Server, you
can ping your surely.

JoAnywhere 10-28-2003 09:44 AM

I am not a total fool
I did get my NIC working in the end.

However, please rest assured - if I tell you it gets an IP address, but yet cannot ping, then this is (or was) the case.


horlix 10-28-2003 12:43 PM

post how you solved your problem so that others searching the forum with similar problems can benefit :-)

Ginux 10-28-2003 02:54 PM

Redhat has an issue with the kernel, upgrading the kernel throu RH update and it solved my problem.
(I'm running RH9 btw.)


kongfanzhao 10-28-2003 07:28 PM

please post your kernel version number and the result of executing "route -n" and "lsmod".

please tell us your wireless NIC's type and if necessary please reinstall PCMCIA-cs at

All times are GMT -5. The time now is 11:15 AM.