LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 12-14-2003, 09:27 AM   #16
boemitsu
LQ Newbie
 
Registered: Dec 2003
Location: Zurich
Distribution: slackware 9.1, mandrake 9.1
Posts: 17

Original Poster
Rep: Reputation: 0

@ugob
I googled around 4 hours _before_ I posted this thread, therefore I already read your proposed link. posting in a forum is always the last solution for me....

-rws--x--x 1 root bin 31088 Sep 25 03:10 /bin/ping*

I can ping anywhere (google.com) but not localhost, not even the ip-adresses bound to the nic's

root@m3:~# ping 192.168.1.1
PING 192.168.1.1 (192.168.1.1) 56(84) bytes of data.
ping: sendmsg: Operation not permitted

--- 192.168.1.1 ping statistics ---
1 packets transmitted, 0 received, 100% packet loss, time 0ms

root@m3:~# ping 80.219.41.x
PING 80.219.41.x (80.219.41.x) 56(84) bytes of data.
ping: sendmsg: Operation not permitted

--- 80.219.41.x ping statistics ---
1 packets transmitted, 0 received, 100% packet loss, time 0ms


I just installed slackware 9.1 over nfs (nfs server is mandrake 9.1) which didn't cause any problem. I didn't install anything else but the original files from the slackware distro.


@davidphilips
I also tried ldconfig, but without any effects....below the output of nsswitch.conf and host.conf

root@m3:~# cat /etc/nsswitch.conf
#
# /etc/nsswitch.conf
#
# An example Name Service Switch config file. This file should be
# sorted with the most-used services at the beginning.
#
# The entry '[NOTFOUND=return]' means that the search for an
# entry should stop if the search in the previous entry turned
# up nothing. Note that if the search failed due to some other reason
# (like no NIS server responding) then the search continues with the
# next entry.
#
# Legal entries are:
#
# nisplus or nis+ Use NIS+ (NIS version 3)
# nis or yp Use NIS (NIS version 2), also called YP
# dns Use DNS (Domain Name Service)
# files Use the local files
# [NOTFOUND=return] Stop searching if not found so far
#

# passwd: files nis
# shadow: files nis
# group: files nis

passwd: compat
group: compat

hosts: files dns
networks: files

services: files
protocols: files
rpc: files
ethers: files
netmasks: files
netgroup: files
bootparams: files

automount: files
aliases: files


root@m3:~# cat /etc/host.conf
order hosts, bind
multi on



I am getting crazy about this prob...maybe just reinstall it once...?!
 
Old 12-15-2003, 12:59 AM   #17
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
try this

in /etc/hosts put

127.0.0.1 localhost.localdomain localhost

the resolver should be looking at /etc/hosts by the looks of it.
 
Old 12-15-2003, 05:58 AM   #18
boemitsu
LQ Newbie
 
Registered: Dec 2003
Location: Zurich
Distribution: slackware 9.1, mandrake 9.1
Posts: 17

Original Poster
Rep: Reputation: 0
well, I tried some different settings in /etc/hosts.

# For loopbacking.
127.0.0.1 localhost.localdomain localhost

# End of hosts.

or

# For loopbacking.
127.0.0.1 localhost.localdomain localhost m3

# End of hosts.


when I ping m3, it gives me
root@m3:~# ping m3
PING localhost.localdomain (127.0.0.1) 56(84) bytes of data.
ping: sendmsg: Operation not permitted
ping: sendmsg: Operation not permitted

--- localhost.localdomain ping statistics ---
2 packets transmitted, 0 received, 100% packet loss, time 1017ms

same with localhost.localdomain and only localhost...
 
Old 12-17-2003, 04:00 PM   #19
boemitsu
LQ Newbie
 
Registered: Dec 2003
Location: Zurich
Distribution: slackware 9.1, mandrake 9.1
Posts: 17

Original Poster
Rep: Reputation: 0
Lightbulb iptables

my solution

iptables -t nat -F
iptables -t nat -X
iptables -t nat -P POSTROUTING ACCEPT

and everything was perfect....

i would have saved much time if i also printed the output of

iptables -t nat -L -v instead of only
iptables -L -v

well, for next time..


anyway...thx for taking time !
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Change localhost name in username@localhost n175uj Linux - Newbie 4 07-01-2005 08:25 PM
apache http://localhost/mysite ---> http://localhost/mysite/index.php how? ilnli Linux - General 8 06-04-2005 03:23 PM
Message from syslogd@localhost localhost kernel: Disabling IRQ #21 ylts Linux - Hardware 0 02-26-2005 08:01 AM
dns requests from localhost to localhost keex Linux - Networking 2 11-13-2003 01:47 PM
Telnet localhost and telnet not from localhost for IMAP services seb77 Linux - Networking 1 10-15-2003 01:20 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 05:20 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration