Download your favorite Linux distribution at LQ ISO.
Go Back > Forums > Linux Forums > Linux - Networking
User Name
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.


  Search this Thread
Old 11-04-2002, 10:07 PM   #16
Senior Member
Registered: Apr 2002
Location: Arbovale, WV
Distribution: Slackware
Posts: 1,759

Rep: Reputation: 78

The link got hosed some how, so here it is agian
Old 11-04-2002, 10:08 PM   #17
Senior Member
Registered: Apr 2002
Location: Arbovale, WV
Distribution: Slackware
Posts: 1,759

Rep: Reputation: 78
Screw it just click on the link to me webstie in my profile. Then click on computer on top.
Old 12-02-2002, 10:51 AM   #18
Registered: Dec 2001
Location: Chester, GBR
Distribution: Mostly Ubuntu
Posts: 48

Rep: Reputation: 15
If it's any help, I had REAL trouble with samba and win2k/winXP because of changes in rpc's from samba v1.x to v2.x.

The resolution was to use
'nt smb support = no'
'nt pipe support = no'
in smb.conf
Old 12-15-2002, 02:26 PM   #19
LQ Newbie
Registered: Dec 2002
Posts: 3

Rep: Reputation: 0

This is a quick and easy fix. Place this in /etc/samba/ as smb.conf then run service smb restart.
This works in my mixed win2k,winXP, RH7.2, RH 8.0 environment.
Good luck and merry Xmas,


# Global parameters
netbios name = "server name"
workgroup = "your workgroup"
server string = Samba Server
security = SHARE
encrypt passwords = Yes
map to guest = Bad User
log file = /var/log/samba/log.%m
max log size = 50
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192
guest account = root
hosts allow = "ip range first 3 octets" 127.

comment = / directory
path = /
read only = No
guest ok = Yes

Last edited by mcontatore; 12-15-2002 at 02:30 PM.
Old 12-15-2002, 10:57 PM   #20
LQ Newbie
Registered: Dec 2002
Location: Urumqi in China
Distribution: debian redhat
Posts: 15

Rep: Reputation: 0
/etc/rc.d/rc3.d/Sxsmb start
mabye samba not start ok.
what's you see ?Better to see error log .
Old 01-17-2003, 01:51 AM   #21
LQ Newbie
Registered: Mar 2002
Location: Perth, WA
Distribution: Gentoo, ubuntu, BeatrIX, Knoppix, RedHat <= 9, Solaris 8
Posts: 17

Rep: Reputation: 0
This sounds like a similar problem I had with Samba on a Sun box. I had posted this problem sometime back in the Sun section.

"The cmd line utility smbpasswd kept giving errors."

Anyway, this is what I did that made it work. Perhaps you can try it too.

I installed the Webmin administration tool and used it to configure Samba. I also (re)-set each user's password through Webmin - after this samba sorked fine.

Since the Webmin interface was able to do set the samba password, Samba started working perfectly.

Last edited by sean_pereira; 01-17-2003 at 01:54 AM.
Old 01-31-2003, 10:43 AM   #22
Registered: Nov 2001
Distribution: Mandrake 8.2
Posts: 97

Rep: Reputation: 15

I run 2 Linux boxes an a mixed Windows 2000, Win98 and Mac network.

If you look at your message:

share disk Linux share space
dne disk
guest disk
user disk
IPC$ IPC IPC service (Samba)

The IPC$ is a password problem. When you make a add a user to Linux and you are running Samba, you need to run smbpasswd to add that user and password to Samba. If you do not you will get a login error and password error - this is especially true in Windows 98, moreso than 2000.

Anytime you see an IPC$ message on a Windows machine logging into Linux, first check your Samba users and passwords.
Old 01-31-2003, 11:27 AM   #23
Registered: Jan 2003
Location: Dallas, TX
Distribution: Fedora Core 4
Posts: 420

Rep: Reputation: 30

I regret that I can't help you any on this because I'm a much bigger newb at this than you are. I did see that you mentioned a Gnome Samba browser. Is that included with Samba, or do you have to install it separately? How do you start it and what's it called and such?

Old 07-02-2003, 02:55 AM   #24
LQ Newbie
Registered: Jan 2003
Distribution: Debian, FreeBSD, Redhat, geentoo and others.
Posts: 1

Rep: Reputation: 0
Try this at the /etc/samba/smb.conf

netbios name = yourmachinename
workgroup = workgroupname
server string = machine description
security = share
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192

Note : this is the minimum setup without any security protection .. but this is the easy way to setup. Besides, you can start sharing with the following option : -

comment = just put any comment at here or no is fine..
path = /home/share_directory
public = yes
writable = yes
create mask = 0765

before try this, u have to create a share directory at /home/share_directory and chmod on this directory.. to 777.

Just remember this is good testing and getting a result faster, but always not recommend putting in to organization.. bcos no security at all, it will just like u make a full share access in win98 with no user control right.

Have fun.
Old 07-02-2003, 03:05 AM   #25
Registered: Aug 2002
Location: England
Distribution: Gentoo
Posts: 38

Rep: Reputation: 15
I had the same problem, try this:

# New Samba Config File

# Global Parameters


netbios name = NAME_OF_THIS_COMPUTER
encrypt passwords = yes
log level = 3
log file = /usr/local/samba/var/samba.log
wins support = yes

# Shared Folder Details

path = /path_to_share
browseable = yes
writeable = yes
public = yes
Hope that helps


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Ms Win2000 Server & Linux NIS Server ON the same network. tulip4heaven Linux - Networking 3 07-26-2005 07:35 PM
Network Between Win2000 And Redhat9 Linux MeMo Linux - Networking 3 06-10-2004 08:54 AM
Installed SAMBA and XP or Win2000 can access Linux Share! Please Help. NYAndy Linux - Newbie 3 02-29-2004 09:29 AM
Samba printing: Linux Client to Win2000 Server GutterBall Linux - Networking 3 10-23-2003 04:44 PM
How can i network linux and win2000 Apollo_440 Linux - Networking 4 03-26-2003 11:11 PM > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 08:20 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration