-   Linux - Networking (
-   -   linux permission works fine for one internal hard drive but not for the other? (

gtrrockz84 07-24-2012 08:40 AM

linux permission works fine for one internal hard drive but not for the other?
Hi All,
I have 5 internal hard drives in my server and the smallest one has linux mint cinnamon installed.

i have 3 "2 TB" (named P, P-backup, R) and 1 "1 TB" hard drive (named U). the OS is in a 500GB hard drive.

my P drive works great. i told only user and group can have rwx and others read only. No issues here.

my R and U drives cannot be accessed at all from pc machines. when they try to map them it says access denied. i have no clue why. i made my linux and samba say read only for everyone then i tried rwx for everyone but still when they try to map it, the pc's say access denied you need permission.

p drive on the other hand works perfect. i even tried copy pasting the p drive lines in the smb.conf file and paste for the share for R drive (changing the path ofcourse) and still doesnt work.

im confused. please help. thanks

Chirel 07-24-2012 12:06 PM


Could you elaborate please ?

On the server side what is the os & smb server ? how do you share what ? you could maybe paste config files.

On the client side what is the os ? how do you mount the share ? maybe you can paste the used command ?

gtrrockz84 07-24-2012 12:23 PM

I use linux mint cinnamon and share using samba. pc's are of different os ranging from xp to vista to windows 7. im trying to make a folder called 'Library' located in R drive to be accessed by all.

i prefer to have read only for everyone except owner and group for the library folder.

"mounting the folder on pcs" i just map it using "map network drive".


        server string = %h server (Samba, Ubuntu)
        username map = /etc/samba/smbusers
        unix password sync = Yes
        syslog = 0
        log file = /var/log/samba/log.%m
        max log size = 2000
        dns proxy = No
;        idmap config * : backend = tdb
        workgroup = workgroup
        security = user
;        encrypt passwords = yes
;        guest ok = no
;        guest account = nobody

        comment = All Printers
        path = /var/spool/samba
        create mask = 0700
        guest ok = Yes
        printable = Yes

        comment = Printer Drivers
        path = /var/lib/samba/printers
        guest ok = Yes

        path = /media/P-drive/Projects
        read only = No
        create mask = 0777
        directory mask = 0777
        inherit permissions = Yes
        inherit owner = Yes

        path = /media/R-drive/Library
;        writeable = no
;        browseable = yes
        valid users = kevin, janice

suicidaleggroll 07-24-2012 07:14 PM

How are the drives formatted and how are they being mounted? Is it possible you're actually mounting the R and U drives in read-only mode?

gtrrockz84 07-25-2012 08:09 AM

i mount the drives through disk utility. they are both ext4 formatted. how can i find out if its mounted in read only mode? i tried chmod couple of times 775 and 777 but no use. i tried chmod 777 and read and write in samba it still cannot be accessed by the pcs. the problem is i cant even access it through the pc, it says access denied.

gtrrockz84 07-26-2012 08:37 AM

Any help would be much appreciated. Thanks!

Reuti 07-31-2012 03:52 AM

The output of mount will tell you whether itís mounted read only (will show up as ro).

Is the problem that they canít access it at all, or not writable?

gtrrockz84 07-31-2012 11:36 AM

Reuti, thanks for your reply. They cannot access it at all. When they try to map it from their pcs a warning message comes up saying windows cannot access \\server\library. please check the spelling... your network.... all that stuff. so im not sure why its not able to see this drive at all. Also how do you check the output of mount? thanks.

ilesterg 07-31-2012 08:30 PM


Originally Posted by gtrrockz84 (Post 4742288)
Also how do you check the output of mount? thanks.

Your server is Mint Cinnamon, right? open up a terminal end enter


All times are GMT -5. The time now is 06:16 PM.