-   Linux - Networking (
-   -   linux gateway/firewall with MASQUERADE (

willix 08-06-2002 03:41 PM

linux gateway/firewall with MASQUERADE
Hi all--
I'm pretty new to Linux, so bear with me please! I am trying to set up my Red Hat 7.3 box to be a firewall/gateway for an internal subnet (really only one Windows 2000 machine in the network). I have read several tutorials on firewall software and IP Masquerade and it seems that my best options would be to use Iptables for the firewall and Masquerading since my connection to the Internet is dchp (cable modem). I have set up two NICS and built a pretty decent firewall that won't allow much of anything.

My problem is this..
No matter what I do I can't get the Windows machine to talk to the linux gateway machine. I get no LED lights on the second NIC. Here is the summary of the configuration:

*both NICs are verified to be in working order

eth0 =>dhcp from cable modem
eth1 =>static assigned IP
IPforwarding is set to true (1)
rules exist in Iptables such that:
all chains drop everything by default
iptables --table nat --append POSTROUTING -o eth0 -j MASQUERADE
iptables -A FORWARD -i eth1 -j ACCEPT

my routing table looks like this:
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface U 0 0 0 eth1 U 0 0 0 eth0 U 0 0 0 lo UG 0 0 0 eth0

I can ping the eth1 NIC at
If I ping to (the windows box static IP) it gives me destination host unreachable.

running tcpdump listening on eth1 shows no packets when I ping, but shows packets when I try to ping the subnet machine past that point ( tcp dump listening on eth1 shows no packets when I boot the windows pc's network service. I thought for sure it was a firewall rule problem for the Windows box (boot pc maybe?) but since there were no packets traversing eth1 from the subnet, I can rule that out right??

The Windows box gets:
gateway is eth1 in linux box=
dns is my isp dns server

I thought that maybe it was the firewall blocking packets, so I turned it to accept all packets, but still had the same problem. No ping to the subnet, no link lights on the second NIC, and the Windows box thinks the network cable is unplugged when I start networking.

Does anyone have any suggestions? I've gone through 4 or 5 tutorials on iptables/masquerading/networking with 2 NICS, and tried a few other rule configurations, but pretty much nothing I tried is any different. The windows box just won't find the network. I have been told that even without forwarding and Masq. running I should be able to ping the Windows box from the Linux gateway.

I sure appreciate any help, it is a real pain running a software firewall on that windows machine. Norton Personal Firewall is killing me with all the question pop-ups it asks me all the time!

Will B.

chaste 08-06-2002 04:19 PM

Hi Will,

I can't help, but just so that you don't feel so alone I'm in the same situation!

If you check out my other posts I've had some great help from a few guys and it may help your problem, even if I haven't quite sorted my own problems out!

I'll be monitoring this thread as well!


willix 08-06-2002 05:37 PM

Thanks. I'll dig through your posts and hopefully between them and what I've already tried I can find the solution.

I appreciate it.

All times are GMT -5. The time now is 11:49 PM.