-   Linux - Networking (
-   -   Linux clients, Solaris NFS server (

wiskic10_4 12-22-2004 11:22 AM

Linux clients, Solaris NFS server
I've got a server running Solaris 9, and several workstations running various *nix OSs - namely Solaris 8 & 9, Debian 3.0 and Slackware 10.0... I keep my users' home directories on the server. This setup works wonderful on my Solaris boxes... they mount the remote directory in a milisecond... However, my Linux boxes seem unable to mount anything remotely from the Solaris machines... I've tried passing various wsize/rsize paramaters through the mount command, but that hasn't worked... I've Googled for about 3 hrs. now, but I just can't seem to find a solution... Any ideas???

BTW, the server is a SPARC III, and the Linux boxes are Pentium 4's and SPARC IIis ... I shouldn't think that this is a hardware issue, though - both Solaris and Linux recognize nfs

Linux.tar.gz 12-22-2004 12:44 PM

Perhaps a hosts.allow problem.
Perhaps a portmapper problem.
Did rpc.portmap is running on the Slack box?

sigsegv 12-22-2004 01:00 PM

Also -- Are both the Solaris and Linux boxes using the same version of the NFS protocol? There's an option to the mount command to specify what version of the protocol to use, though I forget what it is at the moment.

wiskic10_4 01-05-2005 03:17 PM

Sorry I took so long to get back... thank you for the replies...

However, I've still had no luck --> it actually will mount the nfs partition, but it takes five and a half minutes (seriously - I timed it)... this simply will not do... I've tried various options (wsize,rsize,nfsvers,proto,etc.)... no dice.

As I've said, it works fine on my Debian boxes which are using the same kernel as the rest of the linux boxes - however, the Debian boxes are SPARCs, like the server...

Something still tells me that this isn't a hardware issue, though...

Any Ideas??? --> I've done some Googlin - apparently I'm not the first to experience this problem!


[edit] forgive me --> I didn't say that the Debian SPARC boxes worked in my original post... that discovery was more recent...[/edit]

wiskic10_4 01-07-2005 07:31 AM

No ideas, eh... Well, I'm going to try mounting from the Debian boxes w/ the x86 boxes... will post back...

ulfhaga 07-05-2006 01:56 AM

Try to mount with mount option tcp. Example mount -t nfs -o tcp hostnameToSolaris9:/home/xxx /tmp/test
or mount -t nfs -o rsize=8192,wsize=8192,nfsvers=2,intr,tcp hostname1:/home/xxx /tmp/test
Without the tcp option I didn't worked.

All times are GMT -5. The time now is 01:00 AM.