-   Linux - Networking (
-   -   Linux box connects intermittantly to network -- WIERD problem (

ckr 07-12-2006 10:19 AM

Linux box connects intermittantly to network -- WIERD problem
Hi all,
Just to start, this problem occured with mandriva 2006 and still occured with the latest ubuntu. The box is dual boot, and windoze does NOT have this problem.

Lanparty nf4 ultra MB
AMD 64 3800+
onboard lan
NVidia chipset on the MB.
Ubuntu (2.6 kernel)
Latest nforce drivers for MB.
Firefox 1.5

Here's the deal: When I go to a web page, even though I can ping the page, often, firefox will say done, but the page will be blank. If I get, say, google to come up, then type in a search, I get a blank page, but then the address bar reads:

This will happen if I click on links sometimes as well, with any web page. Sometimes the page comes up, sometimes it's just a blank page, and sometimes I get the /?f at the end of the url.

None of the windoze boxes on my network do this, but the really nasty thing is that my server, which has been up and running over a year (P3-450, mandrake 10) has started doing this as well. And it's worked fine for over a year.

This leads me to believe that it could be the router, but if it was, then the windoze boxes should be doing this too, and they're not. Plus, I haven't changed anything in the router for a long, long time.

Oh yeah, and even though it takes a long time, when I can't get a web page to come up, I can still ping the page.

Any ideas?

Thanks for any help!

opioid 07-12-2006 11:34 AM

Wow, where to start. Have you tried looking at /var/log/messages?

ckr 07-12-2006 02:40 PM

No. I mean, it was doing it while I was running from the live CD as well. Plus, I don't think the network's down because even though the browser won't work, I can still ping the urls.

ckr 07-12-2006 06:17 PM

Okay, I've checked. I don't think there's anything in the log indicating a problem, but this is definitly a Linux issue. Meaning I've missed somethign in my setup.

My router serves out the addys on my network, and my linux box is set to accept dhcp. However, when I ping comcasts DNS server, I get nada. When I ping it from my windows box (same machine, it's a dual boot) I have no problem geting a ping and nice, low speeds.

And, in fact, when I run the ping from my Linux server, I also get no return. Is this dns something I was supposed to put in my hosts file? Or somewhere else. I mean, I pointed everything to the router ip.

This is kinda driving me crazy. Anyone have any ideas?

mallard 07-12-2006 11:04 PM

The ISP's DNS server addresses go in resolv.conf, not hosts. What are you using for a router?

ckr 07-13-2006 07:26 AM

I'm using a d-link wireless router -- don't remember the model off hand. The boxes in question are not wireless though.

I added the DNS ip in the config screen that asks for it, but I didn't check and see if the resolv.conf file had been updated. Besides which, the DNS ip is stored in the router, and the DNS ip on the linux box points to the router IP Wouldn't that take care of the DNS for the linux box?

sosborne 07-13-2006 05:50 PM

I think that this is specifically related to Firefox, and not, necessarily, a network issue. If you can ping, then you are still connected; what is failing is the WWW portion of Internet connectivity.

I have had this problem on my Linux box & on my fiancee's Window$ machine, as well. Are you using Firefox on the M$ machine? I've not had this problem using (shudder) Internet Explorer.

Just a few thoughts :) .

ckr 07-13-2006 06:01 PM

I am using Firefox. However, I'm using it on BOTH OSs. Linux and Windoze. And the only time I have an issue is on the linux box. I'm using Ubuntu, and I've made some changes to the resolv.conf. It may have helped, but it's hard to tell because Ubuntu keeps overwriting the file for some reason and putting it back to an older configuration. gotta say, I'm sort of losing patience with this.

All times are GMT -5. The time now is 12:30 PM.