LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 09-22-2015, 02:20 PM   #1
AnjanG
LQ Newbie
 
Registered: Sep 2015
Posts: 2

Rep: Reputation: Disabled
Post Linux Bonding Issue


I hope this is the section where I should post Bonding issue of Ethernet ports in Red Hat Linux 5.9.

I have one production system where my customized application runs.The applications require seamless network connectivity with different machines connected in LAN and WAN. As these applications are very critical, it is very much required to have a seamless network activity.The applications are running on Red Hat Enterprise Linux server release 5.9 Kernel version is 2.6.18.
I have 2 Ethernet port in my application server machine and these 2 ports are bonded using bonding utility of Linux.These 2 ports can be pinged by a single IP.
In bonding configuration I have used Adaptive Load Balancing. Recently I have tested for seamless activity of the applications in production system and found the following.

When I remove LAN A (Physically) from switch I am not losing any ping packet drop.
When I reconnect the LAN A again I am having 7 ping packet drop enough to disconnect logical path formed by customized application running on server.

The same is true for LAN B also.
In order to have seamless load sharing activity bonding is used but it is not performing as desired.

Can any body help me to troubleshoot the same?

# Broadcom Corporation NetXtreme BCM5719 Gigabit Ethernet PCIe
DEVICE=bond0
BOOTPROTO=none
ONBOOT=yes
NETMASK=X.X.X.X
IPADDR=Y.Y.Y.Y
GATEWAY=Z.Z.Z.Z
TYPE=Ethernet
USERCTL=no
IPV6INIT=no
PEERDNS=yes

Ifconfig of eth0
# Broadcom Corporation NetXtreme BCM5719 Gigabit Ethernet PCIe
DEVICE=eth0
BOOTPROTO=none
ONBOOT=yes
HWADDR=aa:bb:cc:dd:ee:ff
MASTER=bond0
SLAVE=yes
TYPE=Ethernet
USERCTL=no
IPV6INIT=no
PEERDNS=yes

Ifconfig of eth1
# Broadcom Corporation NetXtreme BCM5719 Gigabit Ethernet PCIe
DEVICE=eth1
BOOTPROTO=none
ONBOOT=yes
HWADDR=ii.jj.kk.ll.mm.nn
TYPE=Ethernet
MASTER=bond0
SLAVE=yes
TYPE=Ethernet
USERCTL=no
IPV6INIT=no
PEERDNS=yes

Bonding Configuration.

alias scsi_hostadapter mptbase
alias scsi_hostadapter1 mptspi
alias scsi_hostadapter2 ata_piix
alias eth0 tg3
alias eth2 tg3
alias eth1 tg3
alias eth3 tg3
alias bond0 bonding
options bond0 mode=balance-alb miimon=100

Can I play with Mode and miimon parameter?Can a increased miimon upto 300 ms help me out.My average pinging response is 60 ms.
 
Old 09-22-2015, 02:55 PM   #2
nini09
Senior Member
 
Registered: Apr 2009
Posts: 1,850

Rep: Reputation: 161Reputation: 161
Do you try balance-tlb mode? What's balance mode on switch?
 
Old 09-23-2015, 02:46 AM   #3
AnjanG
LQ Newbie
 
Registered: Sep 2015
Posts: 2

Original Poster
Rep: Reputation: Disabled
I did not try Balance-tlb.How can I check what is the balance mode on switch?I have 1 switch for LAN A and another switch for LAN B.
They are 2 separate switch physically.Switches are CISCO 3560.
One more thing Can you please tell me in short the basic difference between Balance ALB and Balance TLB?

Last edited by AnjanG; 09-23-2015 at 02:48 AM.
 
Old 09-23-2015, 02:38 PM   #4
nini09
Senior Member
 
Registered: Apr 2009
Posts: 1,850

Rep: Reputation: 161Reputation: 161
CISCO 3560 should support standard 802.3ad. You should use this mode on both side, switch and Linux machine.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
bonding wierd issue mosawer Linux - Networking 8 02-07-2013 11:01 PM
NIC Bonding in Linux issue aparna8877 Linux - General 2 02-02-2012 04:10 AM
bonding issue fernfrancis Linux - Newbie 5 06-16-2011 12:17 AM
RedHat 5.4 bonding issue mauleta Linux - Networking 3 08-06-2010 03:55 PM
Bonding netxtreme DNS Clearing ISSUE! colincraig127 Linux - Server 0 07-27-2007 05:10 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 11:34 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration