LinuxQuestions.org
Share your knowledge at the LQ Wiki.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 01-10-2001, 02:01 PM   #1
bfloeagle
Member
 
Registered: Jun 2000
Location: Upstate New York
Distribution: Ubuntu
Posts: 158

Rep: Reputation: 30
Angry


I know this question has been asked before in other posts but I need to ask it again.

Has anyone got the Linksys LNE100TX v4.0 ethernet card working on a RedHat 6.2 Machine?

Linksys says all you need is the tulip driver, RedHat says it is incompatable. Either way, I have followed all the directions that Linksys gave and it did not work.

"trickykid" said he got it working in RH 6.2 after RH 7.0 did not work with it. How did you (or how did he if anyone knows) get it to work?
 
Old 01-10-2001, 09:16 PM   #2
jeremy
root
 
Registered: Jun 2000
Distribution: Debian, Red Hat, Slackware, Fedora, Ubuntu
Posts: 13,174

Rep: Reputation: 3801Reputation: 3801Reputation: 3801Reputation: 3801Reputation: 3801Reputation: 3801Reputation: 3801Reputation: 3801Reputation: 3801Reputation: 3801Reputation: 3801
OK. I have learned two things about this card. First - it is VERY picky about witch version of the tulip driver it will work with. Try using v0.91g-ppc as it is confirmed to work. The second thing is that there are actually two versions of the card. The old version uses the tulip driver I just mentioned. For the new version you need to download netdrivers.tgz from http://www.scyld.com.
 
Old 01-11-2001, 10:16 AM   #3
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 256Reputation: 256Reputation: 256
Linksys NIC problems....

Well, Redhat 6.2 detected my card and installed it correctly. I do know however the tulip driver supplied by Redhat 6.2 is correct though. You should try and run the linuxconf from the terminal screen within x and check there to see what driver it is using. I found this is the easiest way to figure out which driver your eth0 is using. Also if it is not present there, check your original Linksys Driver diskette # 2, Linksys has placed the tulip drivers on there but you will be required to compile them but linksys does have all the directions on their homepage.
Here is the link http://www.linksys.com/support/kb.asp?kbid=116

Hope this Helps....

Drew

[Edited by trickykid on 01-11-2001 at 10:25 AM]
 
Old 01-11-2001, 10:33 AM   #4
bfloeagle
Member
 
Registered: Jun 2000
Location: Upstate New York
Distribution: Ubuntu
Posts: 158

Original Poster
Rep: Reputation: 30
Using Tulip

I checked linuxconf and it said I am using tulip. I have never been able to make Linux even detect it. I dont even think it recognizes that it is there. I have downloaded the most recent tulip driver and (I think) I installed it correctly. I followed the compile module methods from Linksys and from scyld.com and neither work. If I try and do ifup I get "Delaying eth0 initialization". If I do a insmod (or depmod - I am not sure - still a newbie here) it tells the that the "device or resource is busy". I dont know from what.

The only thing that may be different is that I bought this card with a set (a switch, 2 nics, and cables). I only have one driver disk and all it tells me to do is get the most current tulip driver. What version is the one you got working?

Another question, is there any way of "probing" for the correct card (sort of like windoze auto detect/plug-n-play)? Maybe another driver I can use just to make this card work?
 
Old 01-11-2001, 01:54 PM   #5
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 256Reputation: 256Reputation: 256
let me get back on that.....

I can't remember what version I am using right now, but I will let you know once I get home from work on which tulip driver I am using and see if i can find any other info on any other driver that might actually work. I could possibly email you the driver I have also for you to try as well.

Drew

Have you tried netconfig in the terminal to reconfigure your network that way?
 
Old 01-11-2001, 04:23 PM   #6
bfloeagle
Member
 
Registered: Jun 2000
Location: Upstate New York
Distribution: Ubuntu
Posts: 158

Original Poster
Rep: Reputation: 30
Unhappy Yup, I have...

Yeah, I have tried netconfig in and outside of X, both lead to a "Delaying eth0 initialization" during bootup and no trace of eth0 in ifconfig. Let me know the version of tulip AND the version of the card if you can...
 
Old 01-12-2001, 09:12 AM   #7
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 256Reputation: 256Reputation: 256
Arrow

Well the version of the tulip driver is the latest that was released, and my card I didn't even bother to see which one it was but I do beleive it is v4.0.
You say that linuxconf displays it but what about ifconfig, does it give you anything about your card or even list it.
If it says "device or resource is busy" did you check to see if the card wasn't disabled or anything in linuxconf. Does the card work in any other OS like Windows?

Drew
 
Old 01-12-2001, 09:58 AM   #8
bfloeagle
Member
 
Registered: Jun 2000
Location: Upstate New York
Distribution: Ubuntu
Posts: 158

Original Poster
Rep: Reputation: 30
Question Disabled???

All linuxconf displays is that the device is enabled, and using tulip with the ip and subnet I gave it. Ifconfig only displays info on my loopback and nothing on eth0.

The card was working in two separate windows 98se machines perfectly. I also have two of the lne100tx cards, so I have tried both on the linux system just to make sure that one was not bad. Nothing happened.

What should I look for that might disable it??? How could it be disabled?

Andy

 
Old 01-12-2001, 10:53 AM   #9
trickykid
LQ Guru
 
Registered: Jan 2001
Posts: 24,149

Rep: Reputation: 256Reputation: 256Reputation: 256
Arrow

Sounds to me if its not detecting when you ifconfig, but it is in linuxconf, then it could be an irq conflict. You did say it was trying to detect during the boot process, then you could try to pass the argument:

ether=10,0x300,eth0 in the lilo boot prompt so you would try typing this

lilo: linux ether=10,0x300,eth0

which the 10 would be the irq and the 0x300 would be your i/o base address. It might be different on your machine. But those I think are the standard settings for an ethernet card. You might want to try and do an make xconfig to bring up to enable the card in the kernel. Might have to recompile the kernel to get it to work. You can find help online in the HowTo's if you never recompiled before.

If none of that works, you could try making your eth0 as a module, by editing your /etc/conf.modules file to use and tell when you use modprobe command to tell which driver to use for your card. Would look something like this:

This would be a line in the file: alias eth0 tulip

Then you can modprobe eth0 and see what it comes up with.
Here are two links that tell this in detail.
http://www.linux.com/firststep/newsi...id=10&aid=4173
http://www.linuxdoc.org/HOWTO/Ethern...O-9.html#ss9.2

Hope this helps in any way. Might want to check out those sites, I could be mistaking in some of my typing above. Those sites explain in more detail.

Drew
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LINKSYS LNET100TX or LINKSYS LNE100TX rsuave Linux - Newbie 6 12-04-2004 07:43 PM
Linksys LNE100TX issues linux_good Linux - Hardware 2 01-29-2004 10:19 PM
linksys lne100tx on slackware barazor Linux - Networking 5 12-28-2003 08:33 AM
Linksys LNE100TX and RH 7.2 splattermark Linux - Networking 1 02-22-2002 03:28 PM
Linksys (LNE100TX) Card Ermac6 Linux - Networking 8 06-25-2001 11:01 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 05:28 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration