-   Linux - Networking (
-   -   Linksys DSL Router/Don't Want DHCP (

fennario 03-20-2002 12:57 PM

Linksys DSL Router/Don't Want DHCP
I've look over the forums, and don't see anything like the problem I'm having:

Linksys DSL Router - Linux Laptop (Dell I7000), RedHat 7.2.

Can't get Apache to work over the open net (apparently it doesn't like DHCP - I DID open the firewall on the Router for port 80). Could SSH (port 23) over the open net from work - could never access Port 80 correctly.

So, I turned of DHCP, and edited my ifcfg-eth0 file and my resolve config for my DNS servers.

Now, I can ping the Router, but can't connect to the Web or anything else outside the network.

ifconfig looks good, shows the right Broadcast IP, the right IP for the card, etc.

I turn back on DHCP - all works. Turn it off - hard code the same values - doesn't work!

Any help appreciated!

Syncrm 03-22-2002 02:26 PM

check your route tables by typing this:

route -n

make sure that there's a default gateway of (or whatever your router's ip is, i'm assuming it's that since linksys defaults it). if there's no route to the gateway, then your machine doesn't know where to send network queries. you can add a default gateway like so:

route add default gw eth0

hope this helps. :-)

Slestak 03-22-2002 02:43 PM

Thats kindof what I was thinking about, the gateway.

What about the NAT firewal, do you need to patch a passthrough for port 80?

Sixpax 03-22-2002 02:50 PM

Is anything else NOT working when you hardcode the values? nslookup... ping... traceroute... etc? can you ping your own hostname (not IP address)?

fennario 03-22-2002 04:49 PM

Thanks, it was indeed the gateway! I am such a putz!

So, that is the good news - I'm off DHCP on the laptop. So, I tried the apache server from outside my network - still no go - resolves fine using "localhost", ""hostname" or my ISP dynamic IP number. Outside my network - 404 error.

I opened port 80 on the DLink Router (I know, I said I had a LinkSys...I'm getting old, sorry...), and in fact also opened port 23, and am able to ssh to port 23 by using the alias I created, so it appears the outside world does properly know how to map to the current IP number to my box.

But, no go on port 80, or trying to access the Web server via the IP number outside my network.


bbenz3 03-22-2002 11:32 PM

This may not apply to you but some ISP's have blocked port 80. Do you know for sure that yours is open. Simply solution but may not be the correct one. If in doubt try putting the webserver on a different port and see if that works.

trickykid 03-23-2002 01:51 AM

bbenz3 is right, most isp's block port 80..
most don't block port 22 for ssh, i thought telnet is reserved for port 23 by default.. guess it depends on how you have yours setup..


batman7 04-29-2002 06:37 PM

Linux webserver / Linksys router
Anyone find a solution?
I can get out to Internet from my Linux Box, but nothing gets in.
Here's what I've got:

Linksys Router:
LinuxBox Webserver:
Actually IP seen by Internet( (coincidentally points to someone else's site, Not mine...don't know why?)
Internally(behind router) I can access my Linuxbox webpage,(proves it works, Internally at least!), however nothing externally. I turned on Port Forwarding for Port 1230 instead of 80(in case it's blocked by ISP) and disabled DHCP, SPF, blocking of WAN requests. DMZ didn't work either.
Any suggestions?


All times are GMT -5. The time now is 10:31 AM.