LinuxQuestions.org

LinuxQuestions.org (http://www.linuxquestions.org/questions/index.php)
-   Linux - Networking (http://www.linuxquestions.org/questions/forumdisplay.php?f=3)
-   -   latest release of my fav distro won't conn to coffee shop (http://www.linuxquestions.org/questions/showthread.php?t=4175444300)

Dreiland 01-05-2013 04:51 PM

latest release of my fav distro won't conn to coffee shop
 
In every release of Ubuntu-based remixes I've ever tried (Linux Mint, PeppermintOS, Crunch Bang), as well as KNOPPIX, connecting to a coffee shop's wifi is “automagic”. It was that way too in BackBox Linux 2.05 (based-on Ubuntu 11.04). But now that I've upgraded that partition to Backbox 3.0, the dang NetworkManager pops-up a dialog-box on me, and wants info I don't have. It says I need ssid, bssid and mac address, and “clone mac address” (whatever * that * is).

Yes, I md5-check any distro before I use it, to help make sure I got an uncorrupted d/l.

I've searched mightily on the web, and d/l-ed and read several Linux networking tutos.

I wonder if this could be a setting, changed by the makers of the distro (BackBox Linux). I've consulted the distro's documentation and forums-posts, but no luck. I'm gonna try posting on BackBox forums next. BackBox 3.0 is based-on Ubuntu 12.04, so this shouldn't be such a mystery.

I want my BackBox back! (I don't use the “hacker-ware” that's in it—it's just that it makes a * very * nice desktop—with the addition of a handful of softwares from reops. And Backbox 2.05 had the ** best ** public WAP/coffee-house/airport ability-to-connect I've yet encountered in a Linux distro, which is why I'm so hot after it.) Back * Track * seems much harder to make into a good desktop.

I wonder why the 3.0 version is not able to connect to * my * favorite * coffee-house I frequent, whereas the 2.05 release did so just fine—and so do all the other os I have installed—such as Linux Mint 13 XFCE: it's just that my other distros * will * not * connect to many of the * other * coffee-houses in my city—though the older (2.05) version of Backbox always will. And Windows 7 Starter always will connect. So I don't see a problem with these businesses' routers.

I notice my install of Ubuntu 12.04 (in another partition), connects to most of these local coffee houses just fine.

If I run “nm-tool”, in Backbox 3.0, I get:

NetworkManager Tool

State: disconnected

- Device: eth0 -----------------------------------------------------------------
Type: Wired
Driver: atl1c
State: unavailable
Default: no
HW Address: 1C:75:08:B9:C0:18

Capabilities:
Carrier Detect: yes

Wired Properties
Carrier: off#

And that's all.

I hope I have been clear.
I am using an AAO d255e-2677, model PAV70, 32-bit CPU, Intel Atom N450, dual-core, 10.1” screen, traditional platter-type hdd ( 160 Gb WD1600BEVT-2 ), 1 Gb RAM it came installed with, Broadcom b43-n [BCM4313 802.11b/g/n] wifi controller.
Any ideas would be helpful.

All I get when clicking on the NM icon in the panel, is a tick-box to “enable wireless networking”. I've toggled that off and on, but no results. And an option to “edit wireless networks”. This brings up a dialog:
[I tried to put screenshot here, but I couldn't figure out right now how to get it to paste in. Maybe if i can update this post, later.....]



If I highlight the only shown interface with a click of my mouse, and click the “ADD” button, I get another dialog: this one asks for ESSID, BSSID, MAC and MAC-clone.


Anyway, the os knows the correct time and date, and also says “there are 176 updates waiting”.

I'll try to update this post, as I do more research.

jv2112 01-13-2013 08:15 AM

If you right click on Network manager in the tray you should see all networks available. You should just have to select and if it is open network then it should log in. However it appears the OS is not picking up on the wireless chip. I am fairly certain your chip is supported by the current kernel which makes me thinl it could be hardware related. Is there a function key combination or switch to turn off the wireless adapter ? Is the wireless option checked ( left click ) on the network manager applet ?

Dreiland 01-20-2013 09:11 PM

still won't conn--dreiland
 
Thanks for your response...yes, I tried Right-click on the nm applet, but no netwoks. I also tried the other (easy) thing you said, but no dice. I suspect the makers of this distro may have loaded a different broadcom driver at the kernel level, as default b43 driver. I am gonna try getting on the net with my USB dongle next time I can boot this os. I will post a reply. Dreiland

Dreiland 02-21-2013 02:37 PM

Here's a little progress on the issue....
 
Sorry it's taken me so long to get back...have been busy...
Okay: The os is importing time and date settings from the computer's cmos: that's why BackBox 3.0 knows what day it is, and the time. I should've thought of it, but I was tired.....
Further, I overlooked something in the results of nm-tool: it says right up there, near the top of the output, what Broadcom driver is loaded. Good info. I'm gonna try have a look at the driver Mint loads: let me see if I can get my Terminal, while I'm here...
It says "brcmsmac", whereas Backbox 3.0 apparently is loading "atl1c".
This looks like it's the problem. I am gonna get with my friend Bob, as he said he'd let me hook my laptop up to his Ethernet (all I have avail at present is the wireless in my building). And then I'll try that kernel update: I've been told that that may just fix the issue "automagically". Stay tuned.... Funny, though, how BB can know how many updates are waiting... Strange mysteries... I'll be back here when I'm able. -Dreiland


All times are GMT -5. The time now is 01:39 PM.