LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 03-10-2016, 03:09 AM   #1
kanalia
LQ Newbie
 
Registered: Mar 2016
Posts: 2

Rep: Reputation: Disabled
Lan Turtle configuration


Hi Chaps
I have recently bought a Lan Turtle, a covert Systems Administration and Penetration Testing tool providing stealth remote access, network intelligence gathering, and man-in-the-middle monitoring capabilities. Housed within a generic "USB Ethernet Adapter" case, the LAN Turtle’s covert appearance allows it to blend into many IT environments. The device is in fact a small computer running Linux. You can plug it in to host computer via usb and connect a network cable on the 'other end'. The 'other end' will be allocated an IP by DHCP and device will serve an IP for the host. Both networks are bridged now so the host can still access internet and I can ssh to device and do all sorts of pen testing activities from it. Because my Ethical Hacking course is founded by my employer I can use our corporate network as firing range. I connected the device to my PC but I am not on domain any more. I wonder if it would be possible for the PC to still be on the same corporate network. This is the current config of the device:

config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fda4:1103:3ec4::/48'

config interface 'lan'
option ifname 'eth0'
option force_link '1'
option type 'bridge'
option proto 'static'
option ipaddr '172.16.84.1'
option netmask '255.255.255.0'
option ip6assign '60'

config interface 'wan'
option ifname 'eth1'
option macaddr '00:e0:4c:36:1c:12'
option proto 'dhcp'

config interface 'vpn'
option ifname 'tun0'
option proto 'dhcp'

config interface 'wan6'
option ifname '@wan'
option proto 'dhcpv6'

So the question is - is it possible to have 'lan' on the same network as 'wan'?
Regards, kanalia
 
Old 03-17-2016, 03:44 AM   #2
kanalia
LQ Newbie
 
Registered: Mar 2016
Posts: 2

Original Poster
Rep: Reputation: Disabled
Hi Chaps
I have figured it out myself. Simply go to etc/config/network and change the config for 'lan' to:

config interface 'lan'
option ifname 'eth0 eth1'
option type 'bridge'
option proto 'dhcp'

This bridge will make both adapters visible to target network so both adapters will be allocated an IP by DHCP. Have fun!!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
LAN DNS configuration Ciralia Fedora 2 06-11-2007 07:16 AM
lan configuration paul62 Linux - Networking 2 09-28-2006 03:37 PM
LAN Configuration Melo Linux - Networking 2 08-31-2003 03:48 PM
Lan Configuration varunbihani Linux - Hardware 1 07-18-2003 09:55 AM
RedHat 7.1 Lan Configuration Chrisf Linux - Networking 12 12-18-2001 11:23 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 08:36 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration