-   Linux - Networking (
-   -   Kubuntu / Iptables / Windows VPN Issue (

Jiggs 11-03-2008 06:47 PM

Kubuntu / Iptables / Windows VPN Issue

I'm having problems with my laptop connecting through my linux router to my corporate VPN.

My setup is as follows.
Cable Modem -> (eht1) Linux Router (eth3) -> SWITCH -> Rest of House.
One of the connections in the house has a WRT54G wireless router on it.

Everything works great except connecting through the linux router to the VPN.

It should be noted, I just replaced the Linux router for an older Ubuntu machine, and VPN worked fine. I'm just missing something, but I'm not sure what.

My laptop connecting wirelessly can connect to anything on the internet. However, when I try to connect to a Windows VPN server, it fails. It reaches the "Verifying Username and Password" stage and hangs.

The linux router is running Kubunu 8.04 64-Bit, running Firestarter on Iptables.

I have added this to /etc/firestarter/user-pre as indicated online:
# Forward PPTP VPN client traffic
$IPT -A FORWARD -i $IF -o $INIF -p tcp --dport 1723 -m state --state NEW,ESTABLISHED,RELATED -j ACCEPT
$IPT -A FORWARD -i $IF -o $INIF -p 47 -m state --state NEW,ESTABLISHED,RELATED -j ACCEPT
$IPT -A FORWARD -i $INIF -o $IF -p 47 -m state --state NEW,ESTABLISHED,RELATED -j ACCEPT

PLEASE help!!!


Jiggs 11-03-2008 07:00 PM

Ok, well I feel slightly silly, but maybe this will help someone else.

Firstly, I checked DMESG... and it held the key.

It was showing packets from eth3 (my lan) to eth1 (internet) destination port 1723 being dropped. Which, shouldn't have happened as I had an ALLOW ALL on that subnet (lan).

[ 725.368096] DROPPED IN=eth3 OUT=eth1 LEN=48 TOS=0x08 PREC=0x60 TTL=126 ID=19816 DF PROTO=TCP SPT=4411 DPT=1723 SEQ=583123285 ACK=0 WINDOW=16384 RES=0x00 SYN URGP=0 OPT ()

I added an exception to allow port 1723 where source = LAN, and it worked.


All times are GMT -5. The time now is 03:35 AM.