-   Linux - Networking (
-   -   kppp problem, need to fix it or find kppp alternative (

trisha 08-08-2004 03:04 PM

kppp problem, need to fix it or find kppp alternative
Hello! I have a laptop with gentoo installed and have been using kppp to dial in to my ISP for a while now, but starting getting an error (see below) a couple nights ago.

Right before the problem started the computer locked up on me and I had to shut it down manually. That happens to me now and then and so far I haven't had any problems when restarting. When I tried starting kppp again and it popped up some message about a file being somewhere and I think something about another instance of kppp running. I should have paid more attention, but it gave me the option of continuing, so I did. I haven't been able to get that same message to pop up again.

If I can get the kppp problem fixed, that would be great. But if there is some other way to dial in, I could use that too. I use Gnome, not KDE anyway. I read something else somewhere about ppp-go, wvdial, rp3 and and pppon and tried running those through Gnome's 'Run Application', which is how I have always started kppp. Maybe those can only be run through a command line or something, or they are not installed on my computer. I don't know, I'm new to linux, and am not good at command line stuff yet. If someone can tell me what to type in through a command line, I'd be happy to try that.

I also tried something called 'Modem Lights', which I found on my computer. When trying to connect through it, I get a message that says:
Failed to execute child process "pppon" (No such file or directory)

That sounds like a more serious problem, yet I can't imagine how anything really terrible could have gone wrong with my computer.

Anyway, here's the kppp error I'm having:
Everytime I try to dial in, I get a message saying 'No dial tone'. I checked the phone lines, the ISP number, the phone line cord, etc - all that is fine. When I try to dial in the kppp window says:

Modem Ready
Initializing Modem
Dialing 6363265155
No Dial Tone

but I can't hear it dial anything, like I usually can.

I have a backup ISP, I tried its number too and the same thing happens.

The kppp log says:


The system logs say:

slmdm: cannot open file '/var/lib/': errno13

Just what is this 'slmdm' file anyway? I tried to open it, but couldn't. Could it have gotten corrupted or something when the computer locked up and I had to manually shut it down?

Another thing, I also tried dialing in when logged in as root, just to see what would happen, it didn't make any difference, got the same error.

Any ideas?

All times are GMT -5. The time now is 10:13 PM.