-   Linux - Networking (
-   -   kppp crash as user not as root (

spoody_goon 12-04-2006 10:07 AM

kppp crash as user not as root
I've read many posts and tried the suggestions but I must be missing something. I can use kppp to connect to the internet as root but not as user. As user I get:

Opener: received SetSecret
Opener: received OpenLock

Opener: received OpenDevice
Opener: received ExecPPPDaemon
segmentation fault

And then it crashed like it was killed

I am using:
-Slackware 11
-Kernel 2.6.18
-and martain_modem for a modem driver

I am willing to try anything suggested even if I have already tried it.

Thank you.

osvaldomarques 12-05-2006 02:02 PM

Hi spoody_goon,

First you need to identify where is the kppp program with the command

which kppp
It will display the directory where kppp is installed, for example, /usr/lib/kde3/bin/kppp; then enter the command

ls -l /usr/lib/kde3/bin/kppp
It will display the attributes of the file

-rwsr-xr-x  1 root root 543096 2005-07-25 10:50 /usr/lib/kde3/bin/kppp
If the first permission letters aren't "rws" or the user/group are not root as shown on the above display, this is your problem; In this case, as root enter the commands

chown root.root /usr/lib/kde3/bin/kppp
chmod u+s /usr/lib/kde3/kppp

Remember to replace the "/usr/lib/kde3" by the directory you found on the first command in this post.

The kppp must be setuid; it must always run as root.

spoody_goon 12-05-2006 02:15 PM

Thank you, I have followed your instructions. kppp was set to -rwsr-xr-x but I executed chown and chmod anyway just to be sure.

I may be wrong but if the permissions was wrong I don't think I would be able to execute kppp at all instead of just having it crash, when it initializes the modem?

Do you have any other suggestions?

Again Thanks

osvaldomarques 12-05-2006 02:39 PM

Repeat the same commands for pppd. It also has to run as root and must be setuid. The problem may be on it. The segmentation fault can occur on such case if it is not conveniently attended; for example, if you try to open a file that you have not permission, you will give a NULL pointer to it; if you check this pointer before use it, you may display a message like "file xyz could not be opened". However, if you assume that you always will open that file with no problems, on the first read you will have a segmentation fault.

As an example, this c source file will show you:

#include "stdio.h"

int main(void)
  FILE *fs = NULL

  char txt[16]
  while (fgets(txt, sizeof(txt), fs))

Save this file as xyz.c, compile it with the following command

gcc -o xyz xyz.c
and run it with


All times are GMT -5. The time now is 02:53 AM.