LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 05-23-2004, 07:26 PM   #1
Geoffrey_Firmin
LQ Newbie
 
Registered: May 2004
Posts: 14

Rep: Reputation: 1
Knoppix/Debian - how to disable NIS


After a Knoppix HD install, I did an apt-get upgrade. Despite choosing to keep my current configuration files everytime I was prompted, after the upgrade NIS services are starting at bootup. This is causing a hang at boottime and a delay everytime I'm trying to load a webpage.

How do I stop the NIS services from starting? I tried editing the nsswitch.conf file, commenting out the NIS line, but it had no impact. Another post I read suggested remaing the /usr/sbin/ypserv executable file, but that hardly seems the best way to proceed. What are the conf files for Debian which control the startup of this service? How do I get rid of it?
 
Old 05-24-2004, 05:58 PM   #2
zatriz
Member
 
Registered: Aug 2003
Location: Seattle, Wa
Distribution: Fedora,Trustix,Debian
Posts: 290

Rep: Reputation: 30
I haven't used debian but the concept is the same
the command to turn off a service is "chkconfig"
chkconfig --level 35 nis off
this command would turn off the service nis for runlevel 3 and 5


The config files are stored in /etc/rc.d/rc?.d/
where ?=the runlevel ie
/etc/rc.d/rc3.d/ would contain the script for runlevel 3
if you delete the file that starts with an S (for start ) that works also
but chkconfig is recommended
 
Old 05-25-2004, 01:15 AM   #3
Geoffrey_Firmin
LQ Newbie
 
Registered: May 2004
Posts: 14

Original Poster
Rep: Reputation: 1
Thanks for the reply, you got me on the right track

Quote:
Originally posted by zatriz
I haven't used debian but the concept is the same
the command to turn off a service is "chkconfig"
chkconfig --level 35 nis off
this command would turn off the service nis for runlevel 3 and 5
No, chkconfig is apparently not available for Debian systems.

Quote:
[i]The config files are stored in /etc/rc.d/rc?.d/
where ?=the runlevel ie
/etc/rc.d/rc3.d/ would contain the script for runlevel 3
if you delete the file that starts with an S (for start ) that works also
but chkconfig is recommended [/B]
After searching for a bit I found that a good Debian option is rcconf,
which is not included on the Knoppiix disc. Very simple to use. Worked
like a charm. I'm brand new to Debian, obviously, and there are a lot of
differences from the Slackware and Redhat systems I've dealt with before.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
What's the difference between debian and other debian-based distro like knoppix? Akhran Debian 11 08-28-2005 07:07 PM
Disable Intel Pro Wireless 2100 Centrino NIC using HD install of Knoppix Substandard Linux - Newbie 1 02-04-2005 01:08 AM
how to disable knoppix firewall upload-3 Linux - Networking 2 09-03-2004 02:38 AM
How do you disable going through a proxy in Debian? sanfran49 Linux - Software 2 02-12-2004 05:14 PM
NIS login probs on debian PeterN Linux - Software 4 01-06-2004 10:12 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 07:06 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration