LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 08-04-2010, 01:28 PM   #1
vikas027
Senior Member
 
Registered: May 2007
Location: Sydney
Distribution: RHEL, CentOS, Ubuntu, Debian, OS X
Posts: 1,305

Rep: Reputation: 107Reputation: 107
Unhappy Kickstart PXE install


Hello Friends,

I am in a VMware environment, and using RHEL 5.4.

I am trying to setup a PXE Kickstart installation. For this I have configured DHCP and TFTP, made a kickstart file and shared it in the network through HTTP.

My problem is that somehow kickstart file (ks.cfg) is not picked by the machine in which I am installing the OS. Although, the contents of my kickstart file can be viewed over HTTP. Please see KS_Error.jpg.

Code:
[root@ser pxeboot]# elinks http://192.168.1.100/ks.cfg | head
   # Kickstart file automatically generated by anaconda. # linux
   ks=http://192.168.1.100/ks.cfg install # The source server from which all
   the packages and other necessary file needed for installation are picked
   up url --url http://192.168.1.100/RHEL5.4 # mouse, keyboard, and lang
   indicates the mouse type, default keyboard and language to be used during
   the installation. mouse keyboard us lang en_US.UTF-8 langsupport
   --default=en_US.UTF-8 en_US.UTF-8 # Networking :- eth0 = interface name,
   rest are obvious network --device eth0 --bootproto static
   --ip=192.168.1.115 --netmask=255.255.255.0 --gateway=192.168.1.1
   --hostname=ser.box2.com rootpw --iscrypted
[root@ser pxeboot]# echo $?
0
However, I believe DHCP and TFTP is working fine as I am getting the correct IP 192.168.1.115 which I have set in /etc/dhcpd.conf. Also, my label 1 which I have set in /tftpboot/linux-install/pxelinux.cfg/default is working fine as I able to locate initrd and vmlinuz. Please see attached Image_1.jpg

Any ideas, how to troubleshoot this. Please do tell me if I need to paste any of my configuration files.
Attached Thumbnails
Click image for larger version

Name:	Image_1.jpg
Views:	16
Size:	111.8 KB
ID:	4242   Click image for larger version

Name:	KS_Error.jpg
Views:	18
Size:	88.1 KB
ID:	4243  

Last edited by vikas027; 08-04-2010 at 01:29 PM.
 
Old 08-05-2010, 10:39 AM   #2
pcangelo
LQ Newbie
 
Registered: Jul 2010
Posts: 8

Rep: Reputation: 0
Did you check your firewall configuration? RHEL I believe that is installed by default with a restrictive firewall.
Maybe your apache server that provides the kickstart file is not available from outside.
Check also your url: url --url http://192.168.1.100/RHEL5.4 - is your ks file inside?

Last edited by pcangelo; 08-05-2010 at 10:47 AM.
 
Old 08-05-2010, 11:59 AM   #3
szboardstretcher
Senior Member
 
Registered: Aug 2006
Location: Detroit, MI
Distribution: GNU/Linux systemd
Posts: 4,212

Rep: Reputation: 1612Reputation: 1612Reputation: 1612Reputation: 1612Reputation: 1612Reputation: 1612Reputation: 1612Reputation: 1612Reputation: 1612Reputation: 1612Reputation: 1612
Lightbulb

Just for testing purposes, I would disable all firewall and selinux.

service iptables stop
service iptables6 stop
system-config-securitylevel (disabled/disabled)

imho, restart after these changes and try again.
 
Old 08-06-2010, 12:31 PM   #4
vikas027
Senior Member
 
Registered: May 2007
Location: Sydney
Distribution: RHEL, CentOS, Ubuntu, Debian, OS X
Posts: 1,305

Original Poster
Rep: Reputation: 107Reputation: 107
Unhappy

Dear pcangelo/szboardstretcher,

I have already disabled SELINUX and IPTABLES. I dont think the problem lies here, because I can access the url http://192.168.1.100/ks.cfg from my Host OS.
 
Old 08-07-2010, 01:03 AM   #5
SuperJediWombat!
Member
 
Registered: Apr 2009
Location: Perth, Australia
Distribution: Ubuntu/CentOS
Posts: 208

Rep: Reputation: 51
Try running a packet trace from the server hosting the ks.cfg file, to see how far the client is getting.
Code:
tcpdump -i eth0 port 80
 
Old 08-07-2010, 12:41 PM   #6
vikas027
Senior Member
 
Registered: May 2007
Location: Sydney
Distribution: RHEL, CentOS, Ubuntu, Debian, OS X
Posts: 1,305

Original Poster
Rep: Reputation: 107Reputation: 107
Quote:
Originally Posted by SuperJediWombat! View Post
Try running a packet trace from the server hosting the ks.cfg file, to see how far the client is getting.
Code:
tcpdump -i eth0 port 80
Nice idea, I will try and post here the output, if in case I need some help decoding it.
 
Old 08-10-2010, 01:52 PM   #7
vikas027
Senior Member
 
Registered: May 2007
Location: Sydney
Distribution: RHEL, CentOS, Ubuntu, Debian, OS X
Posts: 1,305

Original Poster
Rep: Reputation: 107Reputation: 107
Unhappy

Quote:
Originally Posted by SuperJediWombat! View Post
Try running a packet trace from the server hosting the ks.cfg file, to see how far the client is getting.
Code:
tcpdump -i eth0 port 80
Hi,
I tried the same but no luck.

Code:
[root@ser ~]# tcpdump -i eth0 port 80 -w abc1.pcap
tcpdump: listening on eth0, link-type EN10MB (Ethernet), capture size 96 bytes
0 packets captured
0 packets received by filter
0 packets dropped by kernel
Any help people, I am ready to give remote connection to machine through Team Viewer (provided it is allowed in www.linuxquestions.org).
I have done it before, but I am stucked here , cant find any way to troubleshoot it further.
 
Old 08-13-2010, 01:40 AM   #8
vikas027
Senior Member
 
Registered: May 2007
Location: Sydney
Distribution: RHEL, CentOS, Ubuntu, Debian, OS X
Posts: 1,305

Original Poster
Rep: Reputation: 107Reputation: 107
Any help people, I have tried normal kickstart method and shared my ks.cfg file through FTP (Booting the Machine through DVD and then linux ks=ftp://192.168.1.100/pub/ks.cfg)
I even tried providing the static IP.


But, again for some reasons my file it is unable to retrieve my ks.cfg file. Although, I am able to view my cfg file in HostOS browser.
 
Old 08-13-2010, 06:54 AM   #9
mahi_nix
Member
 
Registered: Aug 2010
Distribution: CentOS, RHEL, Ubuntu,
Posts: 154

Rep: Reputation: 16
Thumbs up

Hi Vikas027,

Have you done system-config-netboot configuration on Graphics or you can use pxeboot/pxeos command for kickstart configuration.

Try Below Commands:

1. system-config-netboot

2. pxeos -a -i "Discription" -P "NFS/FTP/HTTP" -D 0/1 (o for diskless and 1 for network) -S "TFTP servers IP" -K "http/ftp://IP of Kickstart Server:/File location with name" -L "Location of Source" "OS Identifier"

3. pxeboot -a -K "Kickstart Server" -o "OS Identifier" "Clienthost IP/Name"

and then restart all related services and boot client via PXE.

Thanks,

Mahi
 
Old 08-15-2010, 05:00 PM   #10
SuperJediWombat!
Member
 
Registered: Apr 2009
Location: Perth, Australia
Distribution: Ubuntu/CentOS
Posts: 208

Rep: Reputation: 51
It looks like a networking issue to me..

Can you Alt+F2 into a text terminal? If so, try these and post the output:
Code:
ifconfig
ip route
ping 192.168.1.100
wget http://192.168.1.100/ks.cfg
wget ftp://192.168.1.100/ks.cfg
If you don't have wget availible, use telnet:
Code:
telnet 192.168.1.100 80
telnet 192.168.1.100 21
 
Old 08-16-2010, 08:56 AM   #11
vikas027
Senior Member
 
Registered: May 2007
Location: Sydney
Distribution: RHEL, CentOS, Ubuntu, Debian, OS X
Posts: 1,305

Original Poster
Rep: Reputation: 107Reputation: 107
Thumbs up

Thanks Mahi / SuperJediWombat,

Indeed there is some problem in setting the IP.

I saw the logs by pressing Alt+F3 and saw that it was taking IP from DHCP service of VMware Workstation, I disabled (through services.msc) it and then tried giving it from my DHCP Server 192.168.1.100.

Now, I find it strange that it is giving some NIC error. Pls see NIC_1.jpg.

I even tried it setting manually, but it is failing. Please see NIC_2.jpg.

Now, I will try to give IPs to both the machines (my Kickstart Server and the Kickstart Client) from VMware Workstation DHCP and see what happens.

I'm glad, at least I figured out the reason with the help of you guys. Alt+F combinations should have clicked my mind.
Attached Thumbnails
Click image for larger version

Name:	NIC_1.jpg
Views:	13
Size:	136.8 KB
ID:	4323   Click image for larger version

Name:	NIC_2.jpg
Views:	9
Size:	76.8 KB
ID:	4324  
 
Old 08-17-2010, 05:16 AM   #12
mahi_nix
Member
 
Registered: Aug 2010
Distribution: CentOS, RHEL, Ubuntu,
Posts: 154

Rep: Reputation: 16
Hi Vikas027,

Do not Stop VMware DHCP Service. please check you network interface mode in vmware and let us know and also paste your DHCP Server Configuration information here so we can able to help you.

Thanks,

Mahi_nix
 
Old 08-17-2010, 05:20 AM   #13
SuperJediWombat!
Member
 
Registered: Apr 2009
Location: Perth, Australia
Distribution: Ubuntu/CentOS
Posts: 208

Rep: Reputation: 51
It sounds like you probably have your guest's virtual network interface set to NAT through VMware. Try setting it to bridged mode and see how you go.
 
Old 08-18-2010, 01:23 PM   #14
vikas027
Senior Member
 
Registered: May 2007
Location: Sydney
Distribution: RHEL, CentOS, Ubuntu, Debian, OS X
Posts: 1,305

Original Poster
Rep: Reputation: 107Reputation: 107
Thumbs up

Quote:
Originally Posted by SuperJediWombat! View Post
It sounds like you probably have your guest's virtual network interface set to NAT through VMware. Try setting it to bridged mode and see how you go.
I have configured my Network Adapter (Interface) as Host Only. because I wanted to access the new machine (kickstart client) from my Host OS. I took help from here.

And I am glad to tell you that finally I have made it working without disabling my DHCP service. I did disable VMware's DHCP service as I wanted to give IP of my choice to the Kickstart Client . Though, I could not figure out the reason(s) why it was not working earlier. I just reconfgured everything, it might be some small mistake I was making earlier.

Many thanks to you.

Last edited by vikas027; 08-18-2010 at 01:29 PM.
 
Old 08-18-2010, 01:28 PM   #15
vikas027
Senior Member
 
Registered: May 2007
Location: Sydney
Distribution: RHEL, CentOS, Ubuntu, Debian, OS X
Posts: 1,305

Original Poster
Rep: Reputation: 107Reputation: 107
Thumbs up

Quote:
Originally Posted by mahi_nix View Post
Hi Vikas027,

Do not Stop VMware DHCP Service. please check you network interface mode in vmware and let us know and also paste your DHCP Server Configuration information here so we can able to help you.

Thanks,

Mahi_nix
Hi Mahi,

I have stopped VMware DHCP Service as I dont require it.
Now, everything is working fine after I reconfigured DHCP, xinetd and HTTP services.

Many thanks to you.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
pxe kickstart redhat install + vnc/smilar during install fishjohn Linux - Server 1 04-24-2010 09:22 AM
centos 5 PXE install server w/kickstart issues swanyjim Linux - Server 10 09-01-2009 01:57 AM
PXE Kickstart of multiple OS's glassman_3d Linux - Networking 1 07-20-2009 09:39 AM
Kickstart PXE install to machine of other network vikas027 Linux - Newbie 2 03-10-2009 12:17 AM
How to Install Red Hat Linux via PXE and Kickstart, sachinbhagat Red Hat 5 07-18-2008 08:14 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 10:54 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration