LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 08-31-2004, 08:40 AM   #46
cidrolin
Member
 
Registered: Jul 2004
Distribution: Fedora c2
Posts: 89

Rep: Reputation: 15

Have a look to my last contribution to
this post and check which sub-version your 2.6 kernel is...
 
Old 08-31-2004, 03:03 PM   #47
alberto2498
LQ Newbie
 
Registered: May 2002
Location: USA
Distribution: Mandrake 9.0
Posts: 26

Rep: Reputation: 15
The final way for me to actually turn the darn thing back to IPv4 was by changing the line:

alias net-pf-10 IPv6 ----> alias net-pf-10 IPv4

The file in wich you find that is "modules.alias", usually located in:

/lib/modules/2.6.something/

If you cant find it just locate the file.
 
Old 09-15-2004, 03:57 PM   #48
dkroft
LQ Newbie
 
Registered: May 2004
Posts: 16

Rep: Reputation: 0
i have been seeing this for a long time -
posted several times, but no good answer yet.

i disabled ipv6 altogether:

/etc/modprobe.conf
alias ipv6 off
alias net-pf-10 off

use both lines - you'll need them
 
Old 09-16-2004, 01:01 PM   #49
alberto2498
LQ Newbie
 
Registered: May 2002
Location: USA
Distribution: Mandrake 9.0
Posts: 26

Rep: Reputation: 15
Go to post # 47

Quote:
Originally posted by dkroft
i have been seeing this for a long time -
posted several times, but no good answer yet.

i disabled ipv6 altogether:

/etc/modprobe.conf
alias ipv6 off
alias net-pf-10 off

use both lines - you'll need them
http://www.linuxquestions.org/questi...47#post1146047
 
Old 09-16-2004, 03:35 PM   #50
littleking
Member
 
Registered: Jun 2003
Location: New Albany, OH
Posts: 190

Rep: Reputation: 30
The quick fix is to su to root and do two things:

#echo "net.ipv4.tcp_moderate_rcvbuf=0" >> /etc/sysctl.conf
#echo "net.ipv4.tcp_default_win_scale=0" >> /etc/sysctl.con
 
Old 09-16-2004, 04:30 PM   #51
dkroft
LQ Newbie
 
Registered: May 2004
Posts: 16

Rep: Reputation: 0
TCP Window size

If I include the sysctl statements, will that allow me to undo the /etc/modprobe additions, . . .

So . . . ( I am hesitant to ask ) . . . will I have IPv6 access?
 
Old 09-16-2004, 05:27 PM   #52
emeskay
LQ Newbie
 
Registered: Sep 2004
Distribution: SuSE 9.1
Posts: 22

Rep: Reputation: 15
I just installed SuSE 9.1 yesterday (as a stand alone system). I used it for a while and I did notice that web page downloads were discernably slower than I was used to on my Windows NT installation. (I have a cable connection (through a hardware router), so I'm used to virtually instantaneous downloads).

The more interesting thing is - when I rebooted into NT and started up a browser, I found that download speeds were distinctly slower even there. This happens with any browser - Opera, Mozilla, IE. It is also the case with Outlook Express. Moreover the download is not as smooth as it used to be - a lot more jerky. It also seems to affect mouse movement when downloading - it is almost as if the mouse is getting a very low priority - with all the processor cycles being taken up by the data transfer. If I try to move the mouse while any transfer is taking place, the movement is very jumpy - a very unnerving effect.

Since this started happening soon after the Linux install, I can only conclude that it was caused by it. Could it have anything to do with some BIOS setting (or maybe a setting on the router?) - changed by the Linux Kernel during installation - because those are the only two connections I can think of between the two OS's.

Last edited by emeskay; 09-16-2004 at 06:30 PM.
 
Old 09-17-2004, 03:03 AM   #53
emeskay
LQ Newbie
 
Registered: Sep 2004
Distribution: SuSE 9.1
Posts: 22

Rep: Reputation: 15
Turned out that it was the ACPI (Advanced Configuration and Power Interface - which presumably had been enabled during installation) that was causing the problem. For whatever reason, when ACPI is enabled, some IRQ's need to be re-routed via PCI bus (not that I really understand what that means - that was what was recorded in the Linux Startup Log. I assume NT needed to do the same). I think that was causing the mouse, keyboard, network card and video card to compete for resources which was causing the behaviour I described in NT.

Turning off ACPI in the BIOS solved the problem. Now I need to find a way to get Linux to turn it on when booting up and turn it off while shutting down. Any way to accomplish this? Thanks.

Last edited by emeskay; 09-17-2004 at 01:21 PM.
 
Old 11-13-2004, 05:47 PM   #54
Cybersurfer
LQ Newbie
 
Registered: Nov 2004
Posts: 1

Rep: Reputation: 0
Smile Possible solution

I was experiencing similar problems.

In my case I found that when using kernel 2.4, I had the Network Configuration set to Automatically obtain DNS information from provider and that was all that was required.

However I found with kernel 2.6 it is not quite that simple, I had to input the following info into the Network Configuration , as obtained from my ISP:

Primary DNS
Secondary DNS
Tertiary DNS

After doing the above, I had speed again

I am using Fedora Core 2

Ensure that Automatically obtain DNS information from provider is not selected
To do this go to
> System Settings
> Network
> select Device
> Edit
> General tab

Hope this helps

Last edited by Cybersurfer; 11-13-2004 at 06:14 PM.
 
Old 11-13-2004, 06:05 PM   #55
exvor
Senior Member
 
Registered: Jul 2004
Location: Phoenix, Arizona
Distribution: Gentoo, LFS, Debian,Ubuntu
Posts: 1,537

Rep: Reputation: 87
Yes indeed I have had the internet slow down bull S$it in fadora.

Its cool to see someone figured it out I gave up real soon on it tho. and went to slack where i had to make a kernel my self and never had this issue.



Like I say now that I know better " If it dont work right remake the kernel your self"
 
Old 11-13-2004, 08:15 PM   #56
qwijibow
LQ Guru
 
Registered: Apr 2003
Location: nottingham england
Distribution: Gentoo
Posts: 2,672

Rep: Reputation: 47
it seems they went back to the old TCP/IP window size in the latest (2.6.9) kernel.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow Internet Connection when Connecting to Internet on Browsers lennysokol Linux - Networking 8 04-09-2011 05:29 PM
Kernel 2.6.11 Internet Browsing is Slow !!! rip_dr_gonzo Linux - Networking 9 11-04-2007 11:02 AM
New Fedora Internet connection slow slow slow matrim Fedora 9 07-29-2005 02:39 PM
kernel 2.6: slow internet janW Mandriva 9 04-26-2004 10:02 PM
slow internet access. too slow!!! iamstinke Linux - Networking 2 01-01-2004 10:46 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 10:50 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration