LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 01-12-2016, 08:57 PM   #1
GNU+Linux-user
LQ Newbie
 
Registered: Jan 2016
Posts: 5

Rep: Reputation: Disabled
Kali can't connect to server using iceweasle browser-I get this message:


Can you tell me what I need to do to connect to the internet.
Not good at networking yet.

terminal message: http://pastebin.com/HP5we4CK.
 
Old 01-12-2016, 09:32 PM   #2
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Ubuntu MATE, Mageia, and whatever VMs I happen to be playing with
Posts: 19,314
Blog Entries: 28

Rep: Reputation: 6138Reputation: 6138Reputation: 6138Reputation: 6138Reputation: 6138Reputation: 6138Reputation: 6138Reputation: 6138Reputation: 6138Reputation: 6138Reputation: 6138
Are you running Kali in a VM? If so, what are the network settings for the virtual machine.

Otherwise, open a terminal and try these commands and, if the do not connect, post the results, being sure to surround them with "Code" tags which become available when you click the "Go Advanced" button at the bottom of the "compose post" window.

Code:
ping google.com  <--if it that doesn't work, try
ping 8.8.8.8   <--if it that doesn't work, try
traceroute google.com  <--if it that doesn't work, try
traceroute 8.8.8.8
 
Old 01-12-2016, 10:17 PM   #3
GNU+Linux-user
LQ Newbie
 
Registered: Jan 2016
Posts: 5

Original Poster
Rep: Reputation: Disabled
Yes Kali virtualbox. Also I should add it stopped suddenly and was working before.

Code:
 ping google.com
ping: unknown host google.com
bridged adapter eth0, cable connected.

ping 8.8.8.8 is still going.

Code:
traceroute google.com
google.com: Name or service not known
Cannot handle "host" cmdline arg `google.com' on position 1 (argc 1)

Code:
traceroute 8.8.8.8
traceroute to 8.8.8.8 (8.8.8.8), 30 hops max, 60 byte packets
 1  kali (192.168.1.39)  1140.295 ms !H  1140.267 ms !H  1140.244 ms !H

Last edited by GNU+Linux-user; 01-12-2016 at 10:36 PM.
 
Old 01-12-2016, 10:49 PM   #4
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Ubuntu MATE, Mageia, and whatever VMs I happen to be playing with
Posts: 19,314
Blog Entries: 28

Rep: Reputation: 6138Reputation: 6138Reputation: 6138Reputation: 6138Reputation: 6138Reputation: 6138Reputation: 6138Reputation: 6138Reputation: 6138Reputation: 6138Reputation: 6138
If pinging a domain fails and pinging an IP address works, that indicates that DNS is not working (domain names are not resolving to IP addresses). I don't have a VM of Kali or Ubuntu open right now, but I'd suggest looking into your DNS settings (if I remember correctly, Kali is based on Ubuntu).

This might help: https://help.ubuntu.com/12.04/server...iguration.html
 
Old 01-13-2016, 04:37 PM   #5
GNU+Linux-user
LQ Newbie
 
Registered: Jan 2016
Posts: 5

Original Poster
Rep: Reputation: Disabled
I tried theese steps didn't work


http://tecadmin.net/configure-dns-settings-on-ubuntu/#

Can I please get some steps to try.

Last edited by GNU+Linux-user; 01-13-2016 at 08:17 PM.
 
Old 01-13-2016, 09:38 PM   #6
frankbell
LQ Guru
 
Registered: Jan 2006
Location: Virginia, USA
Distribution: Slackware, Ubuntu MATE, Mageia, and whatever VMs I happen to be playing with
Posts: 19,314
Blog Entries: 28

Rep: Reputation: 6138Reputation: 6138Reputation: 6138Reputation: 6138Reputation: 6138Reputation: 6138Reputation: 6138Reputation: 6138Reputation: 6138Reputation: 6138Reputation: 6138
What is the output of these two commands?

Code:
cat /etc/network/interfaces
ifconfig -a
You should have to run the second one as root.
 
Old 01-15-2016, 12:42 AM   #7
GNU+Linux-user
LQ Newbie
 
Registered: Jan 2016
Posts: 5

Original Poster
Rep: Reputation: Disabled
I deleted and reinstalled

Last edited by GNU+Linux-user; 01-18-2016 at 06:35 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
[SOLVED] Tor browser suddenly wont connect to network on Kali kryyp Linux - Newbie 3 07-30-2015 11:54 AM
can`t connect to server in my browser,but succeed via ssh MeNok Linux - Newbie 4 08-16-2011 03:19 AM
can`t connect to server in my browser,but succeed via ssh MeNok Linux - Server 2 08-15-2011 11:01 PM
Alert Message when someoe connect to a server. bijit1709 Programming 6 04-22-2007 10:26 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 03:21 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration