-   Linux - Networking (
-   -   iwconfig and Slackware 9. (

m32 04-21-2003 09:50 PM

iwconfig and Slackware 9.
As the title of the post states, running Slackware 9. Card is a linksys wireless WPC 11. I ran this card in Slack 8.1 with no real troubles after configuring it (from searches on this board).

So, in Slack 9, none of the iwconfig commands seem to "stick." In other words,

iwconfig eth0 essid myessid
iwconfig eth0 enc my64bitencryptioncode

work just fine after I issue the commands as root. I can then issue the dhcpcd eth0 command, and get a connection.

However, as soon as I power down/reboot, these are lost. Its a laptop, so I can't leave it running all the time.

Any ideas? I skimmed the man pages, and couldn't glean where the iwconfig actually writes to.

Is there a text file where I can just store these values? Or should I just put them in rc.local?


spurious 04-21-2003 11:32 PM

You need to edit /etc/pcmcia/wireless.opts to permanently configure your wireless card. Slackware 9.0 on my notebook with a Netgear MA401 works fine.

Caveat: I'm a newbie, so I'm still experimenting with the wireless setup; if there is an easier way to configure wireless, please let me know.

m32 04-22-2003 06:32 AM

i'll give that a shot tonight, and update how it goes.

cclavey 04-22-2003 07:23 AM

WPC11 Sux
Yeah, I have an issue similar to yours. I have a WPC11 in Slack 9. The card is *sometimes* recognised by the kernel at bootup, other times, the firmware does not start. Anyway, when you run dhcpcd eth0, it should fill in your essid and all for you -- that's how mine worked. My problem is, I can't get a signal in places I used to. For example, my bedroom 2 floors above the base, I used to get a signal, but now I can't (after re-install). Last night, I re-installed Slack 9. I set it up to do a net install, with my WPC11, and *it worked fine*. But, this morning at school, I boot up, and not 40 ft. from the base, no signal. Any thoughts?

m32 04-23-2003 06:19 PM


Originally posted by spurious
You need to edit /etc/pcmcia/wireless.opts to permanently configure your wireless card. <snip>.

That seems to have done it *crossing fingers*. At first, it didn't, but then I deleted every 'example' in there (after of course backing up the original for a reference point), and went with the 'generic' example.

I got quite a few boot errors on it, when it broadcasted for dhcp, but then it got the ip, and we seem to be ok. (for now).


m32 04-23-2003 06:35 PM

well, update, that didn't do it.

would lose settings and connection, eventually.

Turned off encryption, and now things seem (again, crossing fingers) to be working again.

Living in the suburbs, I'm not too worried about having encryption on. But its kind of silly that I can't.

I see another chap below is having the same issues.

All times are GMT -5. The time now is 08:10 PM.