LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 08-09-2017, 06:02 AM   #1
Sol33t303
Member
 
Registered: Jul 2017
Distribution: gentoo
Posts: 115

Rep: Reputation: Disabled
Issues with setting up a SOCK5 tunnel proxy


When I enter
Code:
sudo ssh-copy-id Sol33t303@IP
I get this output
Code:
/bin/ssh-copy-id: ERROR: failed to open ID file '/root/.pub': No such file or directory
	(to install the contents of '/root/.pub' anyway, look at the -f option)
I tried putting in -f but it didn't change anything. Also when I put in
Code:
ssh -D PORT -f -C -N Sol33t303@IP
I get this output
Code:
ssh: connect to host IP port 22: Connection refused
I'm running Fedora 26 (everything in caps I excluded for privacy/security)
 
Old 08-09-2017, 06:48 AM   #2
Turbocapitalist
LQ Guru
 
Registered: Apr 2005
Distribution: Linux Mint, Devuan, OpenBSD
Posts: 7,210
Blog Entries: 3

Rep: Reputation: 3702Reputation: 3702Reputation: 3702Reputation: 3702Reputation: 3702Reputation: 3702Reputation: 3702Reputation: 3702Reputation: 3702Reputation: 3702Reputation: 3702
Do it without sudo. It does not provide extra "oomph" to your command. It is there to run programs as another user. If that other user does not have your keys then of course the program ssh-copy-id will not find them when run as that other user.
 
Old 08-09-2017, 07:40 AM   #3
Sol33t303
Member
 
Registered: Jul 2017
Distribution: gentoo
Posts: 115

Original Poster
Rep: Reputation: Disabled
Quote:
Originally Posted by Turbocapitalist View Post
Do it without sudo. It does not provide extra "oomph" to your command. It is there to run programs as another user. If that other user does not have your keys then of course the program ssh-copy-id will not find them when run as that other user.
I tried that before, here is the output without sudo
Code:
/usr/bin/ssh-copy-id: ERROR: ssh: connect to IP port 22: Connection refused
 
Old 08-09-2017, 08:17 AM   #4
Turbocapitalist
LQ Guru
 
Registered: Apr 2005
Distribution: Linux Mint, Devuan, OpenBSD
Posts: 7,210
Blog Entries: 3

Rep: Reputation: 3702Reputation: 3702Reputation: 3702Reputation: 3702Reputation: 3702Reputation: 3702Reputation: 3702Reputation: 3702Reputation: 3702Reputation: 3702Reputation: 3702
Ok. You'll have to first find a way to connect to the remote host with the regular client I presume you have the IP address correct there. What about the port and the packet filter? Is the SSH server listening on port 22 or a different port? What provisions have been made withe packet filter (aka firewall) to allow incoming connections?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Can i tunnel http via ssh without setting up a http proxy? ginda Linux - Networking 3 12-24-2009 05:25 AM
[SOLVED] Firewall restrictions on sock5 tunnel forwarding (through ssh) investor_me Linux - Networking 3 09-09-2009 08:29 PM
Creating proxy tunnel Fill Linux - Networking 2 04-02-2009 03:55 PM
SSL tunnel with transparent proxy daviddst Linux - Security 1 09-04-2004 04:22 PM
"socks5" -> "http" proxy protocol, or ssh tunnel to sock5 ? I'm beyond http p vmicho Linux - Networking 2 12-16-2003 06:32 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 07:47 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration