LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 11-07-2002, 11:28 PM   #1
mutantjazz
LQ Newbie
 
Registered: Nov 2002
Location: Denver, CO
Distribution: RedHat 8.0
Posts: 21

Rep: Reputation: 15
Question Issues: NFS on Redhat8.0



I am very new to this(4 evenings).... and have been browsing here every night for info so I am ready to listen.
Got my REdhat 8.0 installed ok, but it seems after I set up NFS it does not work anymore. I am using the gnome interface((Just practising before I go to terminal only)). So when I try to open NFS server there is no outcome... nothing happens, Icon is clicked and no response... I have tryed restarting NFS to no avail?!?!
NFS was set up to Give two users access to a tmp folder. NOw I can nolonger enter this setup to change it. Any suggestions?!?!

I can browse the network and have setup Samba usernames and Passwords, Do I even need to use NFS or should I disable it. The end result I want will be to use the linux box as a fileserver for Music and Backupfiles, and when I get DSL or cable use it as a second firewall for my home network.

--Linux Box--
Compaq Pesario,CYrix 250mhz CPU, 76MB Ram, Linksys 10/100 card LNETX100 plus linksys router, Ess-Solo1 Sound, 40gig WD, 3 partions, 2 NTFS and 1 ext3

Last edited by mutantjazz; 11-08-2002 at 12:24 AM.
 
Old 11-08-2002, 04:48 PM   #2
peter_robb
Senior Member
 
Registered: Feb 2002
Location: Szczecin, Poland
Distribution: Gentoo, Debian
Posts: 2,458

Rep: Reputation: 48
You choice of servers will depend on the clients talking to it.

Win based clients prefer to talk udp based smb protocol, supported by Samba
*nix clients can use a secure form of NFS (or samba). I would only use NFS if I was sure I could trust ALL the users not to bust the box.
There are several threads here at the moment about NFS weaknesses.

The rest of the networking uses netfilter and dns.
 
Old 11-08-2002, 08:40 PM   #3
mutantjazz
LQ Newbie
 
Registered: Nov 2002
Location: Denver, CO
Distribution: RedHat 8.0
Posts: 21

Original Poster
Rep: Reputation: 15
Thnx for the reply. I am using the box to serve only Win based machines... so I guess I will stick with Samba it is the only thing that has worked sofar?!!??!

I still have the questions about whether to disable NFS or if it is even possible to run Samba without NFS running...... plus the fact that my Machine has "Forgotten" how to even run the visual NFS interface is kinda bothering me, I click the NFS Server Icon, the HD makes a noise like it wants to start a program and then nothing?!?! Do I need to reinstall the NFS package or just remove it? get more memory maby???, it seems there are times when my machine won't start up a damn thing
I am a complete Newbie and realise there has to be something I did to make the application act or should I say NOT act in this manner? :-)

Thnx again for taking the time to help me out...
Peter< good name!
 
Old 11-08-2002, 09:03 PM   #4
peter_robb
Senior Member
 
Registered: Feb 2002
Location: Szczecin, Poland
Distribution: Gentoo, Debian
Posts: 2,458

Rep: Reputation: 48
That's cool...

NFS and Samba are like doors. Both do a file sharing job but that's all they have in common.

NFS runs from /etc/rc.d/init.d/ directory.
There are 3 services to disable, nfs, nfslock & portmap
From a terminal, type 'chkconfig --list' to get the correct spelling of those three
then 'chkconfig --level 2345 ~~~ off'
replacing ~~~ with the service name as it is spelled in the --list.
Then 'service ~~~ off' for each one.
 
Old 11-08-2002, 09:49 PM   #5
mutantjazz
LQ Newbie
 
Registered: Nov 2002
Location: Denver, CO
Distribution: RedHat 8.0
Posts: 21

Original Poster
Rep: Reputation: 15
Ok... nfs nfslock and portmap are all off 1--6. Will not need to play with that anytims soon. :-0

I now have a new issue.... My Box boots to localhost instead of "Beast". It was set up and running yesterday with Samba sharing a folder with Winxp and Win98 fine... now in NEtwork browser on the Win machines it comes up as Samaba Server (localhost) and won't let me it...
Have I changed a setting somewhere along my stomping through the system?
Once again thanx for the help?
 
Old 11-08-2002, 10:29 PM   #6
mutantjazz
LQ Newbie
 
Registered: Nov 2002
Location: Denver, CO
Distribution: RedHat 8.0
Posts: 21

Original Poster
Rep: Reputation: 15
Well Searching posts helped me out... I changed the permissions on the folder to Group Samba, and dar she blows!!! Win can see and access folder... Changed host to Beast.... but still get funny error on login.....as follows

"Could not look up internet address for BEast. This will prevent GNOME from operating correctly. It may be possible to correct problem by adding BEast to the file /etc/hosts."

Well did that and it still gives me this error every time I logon???
Thnx
 
Old 11-10-2002, 04:24 AM   #7
mutantjazz
LQ Newbie
 
Registered: Nov 2002
Location: Denver, CO
Distribution: RedHat 8.0
Posts: 21

Original Poster
Rep: Reputation: 15
Error message is gone..... just looked in all the forums to clues about which files to edit.
Winxp connects to my Samba share fine.... Win98 however is not working.... it is not accepting my password as valid?!?!

I have setup two Samba usernames and paswords, plus added these same names to my linux box users, plus put both of them in the group users. My Workgroups are all the same and the share is setup like this

[Shares]
comment = files
path = /server
valid users = +users
read only = no

Am I missing anything??? Win98 sees the linux Box, plus can browse to see the shared folder, but is denied acess due to incorect password...... I really hope there is a simple explaintion.... ie I am new and missed something obvius.... thnx in advance.
 
Old 11-13-2002, 06:42 AM   #8
peter_robb
Senior Member
 
Registered: Feb 2002
Location: Szczecin, Poland
Distribution: Gentoo, Debian
Posts: 2,458

Rep: Reputation: 48
Win 98 sends the logged on user name and password, rather than the box name.
I usually don't have a network logon, I prefer to use "Windows Logon" and an empty password field to get rid of the logon box..
To do this, I must logon at least once to register my username and password... before I change the logon choice in Control Panel, Networking.
Each boot I get the default user (me) without typing anything.
This is the name and password that samba needs to have...
 
Old 12-30-2002, 11:39 PM   #9
morpheous
LQ Newbie
 
Registered: Dec 2002
Posts: 1

Rep: Reputation: 0
Quote:
Originally posted by mutantjazz
Error message is gone..... just looked in all the forums to clues about which files to edit.

WHY DIDN*T YOU POST SOLUTION FOR /etc/hosts GNOME PROBLEM !?!?!?!


Winxp connects to my Samba share fine.... Win98 however is not working.... it is not accepting my password as valid?!?!

I have setup two Samba usernames and paswords, plus added these same names to my linux box users, plus put both of them in the group users. My Workgroups are all the same and the share is setup like this

[Shares]
comment = files
path = /server
valid users = +users
read only = no

Am I missing anything??? Win98 sees the linux Box, plus can browse to see the shared folder, but is denied acess due to incorect password...... I really hope there is a simple explaintion.... ie I am new and missed something obvius.... thnx in advance.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
logon issues: win98 - firewall - samba MichaelP Linux - Security 7 03-10-2005 05:29 PM
Netlogon issues > Samba 3.02a w/ Win98 HiroMasaki Linux - Networking 17 05-15-2004 06:28 AM
WIN98 & SAMBA Sharing nbjayme Linux - Networking 8 12-11-2003 04:50 AM
RedHat8 - IPTables - Win98 - configuration help please Bughin Linux - Networking 4 07-19-2003 03:51 PM
Cant get NFS working on RedHat8 OrganicX Linux - Networking 3 03-31-2003 11:24 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 03:42 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration