LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 08-09-2001, 07:14 PM   #1
simpilot
LQ Newbie
 
Registered: Aug 2001
Location: Dallas, TX
Distribution: RedHat 7.1
Posts: 8

Rep: Reputation: 0
IRQ's and IO Ports


I've setup my ethernet card's irq and base address with linuxconf and it seems to work well during that session once I reboot the system I get the...eth0 [FAILED] and also some line that mentions insmod failed. Is there any way of hard setting the irq and base address on my card so I can avoid the manual loading of everything..
 
Old 08-09-2001, 07:42 PM   #2
simpilot
LQ Newbie
 
Registered: Aug 2001
Location: Dallas, TX
Distribution: RedHat 7.1
Posts: 8

Original Poster
Rep: Reputation: 0
Actually insmod is failing to install module dmfe.0 at boot up. Once I manually do a "insmod dmfe" and "ifup eth0" everything is fine.
 
Old 08-09-2001, 07:47 PM   #3
DavidPhillips
LQ Guru
 
Registered: Jun 2001
Location: South Alabama
Distribution: Fedora / RedHat / SuSE
Posts: 7,163

Rep: Reputation: 58
is the .o file somewhere in the /lib/modules/2.4-xx/kernel/ folder where it can be loaded on bootup?

and you might want to run depmod -a after putting it there


or you can issue the command in /etc/rc.d/rc.local

you may want to use modprobe instead of insmod
 
Old 08-09-2001, 08:54 PM   #4
simpilot
LQ Newbie
 
Registered: Aug 2001
Location: Dallas, TX
Distribution: RedHat 7.1
Posts: 8

Original Poster
Rep: Reputation: 0
Hi David,

dmfe.0 is in /lib/modules/2.4.*/kernel/drivers/net/.....do I have to type "dmfe" after depmod -a ?
 
Old 08-10-2001, 04:59 PM   #5
DMR
Member
 
Registered: Jun 2001
Location: Fairfax, California
Distribution: RH 9.0, RH 7.3, Mandrake 8.0
Posts: 986

Rep: Reputation: 30
As far as trying to force IRQ and Base I/O, settings, you can try adding an option line in /etc/conf.modules below the "alias" line for your dmfe module (conf.modules is named modules.conf in some distros):
Code:
#conf.modules example snippet

alias eth0 dmfe
options dmfe io=0x280 irq=5
Replace the values for io= and irq= with the values you want.

If depmod is used with the -a, you don't specify a module name, because the -a causes depmod to build a dependency file for all modules found in the default module directories (man depmod for more info on that). As DavidPhillips suggested, you can put "depmod -a" in rc.local so you will always have a current dependency file.
 
Old 08-02-2004, 06:32 AM   #6
dpajares
LQ Newbie
 
Registered: Apr 2004
Location: uruguay
Distribution: debian
Posts: 26
Blog Entries: 1

Rep: Reputation: 15
hello:
Iam tying to install two network card dmfe (DAVICOM) in leaf bering.
with this dm
#cat modules
ne io=0x300,0x320 irq=5
but not found. i not have more ideas.
I think, te problem is with irq numbre, but i can error description,
Please Helpme.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to change IRQ's in Suse ManRSA Linux - Hardware 1 10-06-2005 04:51 AM
Does Grup have anything do to with IRQ's? danslinuxbox Linux - Hardware 1 03-03-2004 07:53 AM
Linux version of IRQ's? sunshine Linux - Hardware 1 12-17-2003 04:05 PM
Kernel Panic, IRQ's scarr3d Linux - General 8 10-22-2003 03:07 PM
Is there a way to change IRQ's? -=Sabin=- Linux - Hardware 9 07-29-2003 10:29 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 01:24 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration