LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 11-17-2007, 10:10 PM   #1
Stuckey
LQ Newbie
 
Registered: Nov 2007
Posts: 4

Rep: Reputation: 0
ipw3945 not working/Fedora 8


I'm trying to get an Intel ipw3945 card to work in Fedora 8, and I'm clearly too dumb to make it happen. I've spent hours trying various recommendations, but with little luck. Any help would be appreciated.

Here's some facts:

The system is a Dell Inspiron e1505 laptop. I've installed the following files via Yum:

ipw3945
ipw3945-kmdl-2.6.23.1-49
ipw3945-ucode
ipw3945d

Using Network Manager, I can see my card (listed as status 'ok') and can set up a device (only on wlan0, so far), but as yet have not been able to successfully activate it.

Here's where things get weird: I can start the regulatory daemon (/sbin/ipw3945d) from the command line, and when I do, my little 'wifi' LED starts flickering, indicating the card is on. At this point, if I click on the NM icon in my KDE system tray, a menu of available networks pops up. Unfortunately, I can't connected to any of them - and I still can't activate the card via system-config-network.

Possibly pertinent information follows:

# dmesg | grep ipw
ipw3945: Intel(R) PRO/Wireless 3945 Network Connection driver for Linux, 1.2.0d
ipw3945: Copyright(c) 2003-2006 Intel Corporation
ipw3945: Detected Intel PRO/Wireless 3945ABG Network Connection
ipw3945: Detected geography ABG (11 802.11bg channels, 13 802.11a channels)

# lsmod | grep ipw
ipw3945 179616 0
ieee80211 44268 1 ipw3945

# ps -ef | grep ipw
root 1303 2 0 20:23 ? 00:00:00 [ipw3945/0]
root 1304 2 0 20:23 ? 00:00:00 [ipw3945/1]
root 1305 2 0 20:23 ? 00:00:00 [ipw3945/0]
root 1306 2 0 20:23 ? 00:00:00 [ipw3945/1]
root 3116 1 0 20:26 ? 00:00:00 ipw3945d --quiet
root 7840 7430 0 21:42 pts/1 00:00:00 grep ipw

# modinfo ipw3945
filename: /lib/modules/2.6.23.1-49.fc8/updates/drivers/net/wireless/ipw3945.ko
license: GPL
author: Copyright(c) 2003-2006 Intel Corporation
version: 1.2.0d
description: Intel(R) PRO/Wireless 3945 Network Connection driver for Linux
srcversion: 50BCF40AD276E98D7DA8E93
alias: pci:v00008086d00004227sv*sd*bc*sc*i*
alias: pci:v00008086d00004222sv*sd*bc*sc*i*
depends:
vermagic: 2.6.23.1-49.fc8 SMP mod_unload 686 4KSTACKS
parm: antenna:select antenna (1=Main, 2=Aux, default 0 [both]) (int)
parm: disable:manually disable the radio (default 0 [radio on]) (int)
parm: associate:auto associate when scanning (default 0 off) (int)
parm: auto_create:auto create adhoc network (default 1 on) (int)
parm: led:enable led control (default 1 on)
(int)
parm: debug:debug output mask (int)
parm: channel:channel to limit associate to (default 0 [ANY]) (int)
parm: mode:network mode (0=BSS,1=IBSS) (int)


# lspci | grep 3945
0b:00.0 Network controller: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)

Thanks for any help.

Richard
 
Old 11-17-2007, 10:14 PM   #2
Stuckey
LQ Newbie
 
Registered: Nov 2007
Posts: 4

Original Poster
Rep: Reputation: 0
By the way, when I try to activate the card via Network Manager or enter "ifup wlan0" at the command line, the following error message appears:

Error for wireless request "Set Bit Rate" (8B20) :
SET failed on device wlan0 ; Invalid argument.

Determining IP information for wlan0... failed; no link present. Check cable?
 
Old 11-18-2007, 05:49 PM   #3
Stuckey
LQ Newbie
 
Registered: Nov 2007
Posts: 4

Original Poster
Rep: Reputation: 0
Finally made it work after several days of trying. Thanks to ipw3945 RPMs from Freshrpms, a few mods to ifcfg-wlan0, and a special note to turn of service network.

R. Stuckey
 
Old 11-22-2007, 12:03 AM   #4
jwc
LQ Newbie
 
Registered: Nov 2007
Posts: 1

Rep: Reputation: 0
Quote:
Originally Posted by Stuckey View Post
Finally made it work after several days of trying. Thanks to ipw3945 RPMs from Freshrpms, a few mods to ifcfg-wlan0, and a special note to turn of service network.

R. Stuckey
How did you manage to do this? I have almost an identical set of symptoms and have not been successful figuring out the issue. What did you change in the ifcfg-wlan0 config file? Is it something in there?

Thanks,

--jwc
 
Old 11-28-2007, 01:07 PM   #5
Stuckey
LQ Newbie
 
Registered: Nov 2007
Posts: 4

Original Poster
Rep: Reputation: 0
Hey jwc, I'm no Linux expert - I just played hit or miss until something worked. Someone who knows more may be able to to give you better guidance.

So with that fair warning, here are the steps that got things working for me:

1. If your machine has a hotkey on/off switch for wireless, I'd recommend disabling it to avoid conflicts. To do this. restart your machine, enter BIOS setup, and disable WIFI hotkey (by default, Fn + F2 turned my wireless on or off)

2. Remove ipw3945 components via Yum ($ yum remove ipw3945)

3. Configure freshrpms repo for Yum:

$ sudo rpm -vhi http://ftp.freshrpms.net/pub/freshrp....fc.noarch.rpm

$ sudo rpm --import http://freshrpms.net/RPM-GPG-KEY-freshrpms

(To avoid update conflicts, you'll want to configure yum to disable the freshrpms repository by default and enable it explicitly in Yum commands when you want to access it.)

4. Install freshrpms ipw3945 components via yum:

$ yum --enablerepo=freshrpms install ipw3945

(Yum displays a list of packages and dependencies - make sure that dkms-ipw3945 is included. If it isn't, install it separately afterwards.

5. Restart machine to incorporate new components.

These next steps were key for me.

6. If it's on, turn off 'network' service ($ service network stop)

7. Check status of NetworkManager and NetworkManagerDispatcher - if not running, turn them on (you may want to have these automatically turned on at startup and have 'network' automatically turned off - NetworkManager can manage both wired and unwired network connections).

8. Activate card and kernel module ($ /sbin/ipw3945d --quiet).

If it worked, you should now be able to browse available networks. I just click my nm-tool icon in the icon tray to see a list. Hope it works for you.

Assuming it works, you can turn off the card thusly:

$ rmmod ipw3945
$ /sbin/ipw3945d --kill

Good luck,
Stuckey
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
ipw3945 working herbietheferret Linux - Laptop and Netbook 3 09-02-2007 04:07 PM
lenny +ipw3945 +amd64 not working cybrjackle Debian 5 08-05-2007 10:36 AM
ipw3945 - mode monitor not working slack_baby Linux - Wireless Networking 5 07-13-2007 11:59 AM
Fedora 6 and ipw3945 HELP! zmanods Fedora 3 02-19-2007 01:14 AM
ipw3945 working, really really badly Caboose Linux - Laptop and Netbook 8 02-07-2007 01:52 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 11:19 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration