LinuxQuestions.org
Help answer threads with 0 replies.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 11-14-2015, 01:00 AM   #1
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Linux 11 (Bullseye)
Posts: 3,407

Rep: Reputation: 141Reputation: 141
IPV4 network name problem


I've just installed Debian Jessie on 3 systems. On the two of them that I did an upgrade install, my ATT U-Verse router shows the IPV4 name. On the one I just installed tonight, it's showing the MAC address. The result is that I can't address the third machine by xxx.attlocal.net unless I add that to my hosts files.

I've seen some suggestions that this is a netbios name issue and the suggestion was to install samba. Still no joy. Any suggestions?
 
Old 11-14-2015, 01:56 AM   #2
berndbausch
LQ Addict
 
Registered: Nov 2013
Location: Tokyo
Distribution: Mostly Ubuntu and Centos
Posts: 6,316

Rep: Reputation: 2002Reputation: 2002Reputation: 2002Reputation: 2002Reputation: 2002Reputation: 2002Reputation: 2002Reputation: 2002Reputation: 2002Reputation: 2002Reputation: 2002
What's an IPv4 name? I know about IPv4 addresses, but not names. Do you mean hostname, or DNS name?
Where does this name come from? Do you register it somewhere?
How did you register the name of the third system?
And do these systems have IPv4 addresses? If yes, do they come from the router?

Here is my guess, based on a heap of assumptions: The router doesn't see the IP address of #3, perhaps because the computer isn't configured to get its address via DHCP.
 
Old 11-14-2015, 02:09 PM   #3
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Linux 11 (Bullseye)
Posts: 3,407

Original Poster
Rep: Reputation: 141Reputation: 141
Hmm. I just checked it again, and it's finally the right value for the third system. I'm still in the dark as to why. My guess is that the U-Verse router has some time constraint on when it updates it dhcp tables.

As to what I'm talking about: My understanding is that the ipv4 device name is the machine's hostname. When the router doesn't know the hostname, it uses the MAC address prepended by "unknown". Without the ipv4 device name, you cannot address a device by its FQDN. Maybe this will explain it a bit better. It's taken from the U-Verse router's Device List page:

Code:
MAC Address	00:21:69:01:12:c0
IPv4 Address / Name	192.168.1.77 / unknown0021690112c0
Last Activity	Sat Nov 14 13:58:35 2015
Status	on
Allocation	dhcp
Connection Type	Ethernet lan-1
 
MAC Address	00:22:3f:ec:bf:1f
IPv4 Address / Name	192.168.1.70 / wendy
Last Activity	Sat Nov 14 13:58:35 2015
Status	on
Allocation	dhcp
Connection Type	Ethernet lan-1
The device I was having problems with is 192.168.1.70, which has a hostname of wendy. Until this morning, it was displaying the MAC ID instead of "wendy". Notice for 192.168.1.77 the MAC ID is displayed, prepended by "unknown". That device is a ProLogix GPIB adapter, and has no IPV4 Device Name.

Added:

As to how it's added or where it comes from, I don't know. It could be just the hostname and it took a long time for the U-Verse router to register it, or it could be that samba was needed. I just don't know.

Last edited by Quakeboy02; 11-14-2015 at 02:11 PM.
 
Old 11-14-2015, 02:31 PM   #4
wpeckham
LQ Guru
 
Registered: Apr 2010
Location: Continental USA
Distribution: Debian, Ubuntu, RedHat, DSL, Puppy, CentOS, Knoppix, Mint-DE, Sparky, VSIDO, tinycore, Q4OS,Manjaro
Posts: 5,583

Rep: Reputation: 2685Reputation: 2685Reputation: 2685Reputation: 2685Reputation: 2685Reputation: 2685Reputation: 2685Reputation: 2685Reputation: 2685Reputation: 2685Reputation: 2685
Network Nerds, Attack

Just some clarity, I hope:
hostname is the name by which a server knows itself. At one time this also had to do with the FQDN (Fully Qualified Domain Name) which I believe you called Network Name. (As good a name as any other, I guess.) The FQDN is really the name of an address or interface. They SHOULD match, if your host has only one interface. I have servers with a dozen!

While the server knows itself by a hostname, and this should match the FQDN of one interface, there may be a different FQDN for each interface that has a valid TCP IP address. DNS resolution maps (generally, or in the most common case) one name to one address.

In the case of DHCP assigned addressing, the hostname may have NOTHING to do with the FQDN. It may, but that depends upon how the DHCP server is configured, and the DNS communications involved. If the engines are separate, there may be a lag time between assigning an address and name to a mac, and the availability of resolution on the DNS tables. Some integrated system cut the lag to milliseconds.

I mostly avoid the whole mess by using DHCP only for things where the name and address so not really matter, as long as they work. (Cell phones, laptops, most general client workstations and devices) and using static addressing and naming for servers.

Does any of this help figure out why the delay in your specific case? No idea. I do not have an instance of that device to test, know little about your configuration, and would be guessing in the dark.
My hope is that the discussion helps you figure it out.
 
Old 11-14-2015, 02:43 PM   #5
michaelk
Moderator
 
Registered: Aug 2002
Posts: 25,674

Rep: Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892
Typically, the DHCP client (dhclient) when it requests an IP address from the DHCP server sends the computer's host name as configured in the dhclient.conf file. I assume if the device sends an empty or null host name the U-Verse router will default to unknown<MAC>. Nothing to do with samba.
 
Old 11-14-2015, 02:45 PM   #6
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Linux 11 (Bullseye)
Posts: 3,407

Original Poster
Rep: Reputation: 141Reputation: 141
Quote:
Originally Posted by wpeckham View Post
Just some clarity, I hope:
<snip>
I mostly avoid the whole mess by using DHCP only for things where the name and address so not really matter, as long as they work. (Cell phones, laptops, most general client workstations and devices) and using static addressing and naming for servers.
Hi wpeckham,
I've thought about doing this many times over the years, but I've stubbornly stuck with dhcp. This is the first time I've been bitten. OTOH, I noticed last night that it's possible to set an individual ip to static instead of dhcp, on the U-Verse router. That doesn't fix the delay, of course, but it does make the ips stable.

So, what do you do about addressing? Do you put all your hostnames in each of your machines /etc/hosts files? Granted I've only got three, so it's not a big deal. All three of these devices are servers of one type or other. Two are nfs fileservers, and the other one runs the mysql server. It's just that having the names on the U-Verse router is so much more convenient - until there's a problem, of course. =)
 
Old 11-14-2015, 02:51 PM   #7
wpeckham
LQ Guru
 
Registered: Apr 2010
Location: Continental USA
Distribution: Debian, Ubuntu, RedHat, DSL, Puppy, CentOS, Knoppix, Mint-DE, Sparky, VSIDO, tinycore, Q4OS,Manjaro
Posts: 5,583

Rep: Reputation: 2685Reputation: 2685Reputation: 2685Reputation: 2685Reputation: 2685Reputation: 2685Reputation: 2685Reputation: 2685Reputation: 2685Reputation: 2685Reputation: 2685
I cheat, of course...

I run my own DHCP and caching DNS server (debian, with dnsmasq, but there are other solutions equally good) and do not force (allow) the router to do that job. That allows me to control the naming, addressing, and resolution without very much work.


But then, I do this for FUN! ;-)
 
Old 11-14-2015, 02:51 PM   #8
Quakeboy02
Senior Member
 
Registered: Nov 2006
Distribution: Debian Linux 11 (Bullseye)
Posts: 3,407

Original Poster
Rep: Reputation: 141Reputation: 141
Quote:
Originally Posted by michaelk View Post
Typically, the DHCP client (dhclient) when it requests an IP address from the DHCP server sends the computer's host name as configured in the dhclient.conf file. I assume if the device sends an empty or null host name the U-Verse router will default to unknown<MAC>. Nothing to do with samba.
Hi michaelk,
Thanks for your post. I had completely forgotten about that file. Here is the active contents of /etc/dhcp/dhclient.conf
Code:
option rfc3442-classless-static-routes code 121 = array of unsigned integer 8;

send host-name = gethostname();
request subnet-mask, broadcast-address, time-offset, routers,
	domain-name, domain-name-servers, domain-search, host-name,
	dhcp6.name-servers, dhcp6.domain-search,
	netbios-name-servers, netbios-scope, interface-mtu,
	rfc3442-classless-static-routes, ntp-servers;
So, I guess that means that it's simply down to a delay in the U-Verse box.
 
Old 11-14-2015, 02:54 PM   #9
michaelk
Moderator
 
Registered: Aug 2002
Posts: 25,674

Rep: Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892Reputation: 5892
Most likely...
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
In tspc ipv6 tunnelling, does tunnel broker required for ipv4 to ipv4 communication? nyk.mat Linux - Newbie 2 08-13-2013 09:48 PM
IPV4 Network Numbering theKbStockpiler Linux - Networking 4 01-16-2012 02:07 PM
Disabling IPv4 packet forwarding: net.ipv4.ip_forward = 0 (CentOS 5.5) troiwulful Red Hat 3 11-22-2010 11:04 AM
no network IPv4 in hardy wabbalee Linux - Networking 0 04-26-2008 08:57 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 04:43 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration