-   Linux - Networking (
-   -   Iptables - unable to use target ULOG on Fed 17 (

Lantzvillian 09-14-2012 06:20 PM

Iptables - unable to use target ULOG on Fed 17
Hi all,

I am trying to get iptables to use target -j ULOG via a script and it is returning: Bad argument `ULOG'

My firewall rule looks something like:
iptables -A $CN_AnULOG -j ULOG --ulog-nlgroup $ULOG_NLGROUP --ulog-cprange $ULOG_SNAP_LEN --ulog-prefix $PREFIX_STR

Assuming that this is correct (which on Openwrt it is), I tried ulog1.24 and ulog2.x and verified that ipt_ULOG is loaded through lsmod - which it is. I even recompiled my kernel/iptables with ULOG support.

Does anyone know why this is happening? or perhaps that this is a know issue for Fedora 17 x64?


unSpawn 09-15-2012 01:08 PM

The rule itself looks OK. Maybe it's something with your variables if you load rules automagically? Do any of the logs show anything related?

Lantzvillian 09-17-2012 05:44 PM

Thanks - that is exactly what I thought and you are correct.. somehow the strings in the variables were not be substituted correctly! I'll mark the thread as solved!

All times are GMT -5. The time now is 12:39 AM.