-   Linux - Networking (
-   -   ipop3 only granting one user access (

KnightCrusader 11-25-2003 03:29 AM

ipop3 only granting one user access
Hello all, I am somewhat still new to the mail server side of Linux, but experienced in mail serving on Windows platforms. I moved to Linux so I could have a stable server to do my e-commerce. I have been working for weeks and researching and finally have gotten my mail server up - almost that is.

Sendmail is configured, and accepting all incoming and sending outgoing mail to the right places, and keeping unwanted users out. My problem is with the ipop3 daemon. It works fine, except for the fact that it will only accept connections authorized for the first user I tested the system with, and no one else. I started by using Outlook XP on my Windows machine to test the connection, and when it failed i went to telnet and manually plugged POP3 commands in to see what the error was.

this is my session:
+OK POP3 Server [] v2001.78 server ready
USER defaultuser
-ERR unknown AUTHORIZATION state command
USER defaultuser
+OK User Name Accepted, Password Please
PASS password

(i wait a few seconds)

-ERR bad login

I have tried all the other users set up on my system, and it won't work, I just keep getting the same errors listed above. Just the first one I tested with will be accepted. Could there be a lock on the files somewhere, or an option designed to do this that I accidently turned on? I can't figure it out.

I assume my firewall settings are correct, since the one user can get in. I have even deleted and added new users to no avail. I have deleted the account that works and then recreated it, and it is still the only one that works. I have restarted all the services many times over and reread the config files until my eyes hurt. I also tried switching to the pop3s daemon, and it does the same thing.

Any help is appriciated.


KnightCrusader 11-25-2003 04:26 AM

OK I take part of my original post back. The bad login was dut to the fact that I put in the wrong password. But after fixing that, Outlook or OE still won't connect, but the manual way over telnet now works. Also as a test, I enabled Imapd and i can log into any user account on my server to retrieve mail. I still rather use POP3. Any ideas?

All times are GMT -5. The time now is 08:18 PM.