-   Linux - Networking (
-   -   internet via dhcp from a linksys router (

GeNeSISSIE 09-03-2003 04:07 AM

internet via dhcp from a linksys router
Hey all, I have a router hooked up to the ethernet jack in my wall and it shares internet via DHCP to my desktop (via cat5 cable) and my laptops (through wireless). The router is Linksys BEFW11S4 ver 3. This information is probably not useful, but I figured I might as well put it.

My problem is that when I boot into linux, I can't get online I guess because linux is not detecting the DHCP from the router and accessing the internet through it. In Windows XP, everything works automatically, so I don't know what I have to do manually in linux in order to get my internet working. I have tried running dhcpcd which does nothing apparently (just runs for a while with nothing verbose and then stops and returns to bash prompt). From reading FAQS online about configuring internet with DHCP, I always heard that running dhcpcd would do the job. Well, it didn't...which is why I am here asking. So if anyone knows anything that can get me online and running, PLEASE help me out! Thanks =)

ptwobrussell 09-05-2003 11:15 AM

you have been typing in your eth after "dhpcd", right? e.g. "dhpcd eth1" or whatever, not just "dhpcd"? You may also want to try "dhclient" with your eth after it as well. As a last resort, if you can figure out how to have your router assign static IP addresses to your machines, you can just cut through all of the red tape and go that direction (run netconfig on the machines as well). Man pages are useful for just about all of this stuff.

sidmark-2850 09-05-2003 11:47 PM

Dhcpd is the dhcp daemon. You do not want to run dhcpd on any of your boxes because it will mess up the dhcp from the router. You need to make sure that you have either dhcp client on you box. I think it is called dhcpcd or dhclient or something like that. What happens if you type ifconfig in a command prompt? It could be that your card is not detected. What kind of network card do you have? If you know for a fact that your card is detected, set your address statically and try to ping the router. Make sure that you give a high address so it won't conflict with an existing machine on the network. It could also be a firewall issue. I haven't played with mandrake in a while but if you set the security level too high, you won't be able to make connections unless you explicitly allow it in the firewall rules.

gts116 11-16-2003 11:37 PM

I'm having the same problem as our boy G up there... I'm getting nothing from the router at all.. I've gone through all of the FAQ's and other postings with no avail. DHCPCD only id's my MAC then hangs.. dhclient sits there ony to state that 'NO DHCPOFFERS RECEIVED' The hardware is good. My router is good. I'm currenting on my W98 machine so obviously there is a hot signal. My redhat firewall is completely down. I just don't know what to do. I've also tried reseting ifconfig etc... NOTHING... I'm so terribly lost! Any ideas? Thanks in advance

zanzabros 11-24-2004 06:19 AM

maybe password?
i had the same problem with a d-link dsl-504, i downloaded from the net an utility that allowed me to change the router access password to blank instead of the default one, and then i was able to connect to it during my linux installation and maybe you have the same problem, maybe not, hope this will be useful, cheers :D

geomatt 11-24-2004 07:15 AM

Can you get access to the router via a browser? Try typing the ip address of the browser into the address bar of your web browser. That's what I use to reconfigure my router.


bdogg 11-24-2004 09:36 AM


Originally posted by sidmark-2850
Dhcpd is the dhcp daemon. You do not want to run dhcpd on any of your boxes...
He actually was running dhcpCd which is dhcp-CLIENT-daemon, which is different from dhcpd, which is dhcp-daemon, so yes, he wants to run dhcpcd if it will solve his problem.

Can you paste your lspci and ifconfig commands? Also, a trivial question, but it has been known to resolve a small percentage of networking problems. Are the little lights on your network card on?

All times are GMT -5. The time now is 09:20 AM.