LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 01-30-2004, 11:26 AM   #1
avols143
Member
 
Registered: Jan 2004
Location: Oslo, Norway
Posts: 57

Rep: Reputation: 15
Internet Setting...how???????


Hello, I am using Redhat Linux 9 with daul boot with WindowsXP. My internet is working properly in WindowsXP but not in Linux...
I have a ADSL with username and password and have an External Modem.
My LanCard is connected with this External Modem. I am trying to setup internet in linux from many days, but I can't.

** At booting time of Linux the following service is not working..
Bringing up interface eth0 [Fail]

In my Hardware Browser I have the following information in the Network Device.

Network Device: RTL-8139/8139C/8139C+
Manufacturer: Realtek
Driver: 8139too
Device: /dev/eth

And I checked the following commands to check Internet Configurations.....

[root@localhost temp]# insmod 8139too
Using /lib/modules/2.4.20-8/kernel/drivers/net/8139too.o
insmod: a module named 8139too already exists

[root@localhost /]# lspci -v
Realtek Semiconductor Co., Ltd. RTL-8139/8139C/8139C+ (rev 10)
Subsystem: Realtek Semiconductor Co., Ltd. RT8139
Flags: bus master, medium devsel, latency 32, IRQ 11
I/O ports at a000 [size=256]
Memory at ef010000 (32-bit, non-prefetchable) [size=256]
Expansion ROM at <unassigned> [disabled] [size=64K]
Capabilities: [50] Power Management version 2

[root@localhost /]# ifconfig
eth0 Link encap:Ethernet HWaddr 00:50:FC:63:4E:6B
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:363 errors:0 dropped:0 overruns:0 frame:0
TX packets:327 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:100
RX bytes:22356 (21.8 Kb) TX bytes:21216 (20.7 Kb)
Interrupt:11 Base address:0x9000

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:7935 errors:0 dropped:0 overruns:0 frame:0
TX packets:7935 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:541536 (528.8 Kb) TX bytes:541536 (528.8 Kb)

[root@localhost /]# netstat -i
Kernel Interface table
Iface MTU Met RX-OK RX-ERR RX-DRP RX-OVR TX-OK TX-ERR TX-DRP TX-OVR Flg
eth0 ..1500 0...369 .....0 ..........0 .........0 .....327 ......0 .........0 .......0 .....MRU
lo .....16436 0 ..9645 ....0 .........0 .........0 ....9645 ......0 .........0 .......0 ....LRU

**************************



Can any body solv my problem........???????

Last edited by avols143; 01-30-2004 at 11:30 AM.
 
Old 01-30-2004, 09:45 PM   #2
gladelson
LQ Newbie
 
Registered: Jan 2004
Distribution: redhat (fedora)
Posts: 4

Rep: Reputation: 0
internet

For some reason, your ethernet card (eth0) is not being assigned an ip address. If it were, the second line of the output from ifconfig should list the ip address. Your system my be setup to get the address by DHCP but that is failing during initialization of the NIC. That's the fail message you are getting. I don't know how your DSL is supposed to work, but if you are not able to use DHCP, you might have to manually set and ip address.
 
Old 01-30-2004, 09:57 PM   #3
bstempi
LQ Newbie
 
Registered: Feb 2003
Location: Horsham, PA
Posts: 28

Rep: Reputation: 15
Since you're running Redhat 9, i'm going to assume that you have access so some gui. if you click the hat (start) button->system settings->network, you'll find a nice graphical interface for diagnosing your card, etc. Since you're using a connection being a router, you have to tell linux the ip address of your gateway (in this case, your router is the gateway), any you may need to manually set up an ip. I find that once it knows where the gateway is, it can obtain one by itself, but you may want a static ip, idk. Anyway, when you bring up the dialog, you'll see your device. you highlight eth0 and click the edit button in the toolbar. on the very bottom, you'll see default gateway address. this is where you're routers ip goes (most commonly 192.168.0.1). 2 lines above that is your IP address and above that is the option to use DHCP, or a manual config. If you can't get it to obtain an address, then assign it one. any 192.168.0.xxx address will do. after you make thses changes, click ok. then, click on file->save to save your new settings. you'll then be told that you may need to restart he device or machine for the new config to kick in. you can do this by clicking on eth0 and clicking the 'deactivate' button. after it's been deactivated, just activate it again. I hope this solves your problem.
 
Old 01-30-2004, 09:59 PM   #4
bstempi
LQ Newbie
 
Registered: Feb 2003
Location: Horsham, PA
Posts: 28

Rep: Reputation: 15
oh, and if you don't have a router inbetween you and your modem, then find the modems address and use that as the gateway.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Help setting up Internet doody Linux - Newbie 14 09-01-2004 01:02 PM
setting up internet drowninglessons Mandriva 3 08-10-2004 02:55 AM
Setting up internet smoko Linux - Newbie 10 04-18-2004 01:13 AM
setting up internet utsav_verma Linux - Newbie 7 04-13-2004 12:31 AM
Help with setting up internet Ekim Gram Linux - Newbie 1 05-08-2003 06:49 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 01:35 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration