-   Linux - Networking (
-   -   Internet is very slow after resuming from suspend (

jsteel 06-14-2009 10:48 AM

Internet is very slow after resuming from suspend

After suspending my laptop and resuming, the Internet is very slow. A reboot fixes the problem.

I get about 600 to 800KB/s down normally. After resuming from suspend this turns into about 20 to 30KB/s.

After a suspend/resume I noticed the following after running ifconfig. (The numbers increase the more I use the Internet).
RX packets:1210 errors:78 dropped:155 overruns:78 frame:0

Before a suspend/resume there are no errors etc. This problem happens both when using the wired and wireless connections.

I am using Debian unstable. I would report a bug but I am not sure what package the bug would be in. After a suspend/resume I have tried restarting the networking, manually configuring the network etc. etc. but nothing seems to get it going at its normal speed again apart from a reboot.

The computer is an Acer TravelMate 290. I would like to find where the problem is so that I can either have a workaround and/or report a bug.

Thank you

GlennsPref 06-15-2009 10:09 AM

Hi, I also have this problem sometimes.

The network traffic slows down after the screensaver has been on for a while, but I don't use suspend/resume.

I usually put this down to dns errors,

when you wrote that you restart the network, does that imply the dns lookup too.

Mine does not, and I have to do it manually.

service ldapdns stop && service ldapdns start

your dns program may be different.

Hope this helps, regards Glenn

jsteel 06-15-2009 11:43 AM

Thanks, but surely once a download is in progress it no longer relies on DNS?

tekhead2 06-15-2009 01:38 PM

Do you know what type of network card it is? I'm asking because I know there are a lot of network cards that will "power down" when on battery power or on standby. Most of the Dell Broadcom adapters can do this at a bios level even I believe.

jsteel 06-15-2009 02:23 PM

The wireless card is an Intel Pro Wireless 2200, but this problem also happens when using my wired connection so I don't think that it's a problem with a network device.

GlennsPref 06-15-2009 05:33 PM

I think it is your isp throttling.

Occurs for different reasons, over-subscription and deterring p2p torrents.

I didn't realise you meant during a download.

regards Glenn

jsteel 06-15-2009 06:01 PM

But after a reboot it is fine, so there must be some kind of software-related problem. I'm going to try another distribution with similar package versions and see if that is OK or not.

By the way I have tried unloading many modules and stopping many services before suspending and reloading them afterwards, but this does not help.

jsteel 06-16-2009 08:35 AM

I've tried this with Fedora 11 and it has the same problem as Debian Unstable. I've tried another laptop (same model) and this also has the same problem. This is very strange. It must be something to do with this Acer 290 if noone else is having this problem.

GlennsPref 06-16-2009 05:38 PM

Hi, I'd say it is a power saving measure for the laptop.

it may have something to do with the kernel modules, acpi, apm

or the settings In bios as well. (wake on lan)?

lsmod will show what modules are loaded.

you can blacklist modules from loading

/etc/modprobe.d/blacklist* (something)

have a look at the file to see how it is used.

It will depend on your system what and how you use it.

That's all I have, I'm afraid.

Regards Glenn

jsteel 06-18-2009 03:16 AM

It turned out to be a problem with the Linux kernel version 2.6.29. I installed 2.6.30 (the latest) and it now works perfectly!

All times are GMT -5. The time now is 03:06 AM.