LinuxQuestions.org
Download your favorite Linux distribution at LQ ISO.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 03-02-2006, 06:44 PM   #16
ftwilliam
LQ Newbie
 
Registered: Mar 2006
Distribution: Gentoo
Posts: 18

Original Poster
Rep: Reputation: 0

I don't think that is problem since they can share the same irq without problem. In fact it is set like that as default in my bios. Before getting this computer, I had a thinkpad t21 and it was set up the same way and I was not having any problem with that. I think the problem is somewhere else.
Thanks again. Please I am still looking for suggestion concerning my problem. So annoying it is.
 
Old 03-02-2006, 07:02 PM   #17
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 377Reputation: 377Reputation: 377Reputation: 377
you're right... i did some googling and it seems the IRQ 11 thing is normal for this laptop... i don't know what else to tell you, i mean, if it works fine with other distros then i must assume there's something wrong with your current kernel config/compile... i seriously doubt it would be an application-level issue, it does sound like a kernel/module thing... are you using the latest kernel?? does gentoo have any pre-built kernel/module packages you could try?? if you can get it to work fine by booting a pre-built kernel then at least you've narrowed the problem down and can then begin to take a serious look at your config...
 
Old 03-02-2006, 08:03 PM   #18
ftwilliam
LQ Newbie
 
Registered: Mar 2006
Distribution: Gentoo
Posts: 18

Original Poster
Rep: Reputation: 0
I think what I am going to do is to downgrade to a kernel that I know was working with the thinkpad t21 that I was using and stick with that kernel. until they release a major update. Hopefully it will work. I will keep y'all inform in case somebody else come across the same problem
Thanks y'all
 
Old 03-03-2006, 08:52 AM   #19
ftwilliam
LQ Newbie
 
Registered: Mar 2006
Distribution: Gentoo
Posts: 18

Original Poster
Rep: Reputation: 0
upgrade or downgrad do not do resolve my problem. I am so much getting out of solution. Please I am still waiting on your suggestions.
Thanks y'all
 
Old 03-03-2006, 08:58 AM   #20
ftwilliam
LQ Newbie
 
Registered: Mar 2006
Distribution: Gentoo
Posts: 18

Original Poster
Rep: Reputation: 0
And something weird happen. It did the same thing while I was using livecd. I hope I do not have hardware problem. I am thinking about changing the cable that I am using and see what happen
 
Old 03-03-2006, 12:35 PM   #21
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 377Reputation: 377Reputation: 377Reputation: 377
have you tired a knoppix cd?? this was suggested a long time ago...
 
Old 03-04-2006, 08:25 AM   #22
ftwilliam
LQ Newbie
 
Registered: Mar 2006
Distribution: Gentoo
Posts: 18

Original Poster
Rep: Reputation: 0
I haven't tried the knoppix cd yet. But I will do if I do not get a solution. Right now I am installing the vanilla sources of linux to see if it makes a difference.
I even install the drivers from intel itself, but it does not fix my issue. This so weird
 
Old 03-04-2006, 07:06 PM   #23
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 377Reputation: 377Reputation: 377Reputation: 377
well, please let us know how it goes... good luck man...
 
Old 03-05-2006, 12:40 AM   #24
ftwilliam
LQ Newbie
 
Registered: Mar 2006
Distribution: Gentoo
Posts: 18

Original Poster
Rep: Reputation: 0
my situation is kind of desperate, I have tried the knopix cd and I get the same stuff. It is even worse with knoppix. I am out of solution
If you guys have something that can help me, please do not hesitate.
 
Old 03-05-2006, 02:08 AM   #25
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 377Reputation: 377Reputation: 377Reputation: 377
does your BIOS have a "PnP OS" option?? if it does, set it to "No"...

does it work fine in windows?? just trying to rule-out faulty hardware...
 
Old 03-05-2006, 02:23 AM   #26
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 377Reputation: 377Reputation: 377Reputation: 377
one thing you should definitely try at least is the ubiquitous noapic kernel boot parameter...
 
Old 03-05-2006, 12:54 PM   #27
ftwilliam
LQ Newbie
 
Registered: Mar 2006
Distribution: Gentoo
Posts: 18

Original Poster
Rep: Reputation: 0
hi sorry for my late response.
I have already disable the apic from my kernel. In my bios I do not see any PnP OS option, but I have set in my bios for PCI IRQ auto, so I guess linux is the one who choses the irq. And I use ACPI PNP to have those IRQ set up in my kernel.
And also HPET timer was disable as I read user online having problem with RTC and HPET, but it did not fix my issue.
I am still left with the same problems.
I am still hacking into my kernel configuration, hopefully I will come accross the problem.
Please sugestions are very welcomed.
Thanks again guys !!!

GO LINUX !!!
 
Old 03-05-2006, 12:56 PM   #28
ftwilliam
LQ Newbie
 
Registered: Mar 2006
Distribution: Gentoo
Posts: 18

Original Poster
Rep: Reputation: 0
Also I want to add that it was working fine under window:-(
 
Old 03-05-2006, 01:53 PM   #29
ftwilliam
LQ Newbie
 
Registered: Mar 2006
Distribution: Gentoo
Posts: 18

Original Poster
Rep: Reputation: 0
if this can help, I have increased the amount the debugging information in the kernel, and this is what I get when the problem arise and I restart the service

Mar 5 12:42:04 william eth0: wait_for_cmd_done timeout!
Mar 5 12:42:07 william NETDEV WATCHDOG: eth0: transmit timed out
Mar 5 12:42:07 william eth0: Transmit timed out: status 0050 0c80 at 129/189 command 000c0000.
 
Old 03-05-2006, 02:17 PM   #30
win32sux
LQ Guru
 
Registered: Jul 2003
Location: Los Angeles
Distribution: Ubuntu
Posts: 9,870

Rep: Reputation: 377Reputation: 377Reputation: 377Reputation: 377
try this: unload your e100 module (before the problem begins)... and then, set the ucode to 0 when reloading it... like:
Code:
/sbin/modprobe e100 ucode=0
i'm assuming ucode on that nic is set to 1 by default (if not then vice-versa)... maybe also try some of the other parameters if it still doesn't work:

http://www.intel.com/support/network...htm#parameters

Last edited by win32sux; 03-05-2006 at 02:20 PM.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Slow Internet Connection when Connecting to Internet on Browsers lennysokol Linux - Networking 8 04-09-2011 05:29 PM
New Fedora Internet connection slow slow slow matrim Fedora 9 07-29-2005 02:39 PM
2 min. internet connection and login problems neoAThome Mandriva 12 01-20-2005 12:27 PM
what commands do I use to start and stop my internet connection? babyboss Slackware 2 10-17-2004 02:35 PM
Internet Conecction begins to slow down and thewn stop emilioestevezz Linux - Networking 2 04-07-2004 07:19 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 03:48 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration