Visit Jeremy's Blog.
Go Back > Forums > Linux Forums > Linux - Networking
User Name
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.


  Search this Thread
Old 12-08-2004, 04:22 AM   #1
LQ Newbie
Registered: Dec 2004
Location: Cambridgeshire, UK
Posts: 5

Rep: Reputation: 0
Question Internet connection sharing - WinXP + Knoppix + Gentoo

Sorry for the long post - but here goes:

I have got an interesting problem with Windows XP SP2 and Knoppix 3.7 LiveCD (and also Gentoo 2004.3 Minimal LiveCD). I have a standard home phoneline network card which behaves in the same way as a normal ethernet card and therefore uses the "pcnet32" module. My gateway is an XP computer (pre-SP1) that runs Internet Connection Sharing so that I can crosswire the two computers and use ICS on mine.

In a nutshell - my problem is the following: I cannot configure my network card on the Gentoo LiveCD. In Windows XP - the card works perfectly well and I get no errors whatsoever. When I boot into the Knoppix 3.7 LiveCD - the ethernet card autoconfigures itself with no problems using DHCP (because ICS acts like a DNS server as well as a DHCP server). The real problem is when I boot into the Gentoo LiveCD - the card is detected fine, and can be configured using ifconfig - but I get carrier errors on the card as soon as I try to ping anything.

So, in Gentoo LiveCD - doing this:

ifconfig eth0 broadcast netmask up
route add default gw

And then changing /etc/resolv.conf to say this:


Then I try to ping the gateway ( and I get the following info when running ifconfig:

eth0 Link encap:Ethernet HWaddr ...
inet addr: Bcast: Mask:
RX packets:0 errors:0 dropped:0 overruns:0 frame:0
TX packets:0 errors:19 dropped:0 overruns:0 carrier:19
collisions:0 txqueuelen:1000
RX bytes:0 (0.0 KiB) TX bytes:4740 (4.6 KiB)
Interrupt:11 Base address:0x1040

I get carrier errors - but I have checked that the cable is plugged in and I know that the gateway is actually running...

I then reboot the computer and put the Knoppix CD in - "knoppix26 lang=us"
Knoppix configures itself and starts DHCP broadcasting with the internet working fine. This is what I get when I run ifconfig on a newly booted Knoppix 3.7 system:

root@ttyp0[knoppix]# ifconfig
eth0 Link encap:Ethernet HWaddr ...
inet addr: Bcast: Mask:
inet6 addr: fe80::220:78ff:feb1:37c6/64 Scope:Link
RX packets:14 errors:0 dropped:0 overruns:0 frame:0
TX packets:33 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:3915 (3.8 KiB) TX bytes:4740 (4.6 KiB)
Interrupt:11 Base address:0x1040

lo Link encap:Local Loopback
inet addr: Mask:
inet6 addr: ::1/128 Scope:Host
RX packets:19 errors:0 dropped:0 overruns:0 frame:0
TX packets:19 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:1449 (1.4 KiB) TX bytes:1449 (1.4 KiB)

No errors - and the internet is working fine. Now I am getting to the root of the problem: When I boot into windows and then re-boot (without a shutdown) into Knoppix - the autoconfiguration doesn't work and I get carrier error (the same as I did with Gentoo)...

A quick check (of when the internet is working in Knoppix) of my configation files:

root@ttyp0[knoppix]# route
Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface * U 0 0 0 eth0
default UG 0 0 0 eth0
root@ttyp0[knoppix]# cat /etc/resolv.conf

The routing is the same as in gentoo, the resolv.conf is the same as in gentoo - and the ifconfig is the same - except that I get carrier errors...

root@ttyp0[sysconfig]# cat netcard
FULLNAME="Advanced Micro Devices [AMD]|79c978 [HomePNA]"

returns the same both in Knoppix and in Gentoo liveCD

I also thought that I should check if the pcnet32 module was loaded in the kernel (in both systems 2.6) - so I ran lsmod:

pcnet32 27876 0
mii 7936 1 pcnet32
crc32 8064 1 pcnet32

So, in effect, I can see no difference in my Knoppix and Gentoo configuration that could make carrier errors appear (I haven't touched the hardware). The interesting problem is that I cannot get Knoppix to run with network when I reboot straight from Windows. My guess is that Windows changes the NIC EEPROM settings when installing updates (as I have done) to incorrect ones - and when Linux attemps to use them you get TX carrier errors on the ethernet card.

Any suggestions as to what I could try to get my eth0 working in Gentoo? Or maybe Knoppix 3.7 bypasses the EEPROM settings and uses correct ones?

Last edited by Mireno; 12-08-2004 at 05:12 AM.
Old 12-17-2004, 03:56 PM   #2
LQ Newbie
Registered: Dec 2004
Location: Lisbon, Portugal
Distribution: suse 9.2 Pro
Posts: 1

Rep: Reputation: 0
Having a similar trouble on SUSE 9.2

I'm having a similar problem on my dual boot Windows XP/SuSe 9.2 system.

I have a Motorola Surfboard SB4200 cable Modem connected to a Surecom 10/100 Ethernet card.
Internet works just fine on XP but there's a catch to get it to work on Suse.

If I reboot, or soft shutdown, from XP to Suse dhcpcd can't get an IP adress. In order to do so i either:

fully unplug the PC (turn off the switch on the power source in the back)
shutdown/reboot from suse to suse.

SUse 9.1 had the same problem and I never got to terms with.
I've tried every possible combination on Yast, but the problem remains.

Ideas, anyone?

Mr. Crowley101


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Sharing internet from Debian to WinXP? Paiway Linux - Networking 3 05-02-2008 03:38 PM
Internet Connection Sharing for Gentoo joopie Linux - Distributions 1 11-10-2005 06:06 PM
Internet sharing Fedora3->WINXP Freekas Linux - Networking 2 01-16-2005 05:38 AM
need help on FC3 WinXP file sharing. Internet connection OK bestbidder1 Linux - Networking 1 01-15-2005 04:51 AM
Mandrake 9.2 connection sharing with WinXP Lamotta Mandriva 0 03-31-2004 12:39 PM > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 03:14 PM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration