LinuxQuestions.org
Welcome to the most active Linux Forum on the web.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 05-31-2004, 12:04 PM   #1
apoc63
Member
 
Registered: May 2004
Posts: 38

Rep: Reputation: 15
Unhappy Internet Connection Problems


I just installed mandrake 8.2 firewall. The probelm i am having sit hat im not sure it is connected to the interent. It seems to be getting an IP from comcast but i cant ping anything. Also i think the IP is wrong. When i plug my cable modem into my router it gets an ip of 68.42.197.61 the firewall still gets a class A ip but its not the same. Lets say it is correct why cant I ping anytihing. How do I go about sharing the connection. I have two nics in there one has a static IP and the other that is connected to my cable modem is dhcp. If there is anything else anyone needs to know please let me know. I am a newbie with this and i would appreciate any help I can get.
 
Old 05-31-2004, 03:38 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,696

Rep: Reputation: 232Reputation: 232Reputation: 232
How does your routing table look like? You can view it when you run 'route' as root. You should have a line like
Code:
default         something     0.0.0.0         UG    0      0        0 eth0
eth0 should be replaced with the NIC that's connected to the cable modem.
 
Old 05-31-2004, 04:17 PM   #3
apoc63
Member
 
Registered: May 2004
Posts: 38

Original Poster
Rep: Reputation: 15
Ok I think that was it. I changed the eth1 to static and eth0 to dhcpcd now i can ping and get a proper addy. But i cannot access my firewall thought mandrake anymore. Maybe I changed it wrong. I went in and said ifconfig eth1 10.168.10.1 and it appears to be the right static IP is there anything else i need to do to eth1 so that i may access it through the mozilla like i did before.
 
Old 05-31-2004, 05:19 PM   #4
apoc63
Member
 
Registered: May 2004
Posts: 38

Original Poster
Rep: Reputation: 15
Almost GOt IT

Well I am able to ping now. But i am having trouble sharing the internet connection. I cant access the internet from the computers on my lan. On my firewall i can ping websites and computers on my lan. But I need help on sharing the interent connection so that i may use it on the lan.
 
Old 06-01-2004, 05:14 PM   #5
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,696

Rep: Reputation: 232Reputation: 232Reputation: 232
You need to add something called 'masquerading'. I'm not sure how it's called (may be also 'connection sharing'). If you can't find it, I can write a script for you.
 
Old 06-02-2004, 01:39 PM   #6
apoc63
Member
 
Registered: May 2004
Posts: 38

Original Poster
Rep: Reputation: 15
Connection Sharring

OK do i have to do it inside of the mandrake firewall box or do it from the html interface
 
Old 06-08-2004, 03:15 PM   #7
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,696

Rep: Reputation: 232Reputation: 232Reputation: 232
apoc63, you have probably found it out by now, but I think that's there's a possibility to do it from a web interface.
 
Old 06-08-2004, 04:27 PM   #8
apoc63
Member
 
Registered: May 2004
Posts: 38

Original Poster
Rep: Reputation: 15
Yeah

Well yeah in mandrake firewall i tried using it but its not blocking out the urls. It has the option to but its just not working. Dont know if i have it configured wrong or what.
 
Old 06-08-2004, 04:28 PM   #9
apoc63
Member
 
Registered: May 2004
Posts: 38

Original Poster
Rep: Reputation: 15
nevermind

i got it sorry.. It works fine now. Just got to figure out how to get the web proxy to work correctly now
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Internet Connection Problems Pretzal Debian 1 09-01-2005 12:37 PM
Internet connection problems Elphi SUSE / openSUSE 13 10-23-2004 11:05 AM
problems with internet connection nulinuser Linux - Newbie 3 07-14-2004 07:25 PM
Internet Connection Problems...again! justiceisblind Linux - Newbie 0 04-21-2002 11:38 AM
internet connection problems greatgatsby26 Linux - Networking 4 05-04-2001 07:40 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 10:34 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration