-   Linux - Networking (
-   -   Internet connection problem, able to ping but unable to get web page in browser (

rajnishmishra 07-08-2004 04:40 AM

Internet connection problem, able to ping but unable to get web page in browser
i have linux box running Rh 9 recently added second lan card on pci(eth1) with static ip provided by ISP with isps dns address. First one is used on private lan for local mail.
I am able to ping outside address but not able to access web page on the browser i have uninstlled the browser but it won't work. ifconfig shows both eth0-1.

pingu 07-08-2004 06:19 AM

I would say this is probably a DNS-problem.
Try it: In the browser, type in an IP-number: should take you to Yahoo's home page.
If it does, you know you have a DNS-problem.
Unfortunately, I'm not sitting at a Linux-box so I can't tell you how to check it.
But surely someone helse here can?

zulfilee 07-08-2004 07:13 AM

Have you filled DNS of ISP in resolv.conf

Is any name server running on your system

Any firewall?

vr6stress 07-08-2004 08:05 AM


Originally posted by zulfilee
Have you filled DNS of ISP in resolv.conf

Is any name server running on your system

Any firewall?

i just went through this with mandrake 10....i could go to ip addresses but not websites, i logged in as root, removed my network connections and readded them, then manually edited the resolv.conf putting in the two DNS servers my ISP gave me and BINGO, now it works!!!

rajnishmishra 07-09-2004 12:10 AM

friends, i have dns entries in the /etc/resolv.conf which i added using redhat gui tool. There is no firewall or dns server running on the server.
The same configuration is working perfect on the windows server. I have copied the configuration for second card form there only.
now, i will try again, first deleting all ip and dns entries and swapping previous ips of eth1 and eth0.

thanks for your suggestions.

rajnishmishra 07-10-2004 12:55 AM

friends, i have swapped cable and ip addresses now internet is working but i am unable to telnet the server. But i am able to ping the server from another client in the lan.
first card is onboard, while second is a realtek 8039.
any ideas what to do next.


zulfilee 07-10-2004 01:38 AM

May be due to a lot of reasons.

First type
on a console and see if telnet is enabled.
If not enable it and go for a
service xinetd restart

Also try this [if the above doent work]
service iptables stop
service ipchains stop

And try telnetting from the clients

If the latter is the problem you will have to reconfigure the ifrewall rules which you can do using
This is a graphical tool for default firewall configuration


rajnishmishra 07-12-2004 11:07 PM

friends,i don't have any iptables service running. Telnet was already running on the first on board interface, second one is creating problem.
i have checked running httpd service it also doesn't give any response.
any solutions.


rajnishmishra 07-14-2004 03:14 AM

is there any possibility of my lan card being faulty.

ppuru 07-14-2004 03:19 AM


Can you pls post the output of


iptables -nvL
Check your /etc/hosts.allow and /etc/hosts.deny whether they are blocking telnetd.

rmanocha 07-14-2004 07:39 AM

the best thing to do to check if telnetd is running or not is to do:
nmap localhost on a shell.
this will list all the open ports on ur machine.
if port 23 is not open...this means that telnetd is not running. try to start it from /etc/init.d/telnetd start

after doing this, again run the nmap command. if again you do not see port 23 open, then some kind of firewall is blocking the port.
I have never used a dual card system but maybe you should check to see on which card telnetd runs is sessions(is this a stupid remark????)
also may i suggest using ssh and sshd instead of telnetd. ssh encrypts all ur connections in contrast to telnet which sends everything u type in plin text.
red hat should have a ssh server. try issuing the command: /etc/init.d/sshd start and then issue the nmap command again. if port 22 is open then you have a ssh server running on your machine. all you need to do now is download a ssh client(putty is realy good) and connect to your server. and dont worry, ssh is not slower than telnet.
best of luck

ratcheson 07-14-2004 04:34 PM

I spent all day yesterday fighting a similar problem, I could ping anything -FQDN or IP- but browsers and ftp apps wouldnt connect. Turned out the on-board nic failed. Stick another nic in and try again.

I noticed your ifconfig is showing rx/tx errors, mine showed tx errors on the failed NIC.

rajnishmishra 07-14-2004 11:27 PM

hello friends, thanks for your participation,
we solved the problem, our network card is faulty. I changed the card and it worked.
thanks everybody.
But is there any way to detect first time whether lan card is faulty. Is there might be chances that lan card is perfect
but driver has problem.


ratcheson 07-15-2004 12:54 AM

The only sure way I know of is the substitution route. I have diagnostics for windows or dos but nothing for Linux. Perhaps someone will direct us to something????

All times are GMT -5. The time now is 01:54 AM.