LinuxQuestions.org
Review your favorite Linux distribution.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 06-17-2003, 10:35 PM   #1
vhalik
LQ Newbie
 
Registered: Jun 2003
Posts: 11

Rep: Reputation: 0
Unhappy internet connection on RH9 working sporadically


DSL Modem:
MSN Arescom 1000
I.P. = 192.168.1.1
Subnet Mask = 255.255.255.252

Router:
D-Link DI-614+ Airplus
I.P. = 192.168.2.1
Subnet Mask = 255.255.255.0

Wall -> DSL Modem -> Router -> WinXP
Router -> RH9

Here is the deal. The modem assigns the router an I.P. and then the I.P. assigns addresses to the WinXP box and Linux Box. The WinXP box runs just. Now here comes the problem. The linux box can access the internet but very sporadically. It will open a page, but then for the next 5 or so minutes it doesnít have internet connection and then it comes back on for another minute, so on and so forth. I am not running a wireless network. Everything is wired. I didnít mess with any config files on RH9. I just used the Control Center to set everything up. I donít know how to fix this internet problem with my linux machine. I hope someone can spot a problem with my ignorant description of my problem. I havenít messed with file sharing yet since I want to tackle one problem at a time unless file sharing and internet connectivity require the same solution.

Last edited by vhalik; 06-17-2003 at 10:36 PM.
 
Old 06-17-2003, 10:47 PM   #2
fancypiper
LQ Guru
 
Registered: Feb 2003
Location: Sparta, NC USA
Distribution: Ubuntu 10.04
Posts: 5,141

Rep: Reputation: 58
Try adding your ISPs DNS in /etc/resolv.conf

My file:
Code:
domain infoave.net
nameserver 206.74.254.2
nameserver 204.116.57.2
 
Old 06-19-2003, 12:58 PM   #3
balam
Member
 
Registered: Nov 2002
Location: us
Distribution: red hat
Posts: 143

Rep: Reputation: 15
I am agree

I had the same problem,
the problem was dns on linux, for some reason the router stop pusshing dns resolution to linux,
but to fix this open you Nic config gui. look for the dns entry and type the dns entry of your isp.
save it and viola.
 
Old 06-19-2003, 02:58 PM   #4
vhalik
LQ Newbie
 
Registered: Jun 2003
Posts: 11

Original Poster
Rep: Reputation: 0
Smile Thanks

Thanks for the solutions. They both worked perfectly. I had the DNS of the router in the file, but not for the modem. Once I added that the internet connection worked perfectly.
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
internet problems (sporadically) and doom 3 install??? lowpingnoob Linux - Newbie 4 04-11-2006 11:31 AM
RH9 internet connection setup jewe Linux - Newbie 2 11-08-2003 03:25 AM
RH9 internet connection setup jewe Linux - Networking 1 11-07-2003 07:49 PM
Internet Connection Sharing from RH9 jrwu Linux - Newbie 22 06-14-2003 09:34 PM
Sharing internet connection in RH9 rainmasterrr Linux - Networking 1 04-29-2003 02:14 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 02:38 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration