Review your favorite Linux distribution.
Go Back > Forums > Linux Forums > Linux - Networking
User Name
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.


  Search this Thread
Old 04-08-2004, 04:53 PM   #1
Registered: Apr 2004
Location: Motherboard
Distribution: Debian GNU/Linux
Posts: 156

Rep: Reputation: 30
Question Interface not brought up on booting !!

I am having a problem with my ip configuration. Upon bootup my static ip
is not automatically detected. I have to run the command:

/etc/init.rd/networking restart

to get it configured each time I bootup my machine. I am running Debian (woody).
Any help would be appreciated.
Old 04-08-2004, 05:00 PM   #2
Registered: Jan 2004
Location: Australia
Distribution: Debian
Posts: 168

Rep: Reputation: 30
did you edit your /etc/network/interfaces to reflect your static IP, or some other method. Please clarify 'detected' - it is not possible to detect a static IP configuration.

[Edit - Now I am being vague - If you don't tell it, the computer cannot possibly know you want a static IP, and if so which one]

Last edited by urzumph; 04-08-2004 at 05:02 PM.
Old 04-08-2004, 05:10 PM   #3
Registered: Apr 2004
Location: Motherboard
Distribution: Debian GNU/Linux
Posts: 156

Original Poster
Rep: Reputation: 30
I have my static ip as well as the netmask and the gateway entered
in the /etc/network/interfaces.
I edited the /etc/resolv.conf to reflect the DNS settings.


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off

Similar Threads
Thread Thread Starter Forum Replies Last Post
Wireless interface brought up automatically mawaldne Linux - Wireless Networking 3 11-04-2004 04:19 PM
iv just brought a camcorder master Linux - General 4 03-13-2004 12:11 PM
ethernet interface can't be brought up in Mandrake 10 ?? kix_vn Mandriva 1 03-11-2004 10:19 PM
Network Interface Failed booting RH9 on Vmware 4.0 linux618 Linux - Networking 6 03-01-2004 09:57 AM
When booting 'Bringing up interface eth0' slow and many newbie questions cubeman Linux - Software 14 10-18-2003 03:25 PM > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 01:43 AM.

Main Menu
Write for LQ is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration