-   Linux - Networking (
-   -   installing ubuntu botched network adapter (

angrym0use 05-18-2010 09:35 PM

installing ubuntu botched network adapter
On my desktop, I have Windows 7. I just also installed ubuntu on a partition in order to dual-boot. The installation worked fine, however now I cannot use the internet on either os.

I have a Realtek PCIe GBE Family Controller

On Windows 7, the LAN flashes from "Enabled" -> "Identifying" -> "Network cable unplugged". It does this on a seemingly continuous loop. When I disable it, it will not let me enable it. It says it can't start. Also, I uninstalled and re-installed the driver for my ethernet with no change.

On Ubuntu, when I try to do "ifconfig eth0 up" and "dhclient eth0" I get the message "No DHCPOFFERS received. No working leases in persistent database - sleeping."

I have been looking for a long time for an answer to this problem. Posting here is a last resort for me. I have never posted on any forums before, so I apologize in advance if I do something wrong. Thanks.


LVsFINEST 05-18-2010 10:04 PM


Does the link light illuminate when a cable is plugged in? Have you tried a different Ethernet cable? Did Internet work prior to installing Ubuntu? Are other PCs on your network able to access the Internet?

With two different OS's both having issues, more than likely it's hardware related than the local configurations.

angrym0use 05-18-2010 10:27 PM


Yes, it is plugged in right now, and there is an orange light blinking. I have tried a different ethernet cable, and I also put the current one in my laptop to make sure it still worked.

Yes, the internet worked before, even on backtrack 4. And yes, my laptop (which I'm on right now) is able to connect to the network.

brucehinrichs 05-18-2010 10:33 PM

Check this thread, same problem:

EDIT: And this one: Specifically this:

EDIT: I think this is the part that worked for him, quoting Skaperen:
Try completely pulling the battery from the laptop and leave it out for several minutes. An ability, even if not enabled, to have network packet cause the system to "power on" could leave the NIC and a few other parts enabled enough for the controller and/or BIOS code to be checking on this all the time, preventing the NIC from going to a cold reset state.

angrym0use 05-18-2010 10:45 PM

thanks for the info. I will certainly try disconnecting the power. I'll let you know if it works

angrym0use 05-19-2010 12:35 AM

hey guys, thanks a lot!

I just unplugged the psu and then held down the power button for 30 seconds (supposedly this discharges the capacitors or something). After that, I waited while I watched a movie (so about 90 minutes). After I turned the computer back on, the internet now works just fine across all operating systems.

Thanks again! I would have never thought this could be an issue.

All times are GMT -5. The time now is 03:49 PM.