LinuxQuestions.org
Visit Jeremy's Blog.
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 03-03-2011, 05:45 AM   #1
aocferreira
Member
 
Registered: Feb 2011
Posts: 117

Rep: Reputation: 0
Install Net-snmp 5.4.3


Trying to install net-snmp but always getting an error:

./configure --with-perl-modules
make

and get the error:

/usr/bin/ld: cannot find -lperl
collect2: ld returned 1 exit status
make[1]: *** [snmpd] Error 1
make[1]: Leaving directory `/downloads/net-snmp-5.4.3/agent'
make: *** [subdirs] Error 1

what's the solution?
 
Old 03-03-2011, 08:44 AM   #2
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2023 Fedora38 + 50+ other Linux OS, for test only.
Posts: 17,518

Rep: Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641
Quote:
/usr/bin/ld: cannot find -lperl
That means a missing 'libperl.so'.

# apt-get install libperl-dev

( If you are still using "a Debian based OS".)
 
Old 03-03-2011, 09:09 AM   #3
aocferreira
Member
 
Registered: Feb 2011
Posts: 117

Original Poster
Rep: Reputation: 0
and how can I install that package if I don't have access to internet? without using apt-get?
I downloaded libperl5.10_5.10.1-17_i386.deb and tried to install but got an error:

Unpacking replacement libperl5.10 ...
dpkg: dependency problems prevent configuration of libperl5.10:
libperl5.10 depends on libc6 (>= 2.4); however:
Version of libc6 on system is 2.3.6.ds1-13etch2.
libperl5.10 depends on perl-base (= 5.10.1-17); however:
Version of perl-base on system is 5.8.8-7etch3.
dpkg: error processing libperl5.10 (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
libperl5.10

I downloaded also libc6_2.11.2-10_i386.deb and tried to install it first but also got an error:
dpkg: regarding libc6_2.11.2-10_i386.deb containing libc6:
libc6 conflicts with tzdata (<< 2007k-1)
tzdata (version 2007b-1) is installed.
dpkg: error processing libc6_2.11.2-10_i386.deb (--install):
conflicting packages - not installing libc6
Errors were encountered while processing:
libc6_2.11.2-10_i386.deb

Is there any other way to place the libperl-dev in my server? Thank u!
 
Old 03-03-2011, 09:27 AM   #4
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2023 Fedora38 + 50+ other Linux OS, for test only.
Posts: 17,518

Rep: Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641
Quote:
I downloaded also libc6_2.11.2-10_i386.deb and tried to install it
Please don't do that. You already have a system 'libc', which cannot be changed.

Quote:
Version of libc6 on system is 2.3.6.ds1-13etch2
Looks like you have a "Debian Etch OS".

Please show the output from the command :
dpkg --get-selections | grep libperl
... to decide the version of libperl-dev, that can be installed.

The Debian Etch packages are here :
https://www.securehost.com/mirror/debian/pool/main/ > p/ > perl/
> > https://www.securehost.com/mirror/de...l/main/p/perl/
(( libperl-dev_5.8.8-7etch6_i386.deb ))

..
 
Old 03-03-2011, 09:29 AM   #5
aocferreira
Member
 
Registered: Feb 2011
Posts: 117

Original Poster
Rep: Reputation: 0
dpkg --get-selections | grep libperl
libperl5.10 install
libperl5.8 install

that means I have to install 5.10 and 5.8?
 
Old 03-03-2011, 09:35 AM   #6
aocferreira
Member
 
Registered: Feb 2011
Posts: 117

Original Poster
Rep: Reputation: 0
dpkg -i libperl-dev_5.8.8-7etch6_i386.deb
(Reading database ... 76559 files and directories currently installed.)
Preparing to replace libperl-dev 5.8.8-7etch6 (using libperl-dev_5.8.8-7etch6_i386.deb) ...
Unpacking replacement libperl-dev ...
dpkg: dependency problems prevent configuration of libperl-dev:
libperl-dev depends on perl (= 5.8.8-7etch6); however:
Version of perl on system is 5.8.8-7etch3.
libperl-dev depends on libperl5.8 (= 5.8.8-7etch6); however:
Version of libperl5.8 on system is 5.8.8-7etch3.
dpkg: error processing libperl-dev (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
libperl-dev
 
Old 03-03-2011, 09:48 AM   #7
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2023 Fedora38 + 50+ other Linux OS, for test only.
Posts: 17,518

Rep: Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641
*

# dpkg -i libperl-dev_5.8.8-7etch6_i386.deb libperl5.8_5.8.8-7etch6_i386.deb

https://www.securehost.com/mirror/de...etch6_i386.deb
 
Old 03-03-2011, 09:56 AM   #8
aocferreira
Member
 
Registered: Feb 2011
Posts: 117

Original Poster
Rep: Reputation: 0
it continues giving an error.. I just dont know what to do! is it anything related to etch3/etch6?

(Reading database ... 76559 files and directories currently installed.)
Preparing to replace libperl-dev 5.8.8-7etch6 (using libperl-dev_5.8.8-7etch6_i386.deb) ...
Unpacking replacement libperl-dev ...
Preparing to replace libperl5.8 5.8.8-7etch6 (using libperl5.8_5.8.8-7etch6_i386.deb) ...
Unpacking replacement libperl5.8 ...
dpkg: dependency problems prevent configuration of libperl-dev:
libperl-dev depends on perl (= 5.8.8-7etch6); however:
Version of perl on system is 5.8.8-7etch3.
dpkg: error processing libperl-dev (--install):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of libperl5.8:
libperl5.8 depends on perl-base (= 5.8.8-7etch6); however:
Version of perl-base on system is 5.8.8-7etch3.
dpkg: error processing libperl5.8 (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
libperl-dev
libperl5.8
 
Old 03-03-2011, 10:18 AM   #9
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2023 Fedora38 + 50+ other Linux OS, for test only.
Posts: 17,518

Rep: Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641
# dpkg -i \
libperl-dev_5.8.8-7etch6_i386.deb libperl5.8_5.8.8-7etch6_i386.deb \
perl-base_5.8.8-7etch6_i386.deb

I.e. you will have to install all the packages, dpkg asks for.

https://www.securehost.com/mirror/de...etch6_i386.deb
 
Old 03-03-2011, 10:31 AM   #10
aocferreira
Member
 
Registered: Feb 2011
Posts: 117

Original Poster
Rep: Reputation: 0
The last package is not being installed.. Do you have any other solution? Thanks for all the help

dpkg -i perl-base_5.8.8-7etch6_i386.deb

(Reading database ... 76559 files and directories currently installed.)
Preparing to replace perl-base 5.8.8-7etch6 (using perl-base_5.8.8-7etch6_i386.deb) ...
Unpacking replacement perl-base ...
Setting up perl-base (5.8.8-7etch6) ...


dpkg -i libperl5.8_5.8.8-7etch6_i386.deb

(Reading database ... 76559 files and directories currently installed.)
Preparing to replace libperl5.8 5.8.8-7etch6 (using libperl5.8_5.8.8-7etch6_i386.deb) ...
Unpacking replacement libperl5.8 ...
Setting up libperl5.8 (5.8.8-7etch6) ...


dpkg -i libperl-dev_5.8.8-7etch6_i386.deb

(Reading database ... 76559 files and directories currently installed.)
Preparing to replace libperl-dev 5.8.8-7etch6 (using libperl-dev_5.8.8-7etch6_i386.deb) ...
Unpacking replacement libperl-dev ...
dpkg: dependency problems prevent configuration of libperl-dev:
libperl-dev depends on perl (= 5.8.8-7etch6); however:
Version of perl on system is 5.8.8-7etch3.
dpkg: error processing libperl-dev (--install):
dependency problems - leaving unconfigured
Errors were encountered while processing:
libperl-dev
 
Old 03-03-2011, 10:47 AM   #11
aocferreira
Member
 
Registered: Feb 2011
Posts: 117

Original Poster
Rep: Reputation: 0
I think I got it tks 4 all!
 
Old 03-03-2011, 11:08 AM   #12
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2023 Fedora38 + 50+ other Linux OS, for test only.
Posts: 17,518

Rep: Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641
Yes, it's more tricky, than I thought. Two more packages are required, it seems.
( I installed the packages on my 'Debian Etch' now.)

This is the one that makes the errors occur : perl_5.8.8-7etch6_i386.deb :
https://www.securehost.com/mirror/de...etch6_i386.deb

And this one was found by Synaptic, as a "Broken Package" :
perl-modules_5.8.8-7etch6_all.deb :
https://www.securehost.com/mirror/de...7etch6_all.deb

After installing all this : No errors, no message "Broken Package" in Synaptic.

..
 
Old 03-03-2011, 11:08 AM   #13
aocferreira
Member
 
Registered: Feb 2011
Posts: 117

Original Poster
Rep: Reputation: 0
one more thing: after installing net-snmp and nagios-plugin-snmp it wasn't supposed to have a check_snmp in /usr/local/nagios/libexec ?

I have check_snmp_int, check_snmp_process, check_snmp_storage but no check_snmp!
snmpwalk is working, but can't do check_snmp !
 
Old 03-03-2011, 11:18 AM   #14
aocferreira
Member
 
Registered: Feb 2011
Posts: 117

Original Poster
Rep: Reputation: 0
had to recompile the plugins ! that's all! thank you man
 
Old 03-03-2011, 11:38 AM   #15
knudfl
LQ 5k Club
 
Registered: Jan 2008
Location: Copenhagen DK
Distribution: PCLinuxOS2023 Fedora38 + 50+ other Linux OS, for test only.
Posts: 17,518

Rep: Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641Reputation: 3641
Net-snmp and nagios-* : Sorry, I don't known any of these applications.

Suggest : Start a new thread, if you think, there are any issues.

P.S. : Did you read post # 12 ?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Integrate Mod-Apache-Snmp with Net-SNMP source kirukan Linux - Server 2 05-11-2011 01:48 AM
net-snmp-utils to install nagios in Ubuntu linuxcol Ubuntu 1 03-22-2010 03:16 AM
Net-SNMP writing a Subagent - snmp.conf Unknown token: master AustinMarton Programming 0 12-16-2008 07:34 PM
RHEL4 net-snmp install Strike2000 Linux - Newbie 1 10-02-2007 08:25 AM
blocking smux after net-snmp rpm install relayer416 Linux - Software 0 02-16-2005 07:50 PM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 04:11 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration