-   Linux - Networking (
-   -   in one nic and out the other (

mayhew 01-13-2013 12:27 PM

in one nic and out the other
I have a linux mint 14 cinimon os and am trying to route the internet through my system. my eth0 is inbound 1000mbit ethernet, and my eth1 is a 100mbit nic planned for outbound. I am trying to setup my system to serve the net out to eth1 so i can atach 2 laptops via a switch, get internet to install gentoo.

I tried the following tutorial( ) but can't get the service to start. i think im mising somthing important.

I want the most distro nuteral meathod possable (learn it once...) but if there is a linux mint spicific way thats easier, thats fine by me.

Thanks ^.^

kbp 01-13-2013 04:55 PM

Here's my response to a similar question which should work on pretty much any linux system ..

mayhew 01-14-2013 05:52 PM

the very last command

iptables-save > /etc/sysconfig/iptables
results in a no such file/dir output. i think linux mint may store the tables elsewhere, or i am missing somthing. everythign else resulted in no errors. the only change needed was swaping eth0 for eth1 (my 0 connects to the router) i have saved the steps as a bash script for later use.

no internet connection is found on systems atached to eth1, any advice for dhcp setup. i tried once ( link to tutorial ) and the changes required booting from another system to fix.

thanks again for your help so far.


kbp 01-15-2013 02:04 AM

If you take a look at the init script for iptables you should find where the rules are stored to be reinstated at boot.

Here's an example /etc/dhcpd.conf you can adjust as necessary:


ddns-update-style interim;

allow booting;
allow bootp;

ignore client-updates;
set vendorclass = option vendor-class-identifier;

subnet netmask {
    option routers  ;
    option domain-name-servers;
    option subnet-mask;
    range dynamic-bootp;
    default-lease-time        21600;
    max-lease-time            43200;

All times are GMT -5. The time now is 05:57 PM.