LinuxQuestions.org
Latest LQ Deal: Latest LQ Deals
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 07-25-2007, 03:40 PM   #1
utnalove
LQ Newbie
 
Registered: Jul 2007
Distribution: CentOS 7
Posts: 24

Rep: Reputation: 0
ifconifg no RUNNING flag.. eth0 is up but seems to be down


hallo, I had fedora and everything was working fine. I installed Slackware 12 and one card is up when doing "ifconfig", but there is no link at all and the lights are off. Windows connected to that card says "network cable unplugged"

I explain here what and where...

eth0 is my windows client
eth1 is my ISP

Code:
~# ifconfig
eth0      Link encap:Ethernet  HWaddr 00:02:B3:A9:D6:E1
          inet addr:192.168.100.1  Bcast:192.168.100.255  Mask:255.255.255.0
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)
          Interrupt:18

here is my # /etc/rc.d/rc.inet1.conf
Code:
# Config information for eth0:
IPADDR[0]="192.168.100.1"
NETMASK[0]="255.255.255.0"
USE_DHCP[0]="no"
DHCP_HOSTNAME[0]=""
GATEWAY="192.168.100.1"
DEBUG_ETH_UP="no"

when starting dhcpd
Code:
 dhcpd
Internet Systems Consortium DHCP Server V3.0.5
Copyright 2004-2006 Internet Systems Consortium.
All rights reserved.
For info, please visit http://www.isc.org/sw/dhcp/
Wrote 0 leases to leases file.

No subnet declaration for eth1 (*my.*public.*ip.*).
** Ignoring requests on eth1.  If this is not what
   you want, please write a subnet declaration
   in your dhcpd.conf file for the network segment
   to which interface eth1 is attached. **

Listening on LPF/eth0/00:02:b3:a9:d6:e1/192.168.100/24
Sending on   LPF/eth0/00:02:b3:a9:d6:e1/192.168.100/24
Sending on   Socket/fallback/fallback-net

and here my dhcpd.conf
Code:
# Configuration file for ISC dhcpd (see 'man dhcpd.conf')
ddns-update-style ad-hoc;
subnet 192.168.100.0 netmask 255.255.255.0 {
option domain-name-servers 212.76.39.205,212.76.33.137,212.76.33.138;
default-lease-time 7200;
max-lease-time 7200;
option routers 192.168.100.1;
#shared-network 192-pub
range 192.168.100.2 192.168.100.20;
Code:
# mii-tool
eth0: no link
eth1: negotiated 100baseTx-FD, link ok
do I have to put some other code?
What can I do?
Thank you
 
Old 07-25-2007, 07:01 PM   #2
TylerD75
Member
 
Registered: Aug 2004
Location: Norway
Distribution: Gentoo
Posts: 96

Rep: Reputation: 18
Probably a stupid question, but do you have either:
a) a switch/hub connected to eth0? or
b) You are sure you are using a crossover TP cable?

I would guess that the problem is not in Linux, but rather a cable problem, or maybe a faulty ethernet card.
Otherwise you would get link-lights and your windows client would not report an unplugged cable, but a non configured connection...
 
Old 07-25-2007, 09:34 PM   #3
utnalove
LQ Newbie
 
Registered: Jul 2007
Distribution: CentOS 7
Posts: 24

Original Poster
Rep: Reputation: 0
Everything was working fine before installing Slackware, before I had Fedora and it was working....
I tried different cables and all those cables were working on fedora as well...
on eth0 there is no switch connected, there is the windows xp client... I even tried to change the link sped and duplex in windows, but no change...

in Ifconfig.... in the line
=========
UP BROADCAST MULTICAST MTU:1500 Metric:1
=========
seems to be missing the flag "RUNNING".... maybe there is some other way to start this card?
 
Old 07-26-2007, 08:35 AM   #4
TylerD75
Member
 
Registered: Aug 2004
Location: Norway
Distribution: Gentoo
Posts: 96

Rep: Reputation: 18
Just to underline something: If there's no switch/hub connected between the linux server and the windows client, there HAS to be a crossover cable between them.
This is NOT a normal cat5 or cat6 cable, but one where to of the conductors in the cable has been "crossed over".
You are 100% sure that this is what you have?

Another test:
You can try to setup everything manually?
On the linux computer:
ifconfig eth1 192.168.100.1 netmask 255.255.255.0 up

On the windows client:
Control Panel --> Network And Internet Settings --> Network Connections
1. Then "Right-click" your "Local Area Connection", and choose "Properties".
2. Select Internet Protocol (TCP/IP) and press Properties
3. Enter (Under "Use the following IP address") --> (IP192.168.100.2, (Subnet mask255.255.255.0 and (Default gateway192.168.100.1.
Leave the DNS server settings as-is for now.
4. Hit "OK" 2 times

Make sure your "Local Area Connections" shows as "Connected".

Then start a command shell (Dos Window) on your windows client, and type "ping 192.168.100.1".
If cables, network interfaces and all hardware is OK, then this should work.

If the first "ifconfig eth1 192....." command fails with something like "no interface eth1 present" (...or something like that):
Then you might have to either load the driver module for the interface, or possibly recompile your kernel.
If so, do:
# lspci (and paste the result here)
# lsmod (and paste the result here)

Last edited by TylerD75; 07-26-2007 at 08:39 AM.
 
Old 07-29-2007, 02:42 AM   #5
utnalove
LQ Newbie
 
Registered: Jul 2007
Distribution: CentOS 7
Posts: 24

Original Poster
Rep: Reputation: 0
I bought another card and now everything seems to be working fine...
thank you anyway!
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Running a script if eth0 is up jevin Fedora 3 04-04-2007 09:31 AM
How can I tell if a particular service (eth0) is running or not? donJulio Slackware 4 09-21-2005 01:37 AM
eth0 disconnected / not running kevinatkins Ubuntu 0 06-06-2005 04:51 PM
eth0 interface is not running! JatCo Linux - Networking 1 03-11-2004 01:00 PM
eth0 not running ifconfig calderonr Linux - Networking 1 01-16-2004 01:14 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 10:40 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Open Source Consulting | Domain Registration