LinuxQuestions.org
Latest LQ Deal: Complete CCNA, CCNP & Red Hat Certification Training Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 01-16-2003, 02:02 PM   #1
Radicalm16
Member
 
Registered: Jan 2003
Location: Venezuela
Distribution: Debian, Ubuntu
Posts: 75

Rep: Reputation: 15
http connection problems on RedHat 7.3


I have Installed Red Hat 7.3, on a machine with a winmodem.

In the first boot Anaconda automatically recognized the modem and configured it.

Now, when I use kppp to dial to my ISP, I get connected without problems, but no browsers can get any page, eventhoug I can ping the server of my ISP.


Incidentally, I had had installed Mandrake 8.2 on the machine and on this distribution I was able to connect to my ISP and browse the Internet without a problem.

What can I Do? Where can I found documentation about this problem?

Thnx.

By the way, sorry by my poor English.
 
Old 01-16-2003, 04:02 PM   #2
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,683

Rep: Reputation: 219Reputation: 219Reputation: 219
Can you ping the server using numbers or domain name?
 
Old 01-16-2003, 10:29 PM   #3
Radicalm16
Member
 
Registered: Jan 2003
Location: Venezuela
Distribution: Debian, Ubuntu
Posts: 75

Original Poster
Rep: Reputation: 15
I only can ping using the ISP server's IP address, when I use the server's name (www.cantv.net), the following error message apper on the console after a while:
Unknown Host name.

thnx for your attention

Franciso (Radicalm16)
 
Old 01-17-2003, 05:34 PM   #4
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,683

Rep: Reputation: 219Reputation: 219Reputation: 219
It looks like a DNS problem. Enter your DNS names in the system configuration and try again (not sure where it is in RH graphical tools, the configuration file is /etc/resolv.conf - add lines like 'nameserver xxx.yyy.vvv.zzz').
 
Old 01-17-2003, 08:42 PM   #5
Radicalm16
Member
 
Registered: Jan 2003
Location: Venezuela
Distribution: Debian, Ubuntu
Posts: 75

Original Poster
Rep: Reputation: 15
I wrote on /etc/resolv.conf my DNS names like that:

cantv.net 200.44.32.12
cantv.net 200.44.32.13

but nothig new happened, I get connected but I could't see any page or ping using the server name. During the connection I view again (using "cat resolv.conf") the file and two lines had been added by kppp:

nameserver 200.44.32.12 #kppp temp entry
nameserver 200.44.32.13 #kppp temp entry

Also when I did ping to these IP addresses (my ISP's DNS servers 200.44.32.12 and 200.44.32.13), It tried to do this throug my Ethernet card, which has assigned a local IP address (192.168.1.2).

Francisco Moreno
 
Old 01-18-2003, 04:51 PM   #6
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,683

Rep: Reputation: 219Reputation: 219Reputation: 219
When you're connected try (as root)
route
and post the results.
 
Old 01-18-2003, 11:50 PM   #7
Radicalm16
Member
 
Registered: Jan 2003
Location: Venezuela
Distribution: Debian, Ubuntu
Posts: 75

Original Poster
Rep: Reputation: 15
These are the results:


Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
200.44.79.1 * 255.255.255.255 UH 0 0 0 ppp0
192.168.1.0 * 255.255.255.0 U 0 0 0 eth0
127.0.0.0 * 255.0.0.0 U 0 0 0 lo
default 192.168.1.254 0.0.0.0 UG 0 0 0 eth0





Fracisco.
 
Old 01-18-2003, 11:51 PM   #8
Radicalm16
Member
 
Registered: Jan 2003
Location: Venezuela
Distribution: Debian, Ubuntu
Posts: 75

Original Poster
Rep: Reputation: 15
These are the results:


Kernel IP routing table
Destination Gateway Genmask Flags Metric Ref Use Iface
200.44.79.1 * 255.255.255.255 UH 0 0 0 ppp0
192.168.1.0 * 255.255.255.0 U 0 0 0 eth0
127.0.0.0 * 255.0.0.0 U 0 0 0 lo
default 192.168.1.254 0.0.0.0 UG 0 0 0 eth0


Francisco
 
Old 01-19-2003, 03:46 PM   #9
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,683

Rep: Reputation: 219Reputation: 219Reputation: 219
It looks clear. The default gateway is not your modem, but your NIC. Try
route del default
route add default ppp0
Does it help?
 
Old 01-19-2003, 07:49 PM   #10
Radicalm16
Member
 
Registered: Jan 2003
Location: Venezuela
Distribution: Debian, Ubuntu
Posts: 75

Original Poster
Rep: Reputation: 15
Yes, It work perfectly, actually Im writting this reply on my Linux machine.

But, now there is a better way to set the modem as a default gateway than run a script automatically when I got connected???

Thanks a lot, I appreciate your attention.

Francisco Moreno.
 
Old 01-21-2003, 04:53 PM   #11
Mara
Moderator
 
Registered: Feb 2002
Location: Grenoble
Distribution: Debian
Posts: 9,683

Rep: Reputation: 219Reputation: 219Reputation: 219
There should be a kppp option to make the gateway default. Try to find it.
 
Old 01-21-2003, 10:16 PM   #12
Radicalm16
Member
 
Registered: Jan 2003
Location: Venezuela
Distribution: Debian, Ubuntu
Posts: 75

Original Poster
Rep: Reputation: 15
kppp ask me to put an IP direction as my Gateway, not a device, but thnx for everything. I appreciate all your help.

Francisco Moreno.
 
Old 01-21-2003, 11:07 PM   #13
Darin
Senior Member
 
Registered: Jan 2003
Location: Portland, OR USA
Distribution: Slackware, SLAX, Gentoo, RH/Fedora
Posts: 1,024

Rep: Reputation: 45
kpp should have a settings tab for pppd options, add just the word "defaultroute" in there.
 
Old 01-21-2003, 11:12 PM   #14
Radicalm16
Member
 
Registered: Jan 2003
Location: Venezuela
Distribution: Debian, Ubuntu
Posts: 75

Original Poster
Rep: Reputation: 15
ok I got it thaks.

Radicalm16
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
Implement persistent HTTP connection syseeker Programming 3 11-30-2005 02:18 AM
Connection Refused http://localhost:631/ mlsbraves Linux - General 12 11-30-2004 06:57 PM
redhat 9 gigafast wireless dongle connection problems ndeepak Linux - Wireless Networking 0 05-29-2004 04:03 PM
large downloads (HTTP, FTP) stall (DSL connection) Choye Linux - Networking 0 01-19-2004 03:55 PM
Redhat 9.0 Internet Connection Problems JoeykhCom Linux - Networking 9 06-25-2003 02:05 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 10:48 AM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration