-   Linux - Networking (
-   -   howto setup Cable modem&router&red hat on machine with ethernet integrated on mobo&XP (

takanana 10-18-2003 07:13 AM

howto setup Cable modem&router&red hat on machine with ethernet integrated on mobo&XP
Hi All,
I'd appreciate some help to set up my internet connection. I have one computer running XP pro and the other running Red Hat 9 and XP. They are connected to a router that is connected to a cable modem. Connection worked fine with XP once the drivers for the motherboard were installed. The NIC is integrated in the mobo.
Where can I find a linux driver or package for it?
Or am I not setting this up properly? I tried copying the IP and default gateway ( but with no results. I cannot find my adapter in the list in ethernet configuration or network adapter configuration.

motherboard: Gigabyte GA-7N400 Pro with "on board LAN Intel Kenai 32 + built in realtek 8201"
ISP: Comcast.

I have tried connecting it directly to the cable modem, but to no avail.
The router sees the computer (LED on) but the computer never sends any data (LED would blink)
Any help appreciated,
Thanks a lot,
Newbie Penguin.


Hangdog42 10-18-2003 08:00 AM

I think you have to take this step by step. The first issue is does RH see your ethernet "card" at all? A quick check with ifconfig should determine that. If it doesn't, you're going to have to find drivers. I would think that RH9 would support this chipset, but you could always Google and see if there are other drivers.

If RH does see your card, but it doesn't have an IP address, that suggests that your startup isn't configured right. If you are using DHCP to assign addresses, you could always issue the dchpcd command from console and that should have the card broadcast a DHCP request. Your router (if it is set up properly) would then respond. If you want to use a static ip, you'll have to do a little digging into RH's startup scripts to figure out where that goes. In Slackware it is in the /etc/rc.d/rc.inet1 file, but I"m not sure that RH follows that convention.

takanana 10-18-2003 11:08 AM

Thanks for the reply, Hangdog42.
I must be doing something incorrectly because when I type ifconfig or dchpcd in a terminal as root, it says "command not found". Perhaps I am omitting some parameters.
I have tried adding a new Ethernet connection with an Sis900 (apparently that is another name for the realtek8201), on eth0, with dhcp but when I activate it says "the device does not seem to be present". Also tried rebooting.

Hangdog42 10-18-2003 02:21 PM

Hmm. Both ifconfig and dhcpcd should be in your /sbin directory. It's possible that roots PATH hasn't been set up properly. What happens if you type $PATH as root? If you can't find ifconfig and dhcpcd in /sbin, you might thy the find command to see if RH has put them elsewhere. Without these commands, you're kind of sunk and they SHOULD be there, unless you did a custom install of RH and left out the network bits.

takanana 10-18-2003 05:11 PM

When I type $path, nothing changes. (still [root@localhost bob].
There is a file called ifconfig in /sbin, but no dhcpcd. One is called dhclient in /sbin.
I did a complete install (all packages : 4.8gigs)
I guess I'll just try reinstalling? The rest works well.

takanana 10-18-2003 06:34 PM

I think I've got it: I need to install the chipset driver(nvidia nforce).
It includes a MAC.
Thanks for the help.

takanana 10-18-2003 09:02 PM

I found this file
Red Hat 9.0 (Kernel Upgrade) NVIDIA_nforce-1.0-0261.rh90up_2.4.20_9.athlon.rpm
Do I need to recompile the kernel or just rpm -i ?

takanana 10-19-2003 01:53 AM

Unpacked 2.4.2._9 although my kernel is 2.4.2_8.
Still not working.
LISA config says she can't find the device.
I'll just reinstall and stop wasting gurus' time.

Hangdog42 10-19-2003 07:49 AM

I would like to challenge the notion that reinstalling is always the way to go. That's windows-think.

The point behind asking you to look at the PATH was to find out what directories were part of PATH, it isn't a command in and of itself. When you type a command like ifconfig, the system looks in the current directory to find it. If it isn't found there, the system then starts looking in the directories that are listed in the PATH environment variable. So in your case, the fact that ifconfig is in /sbin, but the system can't find it when you try to run it, suggests that /sbin is NOT part of root's path, and that may be leading to other troubles. So if you're still having the same probelm, post the results of $PATH and lets see if we can fix that first.

The other thing is that you've now wandered from an internet connection problem into messing with your graphics system. I don't think that installing the nvidia drivers are going to help connecting to your router.

Finally, you aren't wasting anybody's time. I read this board for two reasons:
1) I'm still learning about linux and this is hands down the best place I've ever found to get help.
2) I got my Slack box up and running with a TON of help from this board, and I want to pitch in and help others the way I was helped.

So use the search button here, but if that still leaves you confused, keep posting!

takanana 10-19-2003 09:03 PM

Still no luck!

Ifconfig gives me:
lo link encap: Local Loopback
(no other device)

I managed ifconfig by logging in as root, instead of using "su".

I agree, reinstalling can be drastic.
I tried a fresh install on another fresh HDD, but RH9 did not see my eth0 at that point, so I kept my old install on my real HDD.

In / I have bin, boot, dev, etc, home, initrd, lib, lost+found, misc, mnt, opt, proc, root, sbin, tftpboot, tmp, usr, var.

Thanks for the help then. I love this community feeling.

About the nvidia driver, my video card is an ati radeon, but on my motherboards' drivers page, (, at the end of the page, they have a "LAN driver" (for windows only), called driver_lan_via_823x.exe.
So I must have been confused between via and nvidia since I was also looking at the motherboard layout where there is a block with "nVIDIA nForce 2 MCP-T". There is also "RTL 8201", IT8712F", "RTL 8801", and "SiI3112".

Also, my windows install did not have the internet working until I installed the main driver for the motherboard. The install CD calls it "Nvidia system driver".

I'll try installing the Via driver from

Also, on
it says
"The nForce chipset contains a number of hardware devices that can be run under Linux. Along with a display processor, the chipset includes a network device (MAC), audio hardware, an IDE controller, and an OHCI USB controller. Many of the components of the nForce chipset use industry standard interfaces; thus, not all components require custom drivers to be used on Linux."
But since the computer still sees not the eth0, I'll try the via driver.

After that I'll check I configured properly the nvidia package from

Hangdog42 10-20-2003 07:40 AM

OK, good luck with the nvidia install. By the way, if you use su - instead of just su (note the -), you should get root's path capabilities.

takanana 10-21-2003 06:14 PM

Ok, Thanks man.
Nvidia's nvnet still not working.
I compiled the via driver(rhinefet.o). After "depmode -a" and "modprobe rhinefet" , I get this error message:

"/lib/modules/2.4.20-8/kernel/drivers/net/rhinefet.o: init-module: No such device
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters.
You may find more information in syslog or the output from dmesg
/lib/modules/2.4.20-8/kernel/drivers/net/rhinefet.o: insmod /lib/modules/2.4.20-8/kernel/drivers/net/rhinefet.o failed
/lib/modules/2.4.20-8/kernel/drivers/net/rhinefet.o: insmod rhinefet failed"

Where can I play with the IRQ settings? Where is syslog?dmesg?
Thanks if you know. (or if you don't)

Hangdog42 10-21-2003 10:24 PM

dmesg is a command that will display the contents of the syslog file. You can frequently find the syslog file in /var/log along with a bunch of other logs such as messages. Syslog is simply a text file, so you can open it in any text editor. I hope there is something in the syslog, because at this point I'm kind of out of ideas.

As for playing with IRQ settings, I'm afraid I'm lost on that one. However, I bet someone here does know.

I don't know why I didn't think of this earlier, but what is the output of lspci? That may give you a clue about the real nature of the ethernet card.

takanana 10-22-2003 03:20 PM

lspci gives me
00:04.0 Ethernet controller nVidia Corporation nForce2 Ethernet Controller (rev a1)

Also, when it boots, it says: "nforce2:not 100% native: will probe irq's later"

("In what was destined to be a short-lived spectacle, a chicken, suspended by a balloon, drifted through the Samurai bar's doorway. ": What do samurai do with chicken in bars?)

For reference: details of lspci:

[root@localhost root]# lspci
00:00.0 Host bridge: nVidia Corporation: Unknown device 01e0 (rev c1)
00:00.1 RAM memory: nVidia Corporation: Unknown device 01eb (rev c1)
00:00.2 RAM memory: nVidia Corporation: Unknown device 01ee (rev c1)
00:00.3 RAM memory: nVidia Corporation: Unknown device 01ed (rev c1)
00:00.4 RAM memory: nVidia Corporation: Unknown device 01ec (rev c1)
00:00.5 RAM memory: nVidia Corporation: Unknown device 01ef (rev c1)
00:01.0 ISA bridge: nVidia Corporation nForce2 ISA Bridge (rev a4)
00:01.1 SMBus: nVidia Corporation nForce2 SMBus (MCP) (rev a2)
00:02.0 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4)
00:02.1 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4)
00:02.2 USB Controller: nVidia Corporation nForce2 USB Controller (rev a4)
00:04.0 Ethernet controller: nVidia Corporation nForce2 Ethernet Controller (rev a1)
00:05.0 Multimedia audio controller: nVidia Corporation nForce MultiMedia audio
[Via VT82C686B] (rev a2)
00:06.0 Multimedia audio controller: nVidia Corporation nForce2 AC97 Audio Controler (MCP) (rev a1)
00:08.0 PCI bridge: nVidia Corporation: Unknown device 006c (rev a3)
00:09.0 IDE interface: nVidia Corporation nForce2 IDE (rev a2)
00:0d.0 FireWire (IEEE 1394): nVidia Corporation nForce2 FireWire (IEEE 1394) Controller (rev a3)
00:1e.0 PCI bridge: nVidia Corporation nForce2 AGP (rev c1)
01:0c.0 RAID bus controller: Integrated Technology Express, Inc.: Unknown device 8212 (rev 10)
01:0d.0 RAID bus controller: CMD Technology Inc Silicon Image SiI 3112 SATARaid
Controller (rev 02)
03:00.0 VGA compatible controller: ATI Technologies Inc Radeon R200 QL [Radeon 8500 LE]

Hangdog42 10-23-2003 07:20 AM

OK, you definitely have a nVidia network card. In which case, I wouldn't mess with the via driver much. I did a little googling and came across this which may explain why you're having trouble with the nvidia stuff. I guess I don't know of a workaround however.

All times are GMT -5. The time now is 06:00 PM.