LinuxQuestions.org
Latest LQ Deal: Linux Power User Bundle
Go Back   LinuxQuestions.org > Forums > Linux Forums > Linux - Networking
User Name
Password
Linux - Networking This forum is for any issue related to networks or networking.
Routing, network cards, OSI, etc. Anything is fair game.

Notices


Reply
  Search this Thread
Old 10-25-2004, 11:20 PM   #1
rickronn
LQ Newbie
 
Registered: Oct 2004
Posts: 12

Rep: Reputation: 0
How to set Lan card to 10Mb full duplex in FC2


I am using Fedora Core 2 and need to set my Lan card to 10Mb Full Duplex media type for my router to work properly. Would appreciate if someone would tell me how to do it.
Thanks in advance for your help!
 
Old 10-26-2004, 01:28 AM   #2
symen
Member
 
Registered: Sep 2004
Location: Dublin
Distribution: Debian 3
Posts: 61

Rep: Reputation: 15
It's usually a setting in your bootloader that has to be changed.
what bootloader do you use?
 
Old 10-26-2004, 03:21 AM   #3
rickronn
LQ Newbie
 
Registered: Oct 2004
Posts: 12

Original Poster
Rep: Reputation: 0
Hello, Symen,
Thanks for your help. I am using grub. Please be advised that I am a newbie with Linux, I would appreciate if you can show me the detail steps in changing the setting.
 
Old 10-26-2004, 03:56 AM   #4
symen
Member
 
Registered: Sep 2004
Location: Dublin
Distribution: Debian 3
Posts: 61

Rep: Reputation: 15
in grub it would be a line like
ether=0,0,0,0x10
buth then with the settings specific for your driver.

else and easier, you can run ethtools with a line like:

ethtool -s eth0 speed 10 duplex full autoneg off

and if you add the same line to your rc.local it will automatically run at boottime

Usage:
ethtool DEVNAME
ethtool -i DEVNAME
ethtool -s DEVNAME \
[ speed {10,100,1000} ] \
[ duplex {half,full} ] \
[ port {tp,aui,mii,fibre} ] \
[ autoneg {on,off} ] \
[ phyad %d ] \
[ xcvr {internal,external} ] \
[ wol [pumbagsd]+ ] \
[ sopass %x:%x:%x:%x:%x:%x ]
 
Old 10-27-2004, 01:19 AM   #5
rickronn
LQ Newbie
 
Registered: Oct 2004
Posts: 12

Original Poster
Rep: Reputation: 0
Hi, Symen,
Thanks for your help. I will give it a try.
Best regards.
 
Old 10-27-2004, 03:41 AM   #6
rickronn
LQ Newbie
 
Registered: Oct 2004
Posts: 12

Original Poster
Rep: Reputation: 0
Hi, Symen,
I try your suggestion with root login but ethtool -s eth0 speed 10 duplex full autoneg off gets reply of cannot get current device settings : operation not supported
I try just type ethtool and get different ethtool DEVNAME ethtool A DEVNAME ethtool a DEVNAME etc.
Have I done somethings wrong?

Then I follow your suggestion to add line to rc.local, this time it works and internet brower work fine. However, my router still shows media type as 100Mb. Anyway for me to check if it is running at 10Mb or 100Mb?
 
Old 10-28-2004, 01:26 AM   #7
symen
Member
 
Registered: Sep 2004
Location: Dublin
Distribution: Debian 3
Posts: 61

Rep: Reputation: 15
Could you type "ifconfig" and post the results here?
 
Old 10-29-2004, 12:27 AM   #8
rickronn
LQ Newbie
 
Registered: Oct 2004
Posts: 12

Original Poster
Rep: Reputation: 0
Hi, Symen,
Sorry that I was out yesterday and could not reach my desktop to run the information for you. Please find below message from ifconfig.

eth0 Link encap:Ethernet HWaddr 00:0C:6E:77:9E:66
inet addr:192.168.1.3 Bcast:192.168.1.255 Mask:255.255.255.0
inet6 addr: fe80::20c:6eff:fe77:9e66/64 Scope:Link
UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1
RX packets:29 errors:0 dropped:0 overruns:0 frame:0
TX packets:9 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:1000
RX bytes:2396 (2.3 Kb) TX bytes:962 (962.0 b)
Interrupt:10 Memory:d6800000-0

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:2048 errors:0 dropped:0 overruns:0 frame:0
TX packets:2048 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:3155578 (3.0 Mb) TX bytes:3155578 (3.0 Mb)

Thanks again for your help.
 
Old 10-29-2004, 09:12 AM   #9
symen
Member
 
Registered: Sep 2004
Location: Dublin
Distribution: Debian 3
Posts: 61

Rep: Reputation: 15
hmmm, all looks good...
try
mii-tool -F 10baseT-FD eth0

should be little more powerfull.
btw, if you run mii-tool without any options, you'll get your current config as a result
 
Old 11-02-2004, 05:53 AM   #10
rickronn
LQ Newbie
 
Registered: Oct 2004
Posts: 12

Original Poster
Rep: Reputation: 0
Hi, Symen,
Sorry for late reply. I will give it a try. Assume that once I follow your advice to change setting, it will stay and I will not need to change it every time I login.
Thanks again.
 
Old 11-02-2004, 05:59 AM   #11
rickronn
LQ Newbie
 
Registered: Oct 2004
Posts: 12

Original Poster
Rep: Reputation: 0
Hi, Symen,
Its me again. I try your suggestion and found below return. Would like to hear your advice.

[root@localhost root]# mii-tool -F 10baseT-FD eth0
SIOCGMIIPHY on 'eth0' failed: Bad address
 
Old 11-08-2004, 03:41 AM   #12
rickronn
LQ Newbie
 
Registered: Oct 2004
Posts: 12

Original Poster
Rep: Reputation: 0
Hello, Symen,
Havent heard from you. Wonder if you hvae missed my reply. I tried your suggestion and get following error

[root@localhost root]# mii-tool -F 10baseT-FD eth0
SIOCGMIIPHY on 'eth0' failed: Bad address

How should I correct it?
 
  


Reply


Thread Tools Search this Thread
Search this Thread:

Advanced Search

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is Off
HTML code is Off



Similar Threads
Thread Thread Starter Forum Replies Last Post
How to set network card Speed/duplex in Vector Linux? si-diablo Linux - Networking 1 06-20-2005 04:46 PM
configure network card as gigabit full duplex geodo Linux - Networking 3 01-17-2005 05:20 AM
My sound card is not working at full duplex. mir_sheely Linux - Hardware 0 06-19-2004 06:00 AM
how to set half/full duplex on a lan card billy998168 Linux - General 8 03-19-2004 05:33 PM
Full duplex sound card tommylkc Linux - Hardware 1 06-28-2002 10:49 AM

LinuxQuestions.org > Forums > Linux Forums > Linux - Networking

All times are GMT -5. The time now is 02:26 PM.

Main Menu
Advertisement
My LQ
Write for LQ
LinuxQuestions.org is looking for people interested in writing Editorials, Articles, Reviews, and more. If you'd like to contribute content, let us know.
Main Menu
Syndicate
RSS1  Latest Threads
RSS1  LQ News
Twitter: @linuxquestions
Facebook: linuxquestions Google+: linuxquestions
Open Source Consulting | Domain Registration